Classe MUI Mailtext v3.2

La version 3.2 de la classe MUI Mailtext utilisée notamment dans Jabberwocky pour afficher les messages est disponible sur le site officiel.
A part le passage en open-source et des modifications pour le portage sous GCC et OS4 il n’y a pas de modification fonctionnelle particulière. Cette version est donc principalement intéressante pour les possesseurs d’OS4, ceux sous 68k peuvent rester sous 3.1 pour le moment.

A noter que l’auteur ne disposant pas de MorphOS, aucune version n’a pus être compilée, en revanche le code doit être relativement prêt à accueillir une version MorphOS, si quelqu’un se sent intéressé, n’hésitez pas à contacter l’auteur.

Page de téléchargement : MCC_Mailtext-3_2.lha sur sourceforge.net (AmigaOS4) [359 ko]

(10 commentaires)

Passer au formulaire de commentaire

    • Alex on 9 juin 2006 at 15 h 09 min
      Author

    En l’occurence quand dans la news je disais ‘nous’ c’était bien ‘xenic’ et moi donc si quelqu’un ici se sent d’attaque qu’il n’hésite à me contacter par mail.
    De plus l’archive présente sur le site n’est pas limitée à OS4 comme indiqué dans la news mais contient également la version pour ‘020.

    A noter pour finir qu’Olaf Peters n’est plus impliqué dans le développement de cette version donc inutile de l’embêter avec des bugs à propos de cette version.

    • henes on 9 juin 2006 at 15 h 13 min

    Dommage que le tout soit GPL car il est impossible de l’utiliser depuis un programme n’étant pas lui même GPL.
    La LGPL m’aurait semblé plus appropriée pour une telle bibliothèque partagée.

    • falcon1 on 9 juin 2006 at 17 h 52 min

    Effecivement, c’est TRES con….. 🙁

    d’ailleurs Alex avait-il pensé à cela ? ou bien a t -il choisi cette licence « comme ca » sans regarder quelles seraient les conséquences ?

    • Alex on 12 juin 2006 at 9 h 14 min
      Author

    Alex n’étant pas l’auteur original de Mailtext il n’a pas le pouvoir d’en choisir la license…
    J’ai simplement réalisé le passage des sources de SAS vers GCC et en même temps ajouté le support OS4 (au passage après ces remarques très intéressantes sur l’interprétation de la GPL et de son utilisation pour une librairie, toujours aucun volontaire pour la version MorphOS, tant pis les utilisateurs resteront avec la version 68k…)

    • henes on 13 juin 2006 at 19 h 53 min

    Bin… un programme nécessitant Mailtext.mcc > 19.8 devra obligatoirement être GPL alors bon… à la limite pour Jabberwocky qui l’est déjà.
    Si tu connais l’auteur original, tu n’as pas moyen de lui demander de changer la licence vers le LGPL avant qu’il ne soit vraiment trop tard?

    • Alex on 14 juin 2006 at 13 h 23 min
      Author

    Henes ton temps serait mieux utilisé à rajouter les quelques lignes de code qui vont bien pour avoir une version MorphOS de cette bibliothèque plutôt que de discerter sur l’interprétation de la license GPL et son utilisation dans ce cas…
    Au passage je rappelle qu’il n’y a pas de généralité à ce propos et que rien n’a été tranché *officiellement* (il y a juste des rumeurs qui courent un peu à la manière de légendes urbaines), cependant dans le cas particulier d’une classe MUI il me semble que le cas cité ici et en particulier le 2) s’applique complètement et serait tout à fait défendable.

    Au passage je voulais ajouter que Mailtext est en GPL sur sourceforge depuis 2001 et que jusque là persone n’avait trouvé à redire…

    • henes on 14 juin 2006 at 14 h 50 min

    Au contraire, la GPL parle explicitement de ce cas et la FAQ ne laisse aucun doute possible :
    http://www.gnu.org/licenses/gpl-faq.fr.html#IfLibraryIsGPL

    Je peux comprendre que cela ne t’intéresse pas plus que cela… mais ce n’est pas mon cas.
    Une bibliothèque GPL, je n’y touche pas et j’invite tout le monde a en faire autant.
    Dommage :-/

    • Alex on 14 juin 2006 at 16 h 10 min
      Author

    Je pense pas que la FSF ait pensé au cas AmigaOS lorsqu’elle parle des bibliothèques. Sinon c’est tout AOS (et MOS) (et tous les applications qui tournent sous ces environnements) qu’il faut mettre sous GPL car toutes les bibliothèques tournent dans le même espace d’adresse qui celui du système et de toutes les applications qui y tournent…
    De plus le cas ici est un peu particulier : la bibliothèque (Mailtext MCC) a été créée de manière évidente pour fonctionner avec MUI donc le fait de la mettre en GPL implique simplement qu’il est impossible de développer par dessus une classe MUI de plus haut niveau sans que son code soit lui aussi en GPL, c’est tout. Sinon cela voudrait dire que MUI devrait lui aussi passer en GPL non ?
    Enfin bon je considère le problème clos, je ne reviendrais plus dessus (ceci dit va faire un tour dans tes MP 😉

    • henes on 14 juin 2006 at 16 h 42 min

    La GPL comporte une exception concernant les OS. Ceux ci peuvent être GPL sans affecter leurs applis et inversement…
    Tu devrais relire le texte de la GPL 😉

    • Yomgui on 20 juin 2006 at 13 h 02 min

    Moi je suis d’accord avec Henes!

    /me s’en va discretement…

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!