Configuration de MOSnet

15 sujets de 1 à 15 (sur un total de 30)

  • 1
  • 2
  • pegasus

    • Messages : 60
    #3232

    J’utilise une Freebox connectée en Ethernet sur mon Peg1 avec Miami. Tout roule sans problème.

    J’ai voulu essayer MOSnet et jeté un coup d’oeil au read-me, j’ai essayé de le configurer mais il ne se passe rien.

    Je sollicite votre aide pour m’aider à le configurer !

    CptBlood

    • Messages : 253
    #61366

    Pegasus:

    apparement, personne ne veut t’aider.

    Je le ferais bien, mais je n’ai moi meme pas encore réussi a configure la bete.

    Cpt Blood

    slobman

    • Messages : 1010
    #61367

    Hip !!

    Ca pourrait aussi être « Ben, apparement, personne ne PEUT t’aider. ».

    Sinon, détaille un peu ton ancienne config sous miami… DHCP, ip fixe, passerelle ou non…

    Personnellement, j’attends une grosse maj de mon système pour faire un gros backup avant de faire quoique ce soit. Ca devrait arriver sous peu : mui4 beta + ambient sous peu, j’en profiterais pour tester mosnet, et là, on verra bien si je peut t’aider (ma config est à peu de chose près identique à la tienne : peg2 avec une ip fixe sur un routeur sur une freebox).

    !! qiH

    serge

    • Messages : 4408
    #61368

    salut Pegasus,

    -bien, pourquoi tu n’y arrives pas?

    On le saura bientot.

    -pourquoi personne d’autre a tenté de t’aider?

    A mon avis c’est par ce que le nombre d’utilisateurs de cette pile n’est pas encore bien important.

    Bon, disons que comme pour tous ou presque, miamiDX est ma pile actuelle. Ceci ne m’a pas empéché de tester MOSnet avec succes en ce qui concerne une simple connection avec un modem router.

    si tu es en DHCP, la config est ultra simple et se résume à ajouter une ligne dans un fichier de config. Je te dirai quelle ligne ce soir dés que je suis rentré.

    Si tu es en mode adresse IP fixe, il faut quelques paramettres de plus, mais y a rien de bien folichons.

    C’est une pile hyper simple a configurer, saufe que sans interface, c’est vrai que ce n’est pas toujours très clair.

    Aller, à ce soir.

    Edité:

    Ah, ah, ah,

    j’ai la réponse !

    Bien , commence par t’assruer que l’installe est propre telle qu’elle est décrite dans la doc soit :


    1. Extrais l’archive MOSNet où tu veux. (nous allons considérer que tu l’as fais dans SYS:).

    2. Ajoutes les lignes suivantes dans ton fichier S:User-Startup

    n’oublie pas de changer sys: si tu as décompréssé ton archive dans un autre endroit.

    Assign MOSNet: SYS:MOSNet

    Assign LIBS: MOSNet:Libs ADD

    Path MOSNet:C ADD

    3. dans le fichier Mosnet:db/interfaces tu changes la ligne eth0 de la facon suivante:

    eth0 DEV=DEVS:networks/via_rhinepci.device UNIT=0 IP=DHCP UP

    en théorie, les étapes 4 et 5 de la doc ne servent à rien si tu es en DHCP.

    6. Run MOSNet.

    pense a faire un reset pour que toutes les assign soient éffectives.

    redémarre et relance la pile

    6. Run MOSNet.

    Bon, au charbon NOW !

    RyZen Rulez 😉

    pegasus

    • Messages : 60
    #61369

    Merci Serge pour tes explications.

    J’essayes ce soir et je te tiens informé.

    IMM-Informatique

    • Messages : 314
    #61370

    Salut ;)

    J’utilise MOSNet depuis sa version 0.8 sans probleme pour le net avec ma livebox.

    Seul hic que je n’ai pas reussi a ameliorer, c’est les transferts FTP entre le pc et le peg, c’es horriblement lent !

    Par contre, inversement, avec les partages samba, c’est largement plus rapide qu’avec la config que j’avais sous miami.

    Je confirme la ligne a modifier dans le fichier mosnet:db/interfaces pour se connecter a un modem / routeur par exemple (sauf qu’ici je suis en ip fixe).

    TwinVNC est aussi plus rapide sous MOSNet que sous Miami.

    Il faudrait effectivement dans un avenir pas trop lointain une bonne gui pour faciliter la configuration.

    Je trouve que c’est du bon travail et que ca amene de bonnes perspectives pour l’avenir.

    A+ :)

    Faranheit

    pegasus

    • Messages : 60
    #61371

    Merci Serge.

    J’ai suivi tes conseils et ça roule. Merci pour ton aide précieuse.

    gti

    • Messages : 326
    #61372

    Pour l’installer, j’ai aussi changé une ligne de la config car il cherchait

    PROGDIR:SysLog je l’ai remplacé par MOSNET: MNSysLog.

    Sinon c’est facile à utiliser comme pile, elle est intégrée parfiatement à MORPHOS. Elle ne coupe pas sur mon poste comme miami le faisait de temps en temps. Au niveau de la rapidité de surf sur internet je n’est pas mesuré de différence avec MIAMI.

    Je felicite l’auteur pour ce travail formidable qui comble une deux plus grosses lacunes de MORPHOS pour moi. Il ne reste plus qu’à avoir un browser compatible avec l’internet d’aujourd’hui ou une évolution véritable de Ibrowse.

    A+

    GTI

    lugduweb

    • Messages : 999
    #61373

    Bon !

    Va falloir que j’essaye ca moi aussi ;-)

    Merci Serge pour ce mini-tutoriel (qui finira peut être dans le livre du Pegasos ;-) )

    IMM-Informatique

    • Messages : 314
    #61374

    Salut ;)

    Je conseille quand meme pour ceux qui veulent utiliser MOSNet pour des transferts samba (entre un pc et un peg) de rajouter les 2 lignes suivantes dans le fichier MOSNet:db/general.config

    TCP_SendSpace=16384

    TCP_RecvSpace=16384

    Ca ameliore nettement les taux de transferts sur le reseau local !

    Un grand MERCI a Fab pour toutes ses aides precieuses !!

    S’il n’existait pas, il faudrait l’inventer, dommage qu’on ne puisse pas le cloner !

    Faranheit

    amigafil

    • Messages : 160
    #61375

    Hello,

    Je suis avec un routeur, son adresse est 192.168.1.1

    le pegasos 192.168.1.11 et le pc 192.168.1.10, ces adresses sont celles que j’utilise dans miamidx. Question où dois je coder ces adresses dans mosnet ?

    Merci d’avance.

    MorphBook MOS 3.9 et Pegasos II MOS 3.9

    IMM-Informatique

    • Messages : 314
    #61376

    Salut Amigafil ;)

    Il te faut editer 3 fichiers dans le repertoire MOSNET:db/

    1) ‘interfaces’

    eth0 DEV=DEVS:networks/via_rhinepci.device UNIT=0 IP=192.168.1.11

    NETMASK=255.255.255.0 UP

    2) ‘hosts’

    127.0.0.1 localhost

    192.168.1.1 Routeur

    192.168.1.10 PC

    192.168.1.11 Peg

    3) ‘resolv.conf’

    domain TON_NOM_DE_DOMAINE

    nameserver 192.168.1.1

    Avec ca, tout devrait aller.

    Faranheit

    Fab1

    • Messages : 1578
    #61377

    Il y a la définition de la passerelle aussi à ne pas oublier. Je n’utilise pas MOSNET cela dit, donc ce que je dis est à vérifier.

    On trouve deux endroits où la passerelle intervient, pas pratique…

    On peut faire :

    db/static-route :

    DEFAULT GATEWAY 192.168.1.1

    et/ou ?

    c/startnet :

    .def gateway « 192.168.1.1 » (je me demande si ce script est pas obsolète)

    IMM-Informatique

    • Messages : 314
    #61378

    Salut ;)

    Tout a fait exact Fab pour le ‘static-routes’ que j’avais oublie de preciser !

    A+ ;)

    Faranheit

    ACE

    • Messages : 2364
    #61379

    au fait comment marche le ssl sous mosnet ?

    sinon cette pile est stable et rapide

    Et hop une petite ligue des champions pour le fc sion à Swos 🙂 embalé c'est pesé elle est pas belle la vie !

15 sujets de 1 à 15 (sur un total de 30)

  • 1
  • 2
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général Configuration de MOSnet

Do NOT follow this link or you will be banned from the site!