Lecteur disquette externe : « read error »

15 sujets de 1 à 15 (sur un total de 15)

  • Aurelien

    • Messages : 261
    #355296

    Hello,

    En testant un lecteur RF332C, il me fait un bruit assez bizarre en continue, la disquette se monte quand même sur l’écran, mais affiche « bad disk ».

    Je précise que cette même disquette fonctionne parfaitement, que ça soit sur le lecteur interne ou sur un autre lecteur externe 🙂

    En ouvrant le lecteur, j’ai l’impression que la disquette n’est pas entrainée, elle ne tourne pas.

    Quel pourrait être le problème ? Courroie qui déconne ? (j’ai démonté le lecteur et elle a pas l’air pourrie pourtant) Moteur d’entrainement HS ? Autre ?

    Merci pour vos pistes !

    Giants

    • Messages : 3474
    #355299

    Une piste ?
    http://amigaga.chez-alice.fr/classic/bidouilles/disquette/rf332c.htm

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    Aurelien

    • Messages : 261
    #355301

    Merci Giants !

    Mon 1er réflexe fut de penser à la courroie, mais j’avais l’impression que le moteur ne tournait même pas … sans compter ce bruit discret mais bizarre. Bon ça coûte pas grand chose de la remplacer de toute manière, et puis c’est à peu près la seule chose que je devrais être capable de faire 😀

    Aurelien

    • Messages : 261
    #355376

    Bon j’ai changé la courroie tout à l’heure, en effet c’était nécessaire car l’ancienne n’avait plus aucune élasticité, j’ai tiré un peu dessus elle s’est pété direct.

    Par contre et malheureusement, ça n’a pas résolu le problème de « bad disk » …

    Je me demande, est-ce que ça pourrait venir des têtes de lectures sales ? Si oui je passerai un coup de coton tige avec un peu d’alcool dessus (il me semble que c’est ainsi qu’il faut procéder).

    Aurelien

    • Messages : 261
    #355387

    Suite de mes aventures … Après un nettoyage à l’alcool des têtes de lecture et surtout après avoir repositionné cette saleté de ressort qui maintient la tête de lecture vers le bas (que j’avais mal remonté comme un boulet ..), j’ai enfin les disquettes qui se chargent ! Fini donc le « bad disk » que les Amiga m’affichaient à chaque fois 🙂

    Mais ça serait trop simple comme ça … et maintenant lorsque le lecteur charge le contenu, il me sort un « read error » …

    J’ai bien testé les disquettes avec un autre lecteur externe, ça passe niquel.

    Une idée ? Est-ce que je devrais insister un peu plus sur le nettoyage des têtes ?

    Aurelien

    • Messages : 261
    #355415

    En regardant un peu plus en détail sur le web, j’ai l’impression que le soucis pourrait être l’alignement des têtes de lecture. Pourtant le « read error » n’arrive que vers la lecture des blocs 900 et+ de mémoire (et à chaque cancel il me fait une erreur sur un bloc suivant), est-ce que si l’alignement déconnait il ne devrait pas foirer la lecture dès la piste 0 ?

    Giants

    • Messages : 3474
    #355431

    Perso j’aurai déjà regardé la vitesse de rotation du moteur.
    Des têtes qui se désalignent je n’en ai pas vue tant que ça.
    Des moteurs fatigués car trop vieux, j’en ai vue des masses.

    Cherche un outils pour afficher la vitesse de rotation et balade toi sur l’ensemble des tracks.
    Si tu n’es pas dans la limite acceptable, ne cherche pas plus loin.

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    Aurelien

    • Messages : 261
    #355437

    Ok merci du conseil je vais essayer ça 🙂

    To be continued …

    Giants

    • Messages : 3474
    #355448

    Il est facile d’enlever de l’équation le désalignement des têtes.
    Pour cela :
    Tu prends une disquettes qui te fais un ‘read error’.
    Tu la formate.
    Tu enregistre des données dessus, le but étant de la remplir au mieux.
    Tu test la lecture de ses données/fichier a travers un soft de test ou à la main.

    Si tu n’a eu aucun problème au formatage et à la lecture de l’ensemble de tes données et si c’est la même disquettes qui te disait Read error, alors c’est qu’effectivement tes têtes sont désalignées.

    Si tu n’es pas arrivé à formater c’est que tu as un problème H/W sur ton lecteur (mécanique ou électronique voir électrique) OU tout simplement que ta disquette n’est plus bonne (composant magnétique de la disquette ne joue plus sont rôle)
    Si tu es arrivé à formater et à écrire mais que tu as des erreurs de lecture, c’est que ta disquette n’est plus bonne (même raison qu’au dessus).

    Des têtes désalignés n’empêche en rien ton lecteur de fonctionner, sauf que… les disquettes que tu pourras utilisé ne pourront l’être que chez toi. (vue qu’elle sont désalignées, je schématise l’idée)

    Je ne sais pas si c’est clair ?

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    Aurelien

    • Messages : 261
    #355454

    C’est clair merci !

    Je vais donc dans un premier temps faire ce test de formatage avec le lecteur incriminé histoire de bien cibler la cause 🙂

    Giants

    • Messages : 3474
    #355462

    Oui ! Il faut procéder comme ça.
    Lister ce qui peut poser le/s soucis.
    Éliminer un à un les SPOF

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    Aurelien

    • Messages : 261
    #355467

    Bon, test effectué et verdict : les disquettes fonctionnent très bien dès lors qu’elles sont créées avec le lecteur externe, et deviennent donc illisibles avec les autres.

    Donc c’est bien me semble t-il un problème de têtes désalignées 🙁

    Je vais donc chercher maintenant comment solutionner ce problème !

    Giants

    • Messages : 3474
    #355469

    Yep !
    Suivant ce que tu vient de dire au dessus, oui.
    à savoir que j’imagine que tu as bien tester TOUTE la surface de la disquette et pas que la lecture d’un fichier.

    Têtes désalignées c’est chiant à régler quand on ne connait pas et que l’on a pas le matos.
    Il a bien des ‘astuces’ mais cela reste des tips.

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    Aurelien

    • Messages : 261
    #355470

    Yep !
    Suivant ce que tu vient de dire au dessus, oui.
    à savoir que j’imagine que tu as bien tester TOUTE la surface de la disquette et pas que la lecture d’un fichier.

    Alors en fait j’ai même pas eu besoin de tout tester puisque :
    – avant la copie, impossible de lire la disquette sur le lecteur externe
    – après avoir copié du lecteur interne vers le lecteur externe une disquette test vers la disquette citée au dessus (avec xcopie), elle passe maintenant niquel sur le lecteur externe mais plus sur le lecteur interne.

    Je sais pas si c’est clair 🙂

    Bref pour moi y’a pas photo.

    Oui je me doute que le réalignement va pas être simple, je vais voir ce que je peux faire et si ça me semble trop chaud, je demanderai de l’aide ici si quelqu’un a le bon matos !

    Encore merci pour ton aide 🙂

    Giants

    • Messages : 3474
    #355473

    Si si c’est clair.
    Ca ressemble comme deux goutes d’eau à un désalignement.

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

15 sujets de 1 à 15 (sur un total de 15)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Matériel Lecteur disquette externe : « read error »

Do NOT follow this link or you will be banned from the site!