[résolu] Lancer une jeu WHDLoad depuis la Startup-Sequence

6 sujets de 1 à 6 (sur un total de 6)

  • thyphoon

    • Messages : 35
    #6196

    ça fait quelques années que je n’avais pas jouer avec AmigaOs…et j’ai vraiment du mal:sweat: .

    je cherche a lancer a la fin du startup-sequence un jeu whdload

    dans mon startup-sequence j’ai rajouter

    execute startgame

    startgame est un fichier qui contient ce code

    Games:hybris

    Whdload slave hybris.slave quitkey 89 preload nocache pam nommu

    et ça ne fonctionne pas. pourtant si je tape le contenu de mon fichier startgame directement dans l shell/cli ça se lance sans problem …

    Quelqu’ un pourrait il m’aider ? :'(

    merci d’avance

    neya

    • Messages : 75
    #102275

    Essaies comme ça :

    cd games:hybris

    sys:c/whdload hybris.slave quitkey=$89 preload nocache pam nommu

    thyphoon

    • Messages : 35
    #102276

    y a rien a faire j’ai toujours un message d’erreur

    « :Unknow Command

    failedreturn code 10″

    et si je retire la première ligne j’optiens ce message d’erreur

    « 

    wrong number of arguments

    sys:c/whdload failed returncode 10

    « 

    pourtant la commande cd marche bien et si je tape directement dans le cli apres le message d’erreur ça fonctionne…

    J’ai passé la une partie de la nuit sur ce problème…moi qui pensait que ça me prendrait pas trop longtemps lollllllllll

    Une autre idée ?

    dlfrsilver

    • Messages : 512
    #102277

    cd games:hybris

    sys:c/whdload Games:byris/hybris.slave quitkey=$89 preload nocache pam nommu

    Le fichier slave n’avait pas son dossier d’indiqué.

    thyphoon

    • Messages : 35
    #102278

    C’est bon j’ai trouvé finalement…

    comme jai voulu tester en utilisant winuae j’ai voulu me simplifier la vue en editant le startup-sequence avec l’editeur de text window…resultat ça me rajoutait un caractère ^M en fin de ligne….et donc provoquait l’erreur.

    Merci a vous en tout cas de vous être pencher sur ma question …

    neya

    • Messages : 75
    #102279

    dlfrsilver a écrit :

    Le fichier slave n’avait pas son dossier d’indiqué.

    Le chemin du dossier est indiqué dans la ligne précédente par la commande « cd ». WHDload sait donc où trouver le slave.

6 sujets de 1 à 6 (sur un total de 6)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Développement [résolu] Lancer une jeu WHDLoad depuis la Startup-Sequence

Do NOT follow this link or you will be banned from the site!