[Poisson d’avril] Rototo Studio revient en force !

On pensait que son Pegasos prenait la poussière dans un coin de son bureau, mais on s’était trompé. Et c’est via son compte Twitter et sa page Facebook que l’on a appris que Olivier « StAn » Fabre revenait en effet à ses premières amours via un partenariat étonnant avec un grand nom de l’Amiga, à savoir Cloanto.

Ces derniers ont décidé de se lancer dans l’édition de jeux vidéo et ont donc proposé à notre StAn national de faire une version PSN/XBLA de son jeu Smart Lines, un magnifique Puissance 4 en 3D. Il sera vendu à un petit prix et devrait être disponible cet été sur les plateformes de téléchargement des deux consoles HD du moment.

Mais ce n’est pas tout puisqu’à cette occasion, une version MorphOS définitive (le jeu n’est jamais officiellement sorti sur MorphOS) et une version AmigaOS 4 seront également éditées par Cloanto.

Le jeu devrait être légèrement modifié dans sa version console tandis que la version MorphOS/AmigaOS sera quasi identique aux captures d’écran disponible dans « lire la suite… ».

Voilà un retour qui fait plaisir ! Toute l’équipe d’Amiga Impact souhaite une grande réussite à cette entreprise et a hâte de pouvoir mettre la main sur cette nouvelle mouture de Smart Lines !

Site internet : http://www.rototostudio.com

Source : Le Twitter et la page Facebook de Rototo Studio

(16 commentaires)

Passer au formulaire de commentaire

  1. Zut, je voulais être le premier a en faire un, c’est raté.
    On verra l’an prochain ^^

    • BatteMan on 1 avril 2011 at 8 h 40 min
      Author

    Le premier a en faire une news ? Je comprends, c’est tellement chouette ce retour de Smart Lines !


    /me est tout foufou à l’idée de retrouver Smart Lines sur sa PS3 notamment ! Bah oui, /me a déjà une version MorphOS sur son HD ! 😮

    • serge on 1 avril 2011 at 9 h 00 min

    Quelle magnifique nouvelle. Un jeu en commun avec des consoles et nos Amiga-NG !!! c’était inespéré.
    Les graphismes sont assez colorés et jolis.
    Certains tableaux donnent vraiment l’impression d’une ambiance sous-marine.
    Par contre, les plateaux dans l’eau, bah c’est pas trop conseillé car le bois ça gonfle 😀

    Sinon, rototo studio, ça sonne bien italien. Je n’avais jamais fais attention, mais cloanto sonne aussi très italien.
    Ils sont forts ces italiens 😉

    • AmiDARK on 1 avril 2011 at 13 h 07 min

    +1

    • stan on 1 avril 2011 at 14 h 20 min

    Je… suis vraiment désappointé que tu n’aies pas attendu demain pour poster ça, Battou !

    • BatteMan on 1 avril 2011 at 16 h 23 min
      Author

    stan : Je la reposterai/remonterai demain histoire de lever toute ambiguïté !


    /me n’a pas réussi à faire tourner sa version de Smart Lines sous MorphOS 2.x (PowerMac).

    • stan on 1 avril 2011 at 17 h 55 min

    Bon, je te pardonne, alors :).

    MorphOS 2 est compatible avec le 1 ? (Non mais ouais, je demande vraiment ça, pardon si ça vous fait penser à ces pratiques éhontées que l’on retrouve parfois chez certains concurrents américains.)

    • bigdan on 1 avril 2011 at 18 h 19 min

    stan : oui… je reteste ce week-end avec ma version « registred » de Smartlines (qui voisine BoXiKon sur mon Peg1) !

    A quand la version Wiiiii ?

  2. Poisson d’Avril

    • BatteMan on 1 avril 2011 at 21 h 34 min
      Author

    stan : Oui, MorphOS 2 est bien compatible MorphOS 1, pas de soucis là dessus. Le truc avec ma version de Smart Lines, c’est que c’est celle qui traîne sur mon HD depuis 2005 (date de mon achat de la version Mac que je ne dois même plus avoir… argh !) et j’ai changé le système et tout le tsouintsouin, donc il doit me manquer des libs/fonts/trucs du genre.

    Je reteste ce soir avec Snoopium lancé 😉

    [EDIT]
    Bon, ben je n’ai pas réussi à le lancer… J’ai maté dans Snoopium et je n’ai rien trouvé d’intéressant. Par contre dans le log debug de MorphOS, j’ai trouvé ça :

    ## erreur SDL_SetVideoMode
    ## Couldn’t open window: Invalid bits per pixel (range is {8…32})
    Display_Exit()
    before SDL_QuitSubSystem(SDL_INIT_VIDEO)
    end Display_Exit()
    # Check triggered abortion in file Game.c, line 253 : !Display_Init().

    et ça à la fin, mais je ne pense pas que ce soit « utile » :

    # Check triggered abortion in file Settings.c, line 1271 : !line->value.
    # Check triggered abortion in file Settings.c, line 1276 : !ok && line.

    J’ai tenté en mettant une vieille powersdl 12 mais ça n’a pas été mieux… J’suis dépité…
    [/EDIT]


    /me a voulu montrer Shou-kun (mince, je ne sais plus comment cela s’orthographie mais je dois pas en être loin… enfin bref, c’est le premier nom de Smart Lines) à Corto lors de l’Amigâteries, mais il n’a pas réussi à le lancer…

    • stan on 2 avril 2011 at 10 h 57 min

    QUEL MAGNIFIQUE BUG REPORT ! Bon, je pense pas que ce soit un bug. Compare ton fichier de config (Data/settings.cfg) avec http://pastebin.com/kNntx6DL , notamment screenDepth et displayModeId au début.

    • henes on 2 avril 2011 at 11 h 42 min

    @batt

    Je crois que, d’après itix, SDL ne supporte pas certains formats de pixel… et peut-être qu’il a cassé certaines choses…

    Smartlines démarre bien ici en BGRA32 (voir SYS:Utilities/GraphicsBoards pour la liste des modes disponibles sur ta configuration).

    Un peu au hasard, tu pourrais essayer d’anciens psdl, changer de profondeur d’écran (15/16/24/32bpp) ou carrément essayer avec une carte graphique différente…

    • BatteMan on 2 avril 2011 at 14 h 42 min
      Author

    Format de pixels supportés ici : LUT8, RGB15PC, RGB16PC et BGRA32 (c’est une Radeon 9000 Pro).

    Mon fichier de prefs est identique à celui de Stanou et j’ai essayé de modifier la profondeur de mon affichage d’Ambient, sans plus de succès…

    Bon, ben je crois que je l’ai dans l’os… Désolé pour le dérangement.


    /me espérait que ce qu’il avait « donné » suffirait, mais apparemment, c’était un peu trop succinct…

    • stan on 2 avril 2011 at 20 h 56 min

    Il semblerait que SDL_GetVideoInfo() retourne une valeur de BitsPerPixel (info->vfmt->BitsPerPixel) inadéquate. À première vue, ça ressemble à un bug de la (Power)SDL.

    Edit: le modeID est inutilisé dans la version SDL donc en fait ça sert à rien de le changer.
    Edit2: et screenDepth aussi. Buh.

    • henes on 3 avril 2011 at 1 h 14 min

    Format de pixels supportés ici : LUT8, RGB15PC, RGB16PC et BGRA32 (c’est une Radeon 9000 Pro).

    Il devrait y avoir une ligne « Formats de pixel supportés » et une autre « … avec support de la 3D ». Es-tu certain d’avoir posté la bonne ? La présence du LUT8 me fait en douter…

    • BatteMan on 4 avril 2011 at 14 h 40 min
      Author

    henes : La ligne « … avec support de la 3D », que j’ai vue après, comprend les mêmes formats sauf le LUT8. Bien vu sieur henes !


    /me se demande comment il va réussir à lancer SL sur son MOS 2.7 PowerMacïsé…

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!