| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site
   · Confidentialité



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

  · Inscription
  · Mot de passe oublié



 | En ligne

Aucun membre ne se trouve actuellement sur le site






 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Forum

/   Forums d'Amiga Impact
   /  Répondre à : Programmation ASM sur Amiga

Accueil Forums AmigaOS, MorphOS et AROS Développement Programmation ASM sur Amiga Répondre à : Programmation ASM sur Amiga

#222817 Répondre à : Programmation ASM sur Amiga
 le 08/12/2014 à 20:07


huggyone76

Participant
  • Messages : 1977

Alors, premiers « tests » :

* Le scrolling différentiel du décor, ça marche au poil !

* Scrolling + sprite, ça commence à déconner… (barre rouge en haut dans la bande noire, barre cyan en bas qui est au niveau de l’herbe et qu’on ne voit que dans les bandes noires et un « glitch » cyan dans l’herbe), la bête va vers la droite au pas de course… 😉

* Scrolling + sprite + joystick, ça ne change « rien » si ce n’est qu’on peut « accélérer » vers la droite… mais pas aller à gauche ou quoi que ce soit d’autre, la bête avance toujours toute seule vers la droite (et toujours les bugs de la seconde partie)

* Avec l’ajout des barrières, toujours les mêmes bugs graphiques et ajout de magnifiques barres vertes sur toute la hauteur de l’écran et d’une barre jaune en bas (sous la cyan, faut suivre ! 😉 ). On peut diriger la bête ! Mais si on a le malheur de s’arrêter au « mauvais » moment, le décor clignote, saute… bref, c’est l’horreur ! LOL ! 🙂

* Ajout du son… euh… pas de son, pas de musique, rien. Mon STE en reste muet…

Bon, je ne vais pas te jeter la pierre (Pierre ?), et je serai incapable d’en faire la moitié en assembleur… 😉 Mais je crois que c’est « pas ça » mon bon Lexomil pour le faire fonctionner sur un VRAI Atari STE. Mais bon, je ne doute pas que tu vas trouver !

Edit : Ne pas se fier à la bande sombre au niveau de la bête, c’est simplement une photo d’un écran tube cathodique, un vrai ! 😉

Edit 2 : J’ai testé aussi bien sous TOS 1.62 que sous 2.06 et le tout assemblé sous Devpac 3.0

fichiers attachés:
  1. STOB-Atari.jpg

A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+BPPC/060+BVision - A2000 + ROMs 3.1 + IDE4 - Mac Mini 1.42 sous MOS - Just CPC 128k - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 1Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

                   
Derniers sujetsFraîcheur
 · [Vente] jeux Amiga Atari PC sega Nintendo petit prix il y a 34 minutes
 · [VENDS] A1200 il y a 1 heure et 22 minutes
 · [recherche] Alim Amiga 2000 il y a 2 heures et 9 minutes
 · [Vente] MOGA neuf et en boîte il y a 4 heures et 12 minutes
 · [Vente] consoles game boy et accessoires vintage + switch il y a 4 heures et 16 minutes
 · [Vente] très gros lot de jeux PS1 originaux complet 100€ il y a 4 heures et 31 minutes
 · Le fil des vidéos il y a 4 heures et 36 minutes
 · Mod player en JavaScript il y a 4 heures et 55 minutes
 · Infos sur la Vampire (suite) il y a 6 heures et 58 minutes
 · PS1 classic avec 20 jeux il y a 7 heures et 15 minutes





RechercheFraîcheur


Copyright © 2004-2018 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!