Datatypes LHA (et pas que)

13 sujets de 1 à 13 (sur un total de 13)

  • Thor1230

    • Messages : 1011
    #359089

    Bonjour a tous.

    J’ai un soucis de datatypes. Pour qu’un datatype marche, il faut mettre 2 fichiers dans le systeme.
    Il y a un fichier Classes/Datatypes et un autre a mettre dans DEVS/Datatypes

    Le but serait que je puisse double cliquer sur un .lha et que ca m’ouvre un logiciel de décompression plutôt qu’une fenêtre dans laquelle je dois écrire LHA x nomdufichier.lha ram: par exemple.

    Mon logiciel c’est MiraWizARC11b.lha et j’aimerais bien l’associer avec le lha.

    Mille merci

    Amiga + CPC + PC = La meme passion !

    CrashMidnick

    • Messages : 2275
    #359091

    De mémoire il faut que tu aies une icône de type def_lha et/ou def_lharc dans sys:prefs/env-archive/sys

    Tu fais clique droit sur l’icône, information, onglet icône et tu changes le programme par ce que tu veux.

    Tu reboot.

    EndCLI >NIL:

    Thor1230

    • Messages : 1011
    #359093

    Merci CrashMidnick

    Je ne pense pas avoir cette icone

    Je vais check sur morphos dans la semaine si jamais il y en a une.

    Amiga + CPC + PC = La meme passion !

    CrashMidnick

    • Messages : 2275
    #359094

    Tu en prends une déjà présente dans ce dossier sys, peu importe laquelle et tu la dupliques puis tu l’adaptes (nom + programme). Tu personnaliseras plus tard 😉

    EndCLI >NIL:

    Thor1230

    • Messages : 1011
    #359104

    Pas bete 🙂

    Merci je n’y avais pas pensé.

    Amiga + CPC + PC = La meme passion !

    __sam__

    • Messages : 2863
    #359105

    Oui ca n’a rien à voir avec les datatypes. Les datatypes c’est juste pour pouvoir afficher toute sortes d’audio/vidéo/texte (en gros) dans n’importe quel programme qui connait l’api datatype (par exemple Multiview).

    Toi ce que tu veux c’est associer un programme par défaut à une extension. Dans amigaos le programme à utiliser pour ouvrir un fichier donné (ex: toto) est indiqué dans le fichier icone de ce fichier (ex: toto.info). Or si tu n’as pas de *.info pour le fichier, le wb va te demande de compléter la ligne de cmd. C’est ce que tu observes.

    Jusqu’à l’os 3.x de base on ne peut pas aller plus loin. Mais l’outil newicons permet d’associer une icone par défaut et donc un outil par défaut pour les ouvrir. Ca marche à partir de l’os 2.0

    Après à partir de l’OS 3.5 (donc OS3.9 mais aussi 3.1.4 qui est apparu après) la notion prefs/deficons est devenue standard.

    Donc la réponse dépend de ton os amiga en fait, et ca tu ne nous l’indiques pas.

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    Thor1230

    • Messages : 1011
    #359106

    Merci beaucoup a vous.

    Ca reste en effet une enorme lacune que j’ai sur amiga.

    Donc j’ai le wb 3.1.4.1 avec BetterWb 1.3, la rom 3.1.4.

    J’arrive pas a justement associer des fichiers a des programmes.

    Je vais voir ca, avant d’aller me coucher.

    L’autre chose que j’ai du mal a faire, c’est de faire des fichiers batch. Genre comme sous msdos… un fichier.bat je devrais peut etre faire un topic pour ca.

    Amiga + CPC + PC = La meme passion !

    CrashMidnick

    • Messages : 2275
    #359107

    @__sam__

    Effectivement tu as raison, faut dire que j’utilise systématiquement les deficons car je ne suis que sous 3.1 et supérieur sur mes machines donc je ne pense pas à le préciser, c’est l’un des premiers ajouts que je fais au WB 3.1, c’est machinal 🙂
    En plus je le fais à la main, je ne passe plus par l’archive de newicons.

    EndCLI >NIL:

    Thor1230

    • Messages : 1011
    #359108

    Nous utilisons tous nos amiga d’une maniere differente :p

    Amiga + CPC + PC = La meme passion !

    __sam__

    • Messages : 2863
    #359109

    Pour les fichiers de script (protect +s) il y avait une documentation dans les manuels de l’amiga 1.3.

    Si tu sais lire l’allemand:
    https://archive.org/details/amiga-dos-1.3-benutzerhandbuch

    Sinon à défaut:
    https://archive.org/details/Commodore_AmigaDOS_V1.3_Enhancer_Software_1987_Commodore/page/n13/mode/2up

    Ou mieux encore:

    Cliquer pour accéder à amigados_manuels.pdf

    [EDIT] Grouph wordpress a l’air de vouloir inliner le lien précédent (pdf) et échoue lamentablement. Voici le lien « tinyurl »ifié: https://tinyurl.com/unyxb9rr

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    Thor1230

    • Messages : 1011
    #359131

    J’ai fini d’installer newicons 46 et j’ai installé classact 2 démo.

    Je suis bien allé dans sys:prefs/env-archive/sys et j’ai bien vu et édité def_lha

    J’ai modifié l’icone, et quand je clique dessus ça m’ouvre mon logiciel donc sys:Logiciels/MiraWizARC/WizARC

    Par contre quand je clique sur un .lha ça fait comme avant ( vu qu’ils n’ont pas d’icones)
    Je devrais peut être faire une autre manip.

    Vu que cela ne marche pas, j’ai copié mon WizARC dans c: et j’ai modifié le fichier def_lha

    Je n’ai toujours pas d’icône qui s’affiche pour mes lha, et vu qu’il n’y a pas d’icône… Ça ne marche pas.

    La je suis perdu.

    Merci

    Amiga + CPC + PC = La meme passion !

    CrashMidnick

    • Messages : 2275
    #359143

    N’oublie pas def_lharc comme dit précédemment.

    Un reboot est nécessaire aussi.

    EndCLI >NIL:

    Thor1230

    • Messages : 1011
    #359155

    Ah je n’ai pas bidouillé def_lharc car je n’ai pas d’archives en ce format, juste lha.
    Et j’ai fait des reboot a chaque modif.

    Je vais quand même tester des fois que :p

    Amiga + CPC + PC = La meme passion !

13 sujets de 1 à 13 (sur un total de 13)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général Datatypes LHA (et pas que)

Amiga Impact