Fuhquake pour MorphOS disponible

Mark ‘BigFoot’ Olsen, le grand amateur de Quake, vient de mettre à disposition son port du moteur Fuhquake. Ce moteur, pour ceux qui ne le savent pas, est un moteur au rendu graphique très amélioré.

Une occasion de ressortir cette bonne vieille brouette.

Bien évidemment, il nécessite les datas originaux de Quake, premier du nom.
Les sources sont également disponibles.

Vous pouvez également admirer quelques screenshots sur cette page (après quelques réglages).

Télécharger :

25 Commentaires

Passer au formulaire de commentaire

    • fenrix sur 14 février 2006 à 22 h 34 min

    La vieille brouette, elle va vite!

    • BatteMan sur 14 février 2006 à 23 h 46 min

    En plus, la brouette est jolie !


    /me préfère Quake aux autres cakes, mais préfèrerait quand même un bon Doom.

    • crisot sur 14 février 2006 à 23 h 52 min

    Quake 1, c’est LE quake. Meme si Q2 à un excellent solo.

    • Sergio sur 15 février 2006 à 0 h 11 min

    Euh, je suis pas un pro de quake, je lance fuhquake sans options et j’arrive a la console ou il me lance quelques « Could not load XXX », puis pas de menu. Quoi qu’y faut faire?

    • crisot sur 15 février 2006 à 0 h 22 min

    Tu as bien, dans le repertoire de quake, ceci?

    quake/id1/pak0.pak quake/id1/pak1.pak , fuhquake étant dans quake/ ?

    EDIT: Oula j’ai dis une bétise, fuhquake il est déjà pas mal élaboré, il a sans doute besoin de 2 ou 3 autres datas.

    • thefab sur 15 février 2006 à 8 h 51 min
      Auteur

    moi aussi j’arrive sur la console, mais en appuyant sur ‘esc’ tu arrives sur le menu principal.

    hum, cela dit je n’ai pas de « could not load truc »

    avec l’exe tu un répertoire fuhquake qui contient un pak0.pak, tu as bien copié ce dossier dans le répertoire de quake?

    • Sergio sur 15 février 2006 à 9 h 42 min

    Oui j’ai bien pak0.pak, pas de pak1.pak mais pour la demo ca devrait le faire.
    Selon la doc sur le site de fuhquake ca devrait suffire.
    Je vais essayer le coup de ESC et si ca marche pas je vous raconte en detaille ce qu’il ne peut pas charger 😉

  1. ça tourne bien, et c’est beau pour du Quake. Je l’avais jamais vu comme ça.

    @BatteMan : alors le pack de textures hires ? ça donne quoi?

    • thefab sur 15 février 2006 à 9 h 56 min
      Auteur

    ici le pack de textures bug à fond (celui de 50 et celui de 200 Mo)

    • Screetch sur 15 février 2006 à 10 h 01 min

    Il ne veut pas me le lancer en mode GL :

    Error : Unable to initialize GL context

    J’ai pourtant l’update 3D… Dans la doc, ils parlent d’une version récente, il y en a eu d’autres depuis la première release ? Cela passe sur une Voodoo 3 ?

    • Daff sur 15 février 2006 à 10 h 24 min

    Si tu as une Voodoo 3 tape dans un shell :

    fuhquake-gl -depth 16 -gamma 0.5

    …la Voodoo 3 ne pouvant pas faire de 3D en 24/32 bits.

    Tu peux aussi monter la résolution avec -width et -height dans le genre :

    fuhquake-gl -depth 16 -gamma 0.5 -width 800 -height 600

    Par contre, je cherche comment sauver les prefs : à chaque fois que je lance le jeu, il faut de nouveau refaire la configuration des touches, la vitesse de la souris, etc.

    • BatteMan sur 15 février 2006 à 12 h 19 min

    thefab : Qu’est-ce que tu appelles « bugger » ?
    Ici, ça fonctionne, c’est très joli, mais alors la fluidité en prend un coup (avec le pack de 200 Mo).

    Je récupère le pack de 50 Mo pour voir.


    /me ne comprend pas ce qui buggue.

    • thefab sur 15 février 2006 à 12 h 58 min
      Auteur

    @Daff:

    pour la config, une fois que tu as réglé tous tes paramètres, tu ouvres une console et tu fais cfg_save nom_du_fichier, puis quand tu relances fuhquake, tu ouvres une console et tu saisis cfg_load nom_du_fichier et voila.

    @BatteMan:

    ben ça bug quoi, je me téléporte, je bouge un peu, et la les textures deviennent toutes trashées, y compris les menus.

    • fenrix sur 15 février 2006 à 13 h 37 min

    ici no problemo
    j’ai téléchargé le pack de textures de 50 Mo hier soir et ça tourne bien

    • Sergio sur 15 février 2006 à 13 h 55 min

    Il y a quelqu’un qui fait tourner ca sur Peg1? Ca rame?

    • fenrix sur 15 février 2006 à 16 h 37 min

    chez moi c’est sur Peg 1
    Données normale, ça booste
    Textures pack de 50 Mo, ça va

    • Daff sur 16 février 2006 à 10 h 07 min

    Pour les éclairages colorisés, n’oubliez pas de télécharger http://www.fuhquake.net/files/extras/fuhquake-lits.rar et de mettre tous ça dans Fuhquake/qw/lits/

    • thefab sur 16 février 2006 à 16 h 13 min
      Auteur

    tiens, marrant cette dernière archive me fait planter fuhquake

    • BatteMan sur 16 février 2006 à 19 h 51 min

    thefab : Désolé de dire ça, mais ça marche ici © & ®…


    /me est désolé pour thefab.

    • serge sur 16 février 2006 à 21 h 04 min

    je viens tout juste de l’essayer et je suis tombé sur le c*l.

    C’est vraiment beau.
    J’aime le logo spécial MOS de quake 😉

    Sinon, savez vous comment se procurer les textures high res?
    Merci

  2. @serge:

    Sinon, savez vous comment se procurer les textures high res?

    Hé bien c’est un petit peu le sujet de cette discussion non 🙂
    il suffit de lire le readme je cite:

    For more eyecandy, redrawn highres textures can be downloaded from
    http://facelift.quakedev.com/

    clic clic clic textures are there 🙂

    • Sergio sur 17 février 2006 à 10 h 15 min

    Je veins d’essayer le pack de textures, c’est joli mais au second chargement j’ai du n’importe quoi a l’ecran, ca commence par la « barre d’etat » en bas qui affiche de la bouillie de pixel, puis quand je retourne au menu rien n’est plus lisible.
    Je precise que j’ai un Peg1 April2 Radeon7500 MOS1.5.4 Pack3D.

    • thefab sur 17 février 2006 à 12 h 43 min
      Auteur

    Sergio, je te rassure, on est plusieurs dans ce cas, à priori ça serait un bug du pilote radeon.

    • slobman sur 17 février 2006 à 17 h 02 min

    Hip !!

    Non, ça doit venir de son MOS 1.5.4 leaké 😉

    !! qiH

    • Screetch sur 20 février 2006 à 13 h 01 min

    J’ai téléchargé le pack 200 Mo, j’ai créé le repertoire textures et j’y ai mis les fichiers dedans, ça n’a rien changé…

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!