| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site
   · Confidentialité



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

4   +   5   =  

  · Inscription
  · Mot de passe oublié



 | En ligne

Illustration du profil de __sam__






 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Forum

/   Forums d'Amiga Impact
   /  Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur

Accueil Forums AmigaOS, MorphOS et AROS Général Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur

Ce sujet a 15 réponses, 8 participants et a été mis à jour par  JayBLOOD, il y a 3 mois.

15 sujets de 1 à 15 (sur un total de 16)
1 2

Auteur Messages   
#315084 Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 14/09/2018 à 17:07


Clad

Participant
  • Messages : 132

Bonjour,

J’ai un problème de couleurs sur mon A2000.

Pour clarifier, je remet tout au propre:

Mon affichage est incorrect. Mon rouge fonctionne parfaitement, mais il me manque le 2ème bit du vert et le 3ème bit du bleu.

Une petite image pour illustrer:

Mon rouge fonctionne correctement
https://drive.google.com/file/d/139HFlXwMG_4lr0HZ0VCxEdm-dhG85yWV/view?usp=sharing

Il manque le 2ème bit sur le vert, donc $0 et $2 (0000 et 0010), ou $8 et $A (1000 et 1010) sont identique

https://drive.google.com/file/d/1gsCvThpbYh2vmOMmGXtPhoY5uiEiCD3t/view?usp=sharing

Il manque le 3ème bit sur le bleu, donc les plages $0-$3 et $4-$7 par exemple sont strictement identique (00XX et 01XX, ou encore 10XX et 11XX sont identiques)
https://drive.google.com/file/d/11dC-nSJWq_qcJ3PMs10sZp8XWdFbMd5t/view?usp=sharing

C’est pas évident sur la photo, mais j’ai fait des tests c’est exactement ça. (par exemple $008 et $00C sont impossible à distinguer côte à côte)

J’ai essayé avec une autre Denise, le problème ne vient pas d’elle.

Quelqu’un a déjà eu un problème similaire ? Ai je raison de suspecter le line driver ? (c’est le même qui fait le bleu et le vert, il y en a un second dedié uniquement au rouge)

  • Ce sujet a été modifié le il y a 3 mois par  Clad.
  • Ce sujet a été modifié le il y a 3 mois par  Clad.
  • Ce sujet a été modifié le il y a 3 mois par  Clad.
  • Ce sujet a été modifié le il y a 2 mois et 1 semaine par  Clad.

#315087 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 14/09/2018 à 17:55


Thor1230

Participant
  • Messages : 447

Alors pour faire simple.

As-tu teste en mode peritel ou en mode rca ?

As-tu essaye d’afficher (en codant ou avec une image) du vert, du rouge, du bleu sans les autres composant ?

Et pour ton info, visuellement un condensateut peut montrer qu’il fuit, qu’il est hs si il gonfle, et il peut aussi etre tres joli, ne montrer aucun signe de fatigue et etre totalement hors tolerance.

Donc ne te fie jamais visuellement avec un condensateur :p

/HS : dommage que les amigas n’ont pas un petit basic en rom comme sur cpc, cela aurait ete tres simple d’afficher les couleurs que l’amiga sort :/

A500 ECS KS 1.3/3.1 68010 2Mb Chip + 8Mb Fast + IDE
A500 OCS nu
A600 2 Mb Chip + IDE
A1200 Blizzard 1230 64mo Fast + IDE
Xbox Flash TSOP 2To

#315098 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 14/09/2018 à 18:57


sayasupacrew

Participant
  • Messages : 3428

lut Clad (tu me remet ?, j’étais à l’amiga camping)

C’est une première pour jamais vue ce problème auparavant, mais c’est pas une référence en ce qui me concerne. Surement d’après les infos que tu donne, un tout petit composant qui lache, ah Amiga Center serelle tu nous manque.

Sy

A2000, bz 2060, VA2000 + CX, xsurf, MegChip
A2000, combo030, A2058, Vlabmotion, xsurf
A500 vampirisé 128 mo, HDMI, mini SD
CD 32 TF328 + 8 Mo + RVB + Clavier Ps2
To8D, Mo6, Mo5 + Lect Disq 3,5
TI99A4, c=64, Jopac Brant + 60 cartouches
Powermac G5 on Morphos

#315101 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 14/09/2018 à 21:09


garou

Participant
  • Messages : 388

tu as essaye sur un autre ecran pour voir si c etait toujours rougeatre?

pour verifier si c est le  a2000 ou ton ecran.

 

#315103 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 14/09/2018 à 21:25


hivernaal

Participant
  • Messages : 3997

Peut être les résistances de la prise db23

j’ai une petite carte video qui s’enfiche dans le slot de la carte video mais qui a une prise db23, je peut te la preter pour tests si tu veux, si elle affiche aussi la meme couleur c’est que ça vient d’un composant, si les couleurs sont bonnes c’est que c’est la prise (ou les résistances etc…)

A1200. ART member.

#315109 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 02:23


Clad

Participant
  • Messages : 132

J’ai écris un petit programme de test, voilà ce que ça donne

Avec la luminosité au cran du milieu, ça vire pas mal vers le rouge (enfin, surtout le blanc et le jaune) mais toutes les couleurs sont présentes:

https://drive.google.com/file/d/1bAkkMukYHb9bSp2JJb2odXI-7BLo9izp/view?usp=sharing

Exactement la même image, mais avec la luminosité au minimum:

https://drive.google.com/file/d/1UP-1vnRbtnXLuplSdlXl-ZDigVd4Oxj6/view?usp=sharing

On voit que partout où le bit du rouge est présent, l’image ressort. Toutes les couleurs se taisent sauf le rouge qui hurle. On voit aussi que le vert chuchote encore un peu alors que le bleu ne dit vraiment rien. (donc le problème qui affecte mon signal R affecte aussi très légèrement mon signal G)

C’est consistant avec mon expérience: l’utilisation est bien plus agréable avec la luminosité réglée très haut. L’image est un peu délavée, mais l’équilibre des couleurs est plus juste (le gris est vraiment gris, pas marron)

Autre problème: la couleur des pixels est fortement affectée par les pixels d’a cote. C’est particulièrement visible dans un editeur de texte (le fond d’une ligne change en fonction de la quantité de texte) ou dans un jeu avec un fond uni (la couleur du fond change tout autour du personnage).

Une image pour illustrer. Normalement, le fond du menu est uni, sur cette image on voit que la couleur de fond est plus claire par exemple autour des « set » mais qu’il y a une trainée foncée après les mots « autosave » ou « editor » par exemple.

https://drive.google.com/file/d/1CjEI43CO9bOq7fotmNo9KktrgC76bAqk/view?usp=sharing

Je fais les tests sur un moniteur C=, sortie RGB par la prise DB23, entrée sur le moniteur en DB9.

Garou > J’ai fait des tests croisés qui confirment que ni le moniteur ni le câble ne sont en cause.

Je n’ai pas testé avec la sortie composite, et c’est pas vraiment pratique pour moi de le faire (et en plus il me faudrait un adaptateur RCA>peritel, très commun, mais je ne crois plus en avoir)

Hivernaal, c’est très gentil mais je ne pense pas que ce soit nécessaire, ce serait tout de même plus simple d’emprunter autour de moi un écran avec une entrée composite en RCA ou en péritel, pour à peu prés le même diagnostic.

  • Cette réponse a été modifiée le il y a 3 mois par  Clad.

#315114 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 08:50


sayasupacrew

Participant
  • Messages : 3428

Re Clad:

J’avais un problème de couleur sur mon WB et je voulais utiliser mes couleurs avec une balance très bien défini, j’ai utilisé MagicTv qui permet de faire ça balance des couleurs, magictv vas mêmes plus et permet de réduire le scintillement aussi.

http://aminet.net/util/wb/magictv2.lha

A2000, bz 2060, VA2000 + CX, xsurf, MegChip
A2000, combo030, A2058, Vlabmotion, xsurf
A500 vampirisé 128 mo, HDMI, mini SD
CD 32 TF328 + 8 Mo + RVB + Clavier Ps2
To8D, Mo6, Mo5 + Lect Disq 3,5
TI99A4, c=64, Jopac Brant + 60 cartouches
Powermac G5 on Morphos

#315117 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 09:05


amigaouf

Modérateur
  • Messages : 1510

Le teste de la sortie composite ne sera pas concluqnt car c est du N/B si je me trompe pas

#315118 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 09:40


JayBLOOD

Participant
  • Messages : 858

Amigaouf: Tu as raison, seuls les 600 1000 1200 et 4000 sortent en couleur sur le composite. 🙂

Clad: Tu as je suppose essayé de bouger un peu la fiche DB23 dans son emplacement? Mis de la bombe contact? Pareil coté moniteur?

  • Cette réponse a été modifiée le il y a 3 mois par  JayBLOOD.

Jay

#315124 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 15:15


Clad

Participant
  • Messages : 132

Oui ce n’est pas un problème de câble, j’ai fait des tests croisés. Problème de connecteur côté Amiga, peut être. (côté moniteur c’est exclu)

Saya > Ton logiciel necessite l’AGA, mais merci !

Idéalement, je cherche plutot une solution hardware.

La piste d’Hivernaal (problème de résistance) me semble la plus prometteuse, mais j’ai du mal à trouver plus de ressources sur le sujet sur internet.

  • Cette réponse a été modifiée le il y a 3 mois par  Clad.
  • Cette réponse a été modifiée le il y a 3 mois par  Clad.

#315127 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 16:10


Clad

Participant
  • Messages : 132

Bon alors c’est pas vraiment une résistance, mais entre Denise et la sortie vidéo il y a tout-en-un qu’ils appellent le vidiot. C’est une sorte de réseau de résistances qui prend les 4 bits de la couleur en entrée et sort un signal analogique.

La puce en elle même semble introuvable, mais ça doit pouvoir se reconstituer.

Autres possibilités, ça peut aussi être un défaut de contact avant le vidiot (un bit qui manque quelque part, et le signal du rouge est trop fort), ou un problème du line driver.

  • Cette réponse a été modifiée le il y a 3 mois par  Clad.

#315129 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 15/09/2018 à 18:04


Clad

Participant
  • Messages : 132

Bon alors j’ai déposé la carte mère et je ne vois aucun  défaut apparent.

Il manque 3 fusibles sur la sortie vidéo (remplacé par des ponts), mais pas au niveau des signaux RGB.

Les line drivers et le vidiot:

https://drive.google.com/file/d/1tNEqppaydMQVJC8z0PccFq5pL7vEwzN8/view?usp=sharing

Denise:

https://drive.google.com/file/d/14-DNieZcFqHELvp6VPROU9-s7IEWnUgz/view?usp=sharing

A partir de là, on est un peu au delà de mes compétences. Je peux faire des tests de continuité mais c’est à peu près tout, j’oserais pas toucher à la carte mère, il va falloir passer par un reparateur.

  • Cette réponse a été modifiée le il y a 3 mois par  Clad.
  • Cette réponse a été modifiée le il y a 3 mois par  Clad.

#315138 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 16/09/2018 à 09:00


david

Participant
  • Messages : 897

salut,as tu déjà essayer d’enlever les puces montée sur des supports est les remettres c ‘est peut être un faux contact sur les sockets

C128Dcr
gamegear
Gameboy color

#315150 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 16/09/2018 à 15:29


Clad

Participant
  • Messages : 132

Oui c’était une des premières choses que j’ai fait: enlever délicatement Denise et la remettre.

#315187 Répondre à : Amiga 2000 – Couleurs incorrectes, il manque 2 bits de couleur
 le 17/09/2018 à 05:51


Clad

Participant
  • Messages : 132

J’ai remis le premier post au propre. Quelqu’un a déjà eu un problème similaire ? Ai je raison de suspecter le line driver ? (c’est le même qui fait le bleu et le vert, il y en a un second dédié uniquement au rouge)


15 sujets de 1 à 15 (sur un total de 16)
1 2

Vous devez être connecté pour répondre à ce sujet.

                   
Derniers sujetsFraîcheur
 · Manu fait son tour de France à pied et en chanson il y a 1 heure et 21 minutes
 · The Chaos Engine en 3D il y a 1 heure et 31 minutes
 · J-xx il y a 4 heures et 3 minutes
 · Amiga et iPhone il y a 4 heures et 6 minutes
 · [VENDS] jeux c64 +bouton reset il y a 7 heures et 35 minutes
 · [A1200] Problème de résolution sur une TV 24 pouces il y a 7 heures et 48 minutes
 · Le fil des vidéos il y a 12 heures et 29 minutes
 · [TROUVÉ] Amstrad CPC 6128+ il y a 1 jour et 7 heures
 · C64 Mini neufs 20€ il y a 1 jour et 11 heures
 · [VENDU] Amiga 500 et divers objets autour il y a 1 jour et 15 heures





RechercheFraîcheur


Copyright © 2004-2018 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!