freeze d’écran bizarre sous OS4?

6 sujets de 1 à 6 (sur un total de 6)

  • Lynx

    • Messages : 310
    #3027

    Bon cette video de Crisot n’est pas une nouveauté (celle où il fait tourner Petunia, TwinVNC…le tout avec des images de MGS en fond d’écran) mais je n’avais jamais vraiment fait gaffe à quelque chose de bizarre…

    A un moment, Crisot lance un film, avance un peu dedans et juste après, fait un glisser-déposer. Et bien pendant ce glisser-déposer, le film bloque net! 😮 Et repart illico dès qu’il a relaché. Alors que tout ce qu’il fait après ne pose aucun problème à la vidéo (peut-etre une ou deux micro saccades ou alors c’est une impression a moi)…bizarre non? Pourtant bouger une icone (c’est bel et bien pendant le deplacement de l’icone, pas au relachement) c’est pas la mer a boire non?

    Tu peux expliquer ça Crisot (c’est le WB qui a vraiment besoin d’etre refait pour AOS 4.1 :-D )? Vous avez ça les autres possesseurs d’AOne?

    leperefufu

    • Messages : 106
    #58900

    J’avais jamais fait attention à ça, mais je vais le tester quand j’aurais un moment.

    Pour les vidéos, j’utilise DVPlayer enregistré mais je ne fais rien à côté car c’est assez gourmand en ressources sur mon A1 G3-SE même avec 1 Go de RAM.

    Parfois le player se fige mais c’est quand je veux avancer dans la vidéo. Là, il faut attendre un certain temps avant de reprendre la main.

    A1200 -Vampire 1200 v2 - 128 Mo - Coffin R55
    A500+ Vampire 500 v2 - 128 Mo - Coffin R55

    centaurz

    • Messages : 293
    #58901

    Dvplayer se fige aussi quand tu reste trop longtemps dans le menu, ça doit être la même tâche qui gère le menu et l’affichage.

    Il y a un peu le même style de freeze dans certains cas avec les menus du workbench. Quand tu laisse le menu ouvert trop longtemps et que tu es en train de lire une vidéo avec mplayer par exemple, dès que le buffer de lecture est vide, ça bloque ! Mais si tu le détaches du shell avec run, ya pas le soucix.

    elwood

    • Messages : 1579
    #58902

    le WB qui a vraiment besoin d’etre refait pour AOS 4.1

    Si tu le sais déjà, pourquoi tu demandes ?

    Lynx

    • Messages : 310
    #58903

    Bah justement, je me demandais si ça venait du WB ou s’il y avait une autre explication. En tout cas c’est paaaas cool pour un système multitache…bon ça sera pour AOS4.1 on y croit! :-)

    Fab1

    • Messages : 1578
    #58904

    Le WB est monotâche par conception. C’est pas des hacks comme asyncwb qui peuvent changer ça. :)

    Cela dit, pour le drag’n’drop des icônes, c’est probablement une autre raison.

    En effet, le drag’n’drop sur amigaos verrouille l’écran et donc empêche les refresh. D’ailleurs, sous morphos, si mplayer tourne pas en overlay, ça bloque de la même manière. En overlay en revanche, ça le gêne pas du tout et ça continue.

6 sujets de 1 à 6 (sur un total de 6)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général freeze d’écran bizarre sous OS4?

Do NOT follow this link or you will be banned from the site!