HTML sous IBrowse

15 sujets de 1 à 15 (sur un total de 17)

  • 1
  • 2
  • Tom

    • Messages : 1270
    #503

    J’aimerais peaufiner les pages de mon site pour qu’elles s’affichent le mieux possible sur tout les browsers.

    Dans l’immédiat, Opéra et IBrowse posent quelques problèmes.

    Est-ce que quelqu’un s’est suffisamment penché sur la question avec IBrowse pour m’éclairer ?

    A moins qu’il n’existe des site qui traitent de la question ?

    J’ai notammant comme soucis avec IB :

    – lorsque j’ai une image de fond dans une table, il va la reproduire dans chaque cellule de la table. Dois-je vraiment découper mon image en petits morceaux à assembler dans chaque cellule ?

    – Si je déclare une

    à un emplacement précis (x,y), il s’en fout et le met à la fin de la page

    – Il ignore les rollovers (images qui changent d’aspect quand le pointeur de la souris passe au-dessus). Il semblait pourtant avoir vu ça fonctionner sur ce navigateur, malgré le javascript que cela suppose.

    Avec Opéra…. pffff, c’est encore autre chose.

    Sinon pour Netscape/Firefox/Mozilla et IE c’est tout bon.

    fenrix

    • Messages : 2598
    #18157

    je vais essayer de t’aider :

    pour l’image dans la table, je ne comprends pas : il me semble logique qu’il l’affiche dans chaque cellule non? Qu’est ce que tu souhaites obtenir comme résultat en fait?

    pour

    je ne sais pas, je ne m’en sers jamais.

    pour le javascript : si ca marche mais il faut faire un petit script que je peux te donner si tu veux.

    Il me semble avoir vu un autre pb (bug) avec IBrowse. Quand on déclare une BGCOLOR dans une cellule et qu’on place une table dans cette cellule , le BGCOLOR de cette table semble ignoré. Vous confirmez?

    fenrix

    • Messages : 2598
    #18158

    Je viens de vérifier sur les sites de Netscape et de w3, BACKGROUND n’est PAS un attribut valide de TABLE

    Tom

    • Messages : 1270
    #18159

    Aïe, pas bon ça.

    Donc si ma table a 3 lignes avec deux colonnes par ligne, alors je dois découper mon image en 6 morceaux, chacun dans le background d’un

    ??

    Remarques ça expliquerait pourquoi j’ai souvent vu ce genre de mise en page sur Internet…

    Par contre je veux bien voir ton script pour le rollover, car j’en ai fais 2-3 différents mais tous sont ignorés par IBrowse.

    Ha pis j’ai aussi fais un script de scrolltext dans la page d’intro de ma section « Upgrades hardware ».

    Et ça ne marche ni pour IBrowse, ni pour Opéra, du coup je dois détecter le navigateur avant d’afficher la page.

    Toute suggestion est la bienvenue.

    fenrix

    • Messages : 2598
    #18160

    Apparement oui. En mettant l’argument Width=taille en pixels pour etre sur que les morceaux ne bougent pas.

    tu peux aller voir sur http://perso.wanadoo.fr/danmark/index2.html

    j’ai utilisé à la fois un tableau pour caser une image découpée et des images qui changent d’état (tu peux voir le script en affichant le source).

    stan

    • Messages : 508
    #18161

    C’est pas un attribut valide, mais tous les browsers supportent ça (sauf Amaya, je suppose).

    Je peux me tromper mais à priori, sans CSS, impossible de s’en passer si on veut mettre des images en fond…

    Pour les rollovers, à priori ça marche sous iB. Peut-être que ton script utilise un truc non supporté. Ou alors tu as oublié d’activer le JS :).

    Pour le positionnement au pixel, c’est impossible je pense (et d’ailleurs je trouve ça débile vu qu’on ne maitrise pas la taille des fontes et donc ça peut causer des chevauchements). Je viens de regarder la doc du HTML 4.01 et du HTML 3.2 sur http://www.w3.org, et aucune des deux versions ne supporte les attributs que tu mentionnes. (ok, ça ne prouve pas que ça ne marche pas, cf table background, mais bon…)

    stan

    • Messages : 508
    #18162

    Pour l’image de fond de ta table, tu peux imbriquer ta table dans une autre table qui ne contient qu’une cellule, et mettre le tag background dans la table imbriquante.

    hybrid

    • Messages : 492
    #18163

    fenrix a écrit :

    Il me semble avoir vu un autre pb (bug) avec IBrowse. Quand on déclare une BGCOLOR dans une cellule et qu’on place une table dans cette cellule , le BGCOLOR de cette table semble ignoré. Vous confirmez?

    Je confirme, sous IB le BGCOLOR de la table est ignoré, tu es obligé de l’utiliser dans chaque cellule pour avoir une vouleur en fond dans ton tableau.

    De même avec

    qui est ignoré lui aussi, dommage, c’était pratique, ça permet de changer les attributs par défaut des balises

    Tom

    • Messages : 1270
    #18164

    @stan :

    Merci pour l’astuce, ça marche très bien :)

    Et, oui, le javascript est bien activé :)

    Puisque j’y suis, faudrait peut-être que je fasse des tests avec AWeb, étant donné que des gens se sont connectés sur mon site avec ce navigateur.

    Tiens par contre j’ai aucun moyen de savoir si tout ça passe bien avec les navigateurs mac. On verra plus tard.

    @fenrix :

    Arf, non ici avec WinUae, je fais tourner une install OS3.9 avec IBrowse 2.2, et aucun rollover n’a lieu sur ta page.

    Je devrais peut-être upgrader vers IBrowse 2.3 ?

    De toute façon j’attend maintenant d’avoir nettoyé tout ça avant de mettre le site à jour. Mais il y a déjà beaucoup de progrès, juste Opéra qui est un peu récalçitrant…

    anonyme

    • Messages : 8171
    #18165

    ashitaka a écrit :

    Tiens par contre j’ai aucun moyen de savoir si tout ça passe bien avec les navigateurs mac. On verra plus tard.

    Ici, sur Safari, ça marche bien :-D

    Les vignette changent quand je passe dessus avec la souris, tout comme les liens avec la Vachette X-D

    fenrix

    • Messages : 2598
    #18166

    @ashitaka

    oui il faut IBrowse 2.3. Ca ne marchait pas avec le 2.2. En fait je ne me suis mis au JS qu’à partir du moment ou IB made it possible :D

    Tom

    • Messages : 1270
    #18167

    @ TP et fenrix : ok, merci pour vos remarques :)

    anonyme

    • Messages : 8171
    #18168

    ashitaka a écrit :

    @ TP et fenrix : ok, merci pour vos remarques :)

    ya pas de quoi :-)

    Concernant Opera, ça passe comme il faut (ici à la maison)

    Opera 7.23 (win98)

    Tom

    • Messages : 1270
    #18169

    @TP : nan ça passait pas « comme il faut » lorsque tu as posté ton message, car je n’avais pas encore retravaillé le javascript. Disons qu’à ce moment là ton Opéra ignorait le javascript car ce dernier était trop mal torché.

    Maintenant les rollovers sur les images et le scrolltext de la section « upgrades hardware » fonctionnent sous Firefox/Mozilla, IE et opéra.

    Faudrait que j’installe IBrowse 2.3 pour voir si ça marche aussi là-dessus.

    anonyme

    • Messages : 8171
    #18170

    tu fais un gif tout transparent et tu le met en fond de toutes tes

    cellules(celles ou tu vois le fond se repeter) et voila

15 sujets de 1 à 15 (sur un total de 17)

  • 1
  • 2
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Développement HTML sous IBrowse

Amiga Impact