| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site
   · Confidentialité



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

  · Inscription
  · Mot de passe oublié



 | En ligne

Illustration du profil de david Illustration du profil de BatteMan Illustration du profil de Jedi Illustration du profil de brochi




 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Forum

/   Forums d'Amiga Impact
   /  R-type II et émulateurs

Accueil Forums AmigaOS, MorphOS et AROS Émulation et autres OS R-type II et émulateurs

Ce sujet a 17 réponses, 8 participants et a été mis à jour par  leo, il y a 3 mois et 3 semaines.

3 sujets de 16 à 18 (sur un total de 18)
1 2

Auteur Messages   
#323844 Répondre à : R-type II et émulateurs
 le 01/03/2019 à 18:55


modulo

Participant
  • Messages : 238

Et j’ai même pas pensé à jeter un coup d’œil à codetapper /o\

Donc un jeu comme risky woods , qui utilise le même genre d’astuce, rame également sur l’émulateur ?

#323845 Répondre à : R-type II et émulateurs
 le 01/03/2019 à 19:05


Giants

Participant
  • Messages : 2108

Juste pour info meme avec la dernière version de WinUAE sous Windows 10 et avec mon Core [email protected] on peut pas dire que c’est d’une fluidité exemplaire.

Donc, même test sur mon A500
Rien de transcendant non plus mais ça ne lag pas.
MAIS, dés que l’on commence à avoir pas mal de gros sprite, exemple les robots qui sortent de l’eau + nos tir en continu, la…
On sans que le code du jeu + l’Amiga arrive au bout.

Donc effectivement, le code original est pas ce que l’on pourrait appelé ‘optimisé’.
Après, je n’ai jamais codé de jeu sur Amiga, peut être qu’au final c’est impossible d’avoir un rendu nickel fluide sur ce genre de bécane.

Il me semble que même sur les bootleg ca ramait, non ?

Région : Yvelines
Site : http://sasfepu78.fr
H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc

#323858 Répondre à : R-type II et émulateurs
 le 01/03/2019 à 19:48


leo

Participant
  • Messages : 3487

@modulo: je me pose la même question.

Apparemment c’est l’utilisation intensive du copper qui provoque ces ralentissements, ce qui n’est pas illogique.

Dans R-Type 2, le fond parallaxe qui apparaît après le début du jeu est en fait composé de sprites multiplexés, et c’est le copper qui permet de faire ça.


3 sujets de 16 à 18 (sur un total de 18)
1 2

Vous devez être connecté pour répondre à ce sujet.

                   
Derniers sujetsFraîcheur
 · Maître Batte il y a 3 minutes
 · installation logiciel il y a 12 minutes
 · Sortie du Rapsberry Pi 4 il y a 55 minutes
 · [VENDS] FastATA III avec disquette pour A1200 il y a 56 minutes
 · [RECH] clavier A 500 il y a 1 heure et 6 minutes
 · qui a déjà posséde cette ordi il y a 1 heure et 17 minutes
 · [DONS/Echange] Lecteur K7 de l'espace + Canon IP3000 il y a 3 heures et 26 minutes
 · [VENDS] Pcb bootleg Robocop il y a 11 heures et 33 minutes
 · Cartes Terrible Fire il y a 16 heures et 59 minutes
 · (Update) Gotek firmware HxC du nouveau il y a 17 heures et 52 minutes





RechercheFraîcheur


Copyright © 2004-2019 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!