R-type II et émulateurs

3 sujets de 16 à 18 (sur un total de 18)

  • 1
  • 2
  • modulo

    • Messages : 267
    #323844

    Et j’ai même pas pensé à jeter un coup d’œil à codetapper /o\

    Donc un jeu comme risky woods , qui utilise le même genre d’astuce, rame également sur l’émulateur ?

    Giants

    • Messages : 3059
    #323845

    Juste pour info meme avec la dernière version de WinUAE sous Windows 10 et avec mon Core [email protected] on peut pas dire que c’est d’une fluidité exemplaire.

    Donc, même test sur mon A500
    Rien de transcendant non plus mais ça ne lag pas.
    MAIS, dés que l’on commence à avoir pas mal de gros sprite, exemple les robots qui sortent de l’eau + nos tir en continu, la…
    On sans que le code du jeu + l’Amiga arrive au bout.

    Donc effectivement, le code original est pas ce que l’on pourrait appelé ‘optimisé’.
    Après, je n’ai jamais codé de jeu sur Amiga, peut être qu’au final c’est impossible d’avoir un rendu nickel fluide sur ce genre de bécane.

    Il me semble que même sur les bootleg ca ramait, non ?

    Région : Yvelines
    Site : http://sasfepu78.fr
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    leo

    • Messages : 3501
    #323858

    @modulo: je me pose la même question.

    Apparemment c’est l’utilisation intensive du copper qui provoque ces ralentissements, ce qui n’est pas illogique.

    Dans R-Type 2, le fond parallaxe qui apparaît après le début du jeu est en fait composé de sprites multiplexés, et c’est le copper qui permet de faire ça.

3 sujets de 16 à 18 (sur un total de 18)

  • 1
  • 2

Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Émulation et autres OS R-type II et émulateurs

Do NOT follow this link or you will be banned from the site!