Rediriger les sons du système sur carte audio PCI

7 sujets de 1 à 7 (sur un total de 7)

  • Safir

    • Messages : 65
    #6973

    Bonjour à tous,

    Est-il possible de rediriger les sons système via AHI vers une carte audio PCI?

    Je possède un Mediator 1200SX équipé depuis hier d’une soundblaster CT4810 compatible avec ce dernier. Ce qui me semble bizarre, c’est que les sons du système ne sont pas redirigés vers la carte! Seuls les mp3 sur AmigaAmp me donnent du son.

    J’ai contôlé la config d’AHI, j’ai sélectionné unit0, SBxx, 16bits Stereo +++.

    Le seul pb, c’est que je n’ai la main que sur la fréquence d’échantillonage et le nombre de canaux, les autres paramètres restent grisés, normal ou pas?

    Bref je suis un peu bloqué merci d’avance pour votre aide.

    A+

    Safir

    henes

    • Messages : 2600
    #110834

    Il te faut sans doute un sound.datatype utilisant AHI plutôt que l’audio.device (celui-ci ne sachant utiliser que le chip Paula).

    Cela se trouve… je ne sais plus où.

    Farfadet

    • Messages : 57
    #110835

    Hello,

    En fait, tu dois aussi branché la sortie son de ton Amiga sur l’entrée micro de ta carte son via un câble avec 2 prises RCA vers mini-jack; et si tu as un lecteur CD/DVD branche le avec le câble dédié. :-)

    Voxel

    • Messages : 1400
    #110836

    pas l’entrée micro malheureux! tu vas exploser ta carte son !

    c’est sur l’entrée Ligne (ou auxiliaire) qu’il faut brancher la sortie son du miga.

    par contre ça ne changera rien pendant le boot puisque la carte son ne sera pas initialisée ;-) mais après ça marche :-)

    autrement, l’auteur de AHI avait sorti un patch (Amipooh ou kek chose comme ça) qui détournait les appels à paula sur le driver AHI. perso chez moi il ne marchait pas top (guru) mais je sais que chez d’autres ça le faisait :-)

    Et puis il y a kekun (la faut chercher, j’ai oublié son blaze) qui développe un « remplaçant 100% compatible » de l’audio.device qui se trouve en rom kickstart et qui fait la même chose, tout appel à paula via l’audio.device est répondu par AHI. il me semble qu’il faisait ça pour morphos, une version pour AmigaOS serait la bienvenue :-)

    Farfadet

    • Messages : 57
    #110837

    Aïe aë, j’ai dit une bêtise plus grande que moi (1,82m) :-?

    J’en suis vraiment navré. :sweat:

    henes

    • Messages : 2600
    #110838

    Cela m’étonne que personne ait encore parlé de la solution de la table de mixage…

    Puisque l’on parle uniquement des sons système (DisplayBeep() & co), installer l’un de ces deux datatypes me parait être une bonne solution:

    http://aminet.net/package/util/dtype/AHI-SoundDT

    http://aminet.net/package/util/dtype/soundDT41

    Safir

    • Messages : 65
    #110839

    Merci à tous pour votre aide, je vais essayer dès que possible.

    Je vous tiens au courant.

    A bientôt.

    Safir

7 sujets de 1 à 7 (sur un total de 7)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général Rediriger les sons du système sur carte audio PCI

Do NOT follow this link or you will be banned from the site!