| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

  · Inscription
  · Mot de passe oublié



 | En ligne

Illustration du profil de Outlaw Illustration du profil de bigdan Illustration du profil de logo Illustration du profil de Tcheko Illustration du profil de Jérôme




 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Actualités


   Nouveaux DNETC OS4 et MorphOS
   | 1 septembre 2004 | Logiciels

logiciels

Récemment distribué sur le site de Distributed.net, le nouveau client 494b est enfin disponible pour AmigaOS 4 et MorphOS.

Cette nouvelle version apporte enfin sur nos machines le support des puissants cores Altivec, ce qui a pour principal intérêt de prouver aux utilisateurs que l’Altivec est enfin actif sur les 2 OS.

Activé et utilisé ? La version OS 4 nécessite le kernel 51.12 et la version MorphOS nécessite MOS 1.5, qui sont pour le moment réservés à leurs betatesteurs respectifs.

On attend maintenant de les voir arriver jusqu’aux utilisateurs.




Les commentaires appartiennent à leurs auteurs.
Nous ne sommes pas responsables de leur contenu.


Auteur Conversation
anonyme Posté le 1 septembre 2004



Le core Altivec tournse sous MorphOS depuis décembre et la sortie du Peg II (MorphOS 1.5 necessaire).

Je me demande si cette nouvelle version est plus rapide (+ mieux optimisé) que la précédente…



anonyme Posté le 1 septembre 2004



RC5-72: 10.694.108 keys/s on [email protected] 😀



anonyme Posté le 1 septembre 2004



Nico: Récement encore (j’en ai papoté y’a pas plus de 2 mois), MOS ne supportait pas l’altivec. Tu pouvais l’avoir, mais en le forçant. Le problème de ce principe c’est qu’en lançant 2 taches altivec, tout s’auto gauffre immédiatement.

Il en était de même pour l’Os 4 depuis des mois, le mec qui fait le client n’avait néanmoins pas inclu les cores par souci « déontologique ».

Le mec qui fait le client MOS (Pyru?) en avait d’ailleur parlé avec Kakace IIRC et ils avaient conclu que forcer le client à utiliser altivec alors que l’os ne le gère pas proprement, c’est caca beurk.

Voici donc pourquoi la version MOS n’a été releasé que le 19 aout 2004, soit depuis 2 semaines. (et non pas Decembre, dont tu as peut etre le client qui marchait sur Os explosif).

Bref, l’altivec sur MorphOs et Os4, c’est une nouveauté.

Tu ne devrais pas voir de différence de performance sur les cores RC5-72 qui sont au taquet depuis plusieurs mois déjà (merci Kakace). Par contre, les nouveaux cores OGR-P2 sont un vrai régal 🙂



falcon1 Posté le 1 septembre 2004



pour ceux qui n’ont pas morphOS 1.5, il n’y a pas les cores altivec d’activés, dans cette version, ainsi que dans toutes les versions publiques.

Ca a toujours été, et c’est toujours environ 3.8M keys/sec.

crisot : les versions mos des clients dnetc sont dispos sur le net depuis décembre… (avant les premiers clients OS4 d’ailleurs) mais l’altivec n’est activé qu’avec un OS qui le supporte.

A titre d’info, je crois que c’est la 4ème version mos…



anonyme Posté le 1 septembre 2004



Falcon: j’ai jamais dis le contraire, mais les précédentes versions du client MOS avaient des cores Altivec désactivés pour cause de non support, à priori meme sur les MOS internes.

Tout comme les clients Os4, qui ont eu aussi plusieurs mois, sans support altivec.



anonyme Posté le 1 septembre 2004



(MorphOS 1.5 necessaire)

C’est pareil pour OS4 ? (ie: il faut un noyau non public pour pouvoir utiliser le core Altivec)

@+,
Léo.



logo Posté le 1 septembre 2004



En gros, sur MorhOs 1.5, il y a l’altivec, le support 3D Radeon, un support imprimante qui marche, etc…

Arrrrghhh !!!



henes Posté le 1 septembre 2004



@Crisot

Récement encore (j’en ai papoté y’a pas plus de 2 mois), MOS ne supportait pas l’altivec. Tu pouvais l’avoir, mais en le forçant. Le problème de ce principe c’est qu’en lançant 2 taches altivec, tout s’auto gauffre immédiatement.

Faux. Il faut papoter avec les bonnes personnes. 🙂

Un moyen très simple de prouver que cela marchait il y a plus de 2 mois est de regarder mes stats RC5: http://stats.distributed.net/participant/phistory.php?project_id=8&id=437750
On voit clairement que le 16 juin (plus de 2 mois donc) je crackais déjà du RC5 avec l’Altivec (je suis désolé de ne pas avoir de pcul/mac pour surfer et cracker du rc5 :).
Si tu regardes les stats de piru ( http://stats.distributed.net/participant/phistory.php?project_id=8&id=388159 ) qui a installé le client optimisé Altivec *plusieurs mois* avant moi, tu verra qu’il a fait un bond en *janvier* (et pas en août…). Et non, personne n’a été assez fou pour envoyer des blocs calculés en utilisant l’Altivec avant que MorphOS ne le gère entièrement.

Le mec qui fait le client MOS (Pyru?) en avait d’ailleur parlé avec Kakace IIRC et ils avaient conclu que forcer le client à utiliser altivec alors que l’os ne le gère pas proprement, c’est caca beurk.

Oui. Ils avaient discuté pour savoir s’il était envisagable de faire tourner un client dnet utilisant l’Altivec sur un vieux MorphOS ne le supportant pas.
La réponse est non et c’est pour cela qu’il est vérifié que la version de MorphOS utilisée supporte bien l’Altivec. Sinon, d’autres routines sont utilisées.

Pour résumer: MorphOS supporte bien l’Altivec depuis le début de l’année et il aurait été suffisant de s’arrêter au post initial de Nico plutôt que de tenter de prouver le contraire… 🙂

Surtout qu’en fait je suis sûr que tout le monde se contrebalance de savoir qui a supporté l’Altivec le premier puisqu’il s’agit en fait Apple ou d’un Unix interne à Motorola et qu’on est bien largués à côté d’eux 🙂
De toute façon, le porte parole d’Hyperion vient de déclarer (hier je crois) que l’Altivec ne servait à rien… Je te file l’URL si tu veux, il est trop ridicule. 🙂



anonyme Posté le 2 septembre 2004



@Henes: ca m’intéresse cet URL 🙂

@+,
Léo.



thefab Posté le 2 septembre 2004



oui bon ben voilà une application qui était totalement inutile sur
MorphOS portée sur OS4.

Ca aura au moins le mérite d’occuper le cpu, a défaut de
l’utilisateur.



corto Posté le 2 septembre 2004



Pour moi, la grosse nouveauté de cette news, c’est qu’on commence à annoncer des logiciels pour des versions indisponibles de nos OS ! Enfin, si au moins ça pouvait signifier qu’il y aurait à leur sortie des applis qui les exploitent, ça serait bien (pour peu que ce soit des applis plus utiles que celle-ci pour le grand public).



anonyme Posté le 2 septembre 2004



@Corto: malheureusement c’est pas nouveau… Et puis on pourrait se dire « Des logiciels dont certaines caractéristiques requièrent une nouvelle version de l’OS pointent le bout de leur nez: MOS 1.5 va donc surement pas tarder à sortir » et il n’en est rien 🙂

Le DNetc avec support altivec « seulement activé sur MOS 1.5 » est dispo. depuis plusieurs mois.
De même, l’horloge de Piru nécessite le nouveau MOS pour les options « always on top »,… (option sans laquelle ce genre d’outil est totalement inutile pour moi). CPU Mon. nécessite MOS1.5+ pour la mesure de la t° du CPU…

Mais je m’arrête là, j’en ai déjà trop dit pour les espions OS4, hein ? 🙂

@+,
Léo.








Haut de page 

Copyright © 2004-2017 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!