OS4Emu 1.2 pour MorphOS

Itix vient de rendre disponible OS4Emu 1.2, le dorénavant célèbre émulateur OS4 pour MorphOS.

Au rendez-vous des nouveautés on retrouve, un patch pour charger
directement les exécutables Amiga OS4 depuis MorphOS, diverses corrections de bugs, le support des libraries et devices Gadtools, ASL, CGX, Layers, AHI et Interfaces Workbench.

Télécharger : os4emu.lha (MorphOS) [47 ko]Les programmes suivants ont été testés avec succès:

  • List68K
  • AMP
  • LHA
  • Zero
  • UnRAR
  • Rage
  • Atari800
  • SGE

Et bien d’autres.

A noter, que tous ces programmes devraient maintenant fonctionner sur
MorphOS 1.4.x.

24 Commentaires

Passer au formulaire de commentaire

    • anonyme sur 5 décembre 2004 à 17 h 10 min
      Auteur

    ahah 🙂
    Zero fonctionne sur mon petit Pegasos ça y est !
    34fps sur peg1 G3 600MHz (ce qui est trés largement suffisent et agreable).

    • jchap sur 5 décembre 2004 à 17 h 50 min

    C quoi Zero ?

    • thefab sur 5 décembre 2004 à 17 h 51 min

    une démo qui porte bien son nom? 🙂

    /me sort

    • anonyme sur 5 décembre 2004 à 17 h 58 min
      Auteur

    snake et Pong fonctionnent aussi (je continues les tests)

    • thefab sur 5 décembre 2004 à 18 h 32 min

    hum, peut etre devrais tu te limiter à essayer des progs intéressants
    et non des daubes 😉

    • anonyme sur 5 décembre 2004 à 18 h 34 min
      Auteur

    faudrait deja qu’il y en ai 🙂
    fpse ne marche pas (encore)
    sinon, lights, plasmastring, ripple (91fps), tunnel (38fps) et vector fonctionnent.
    on les trouve ici

    • anonyme sur 5 décembre 2004 à 20 h 06 min
      Auteur

    @logo:pour l’instant heu… la demo zero, sympa mais pas revolutionnaire, sinon en attendant que FPSE soit supporté (on aura peut être notre propre version d’ici la) je vois pas.

    • anonyme sur 5 décembre 2004 à 20 h 10 min
      Auteur

    Si tu trouves un truc bien que l’on a pas sur Peg, merci de me le faire savoir.

    Un truc qu’apparament on n’est pas prêts d’avoir sur peg: le WB.

    @+,
    Léo.

    C’est mon dernier post 🙂

    @TheFab: au cas où tu l’aurais pas compris, c’était une petite touche d’humour noir pour fêter mon dernier post…

    @BatteMan: désolé pour les écorchures, c’était (vraiment) pas intentionnel

    @Tout le monde: bon vent !

    • anonyme sur 5 décembre 2004 à 20 h 20 min
      Auteur

    @leo: heu si ambient ne te convient pas (c’est egalement mon cas) tu peux y mettre Workbench (beurk), magellan (miam) 🙂

    • thefab sur 5 décembre 2004 à 20 h 37 min

    Leo:

    on parle ici de programme que nous pouvons acquérir en toute légalité
    merci, ton manque de perspicacité m’étonnera toujours 🙂

    • Kokin0u sur 5 décembre 2004 à 21 h 57 min

    Sas_: Workbench, comme tu l’appelles, a bien changé depuis le 3.9. Tout est 100% skinnable… Et je ne parle même pas des thèmes qui seront gérés avec la prochaine update (peut-être le 4.0 définitif ?). La GUI de l’OS 4 n’a rien à envier à Ambient.

    /me possède l’un et a utilisé l’autre 🙂

    • anonyme sur 5 décembre 2004 à 22 h 04 min
      Auteur

    @kokinou: je parlais bien entendu du WB 68K.

    Cela fait un moment que je n’ai pas vu le WB d’OS4, la derniere fois c’etait guére different de celui de OS3.9 et franchement (mais je n’ai jamais aimé en ce qui me concerne le WB) pas des plus agreable (et je ne parle pas de skin et de thémes dont je me fout quelque peu :).
    donc si tu dis que ça à bien evolué j’en suis heureux pour vous.

    • anonyme sur 5 décembre 2004 à 23 h 00 min
      Auteur

    Déjà certains voyaient lepeg/Aone comme identiques alors si tous les progs OS4 passent sous MOS on peut se demander si Genesi n’a pas racheter hyperion 😀

    • serge sur 5 décembre 2004 à 23 h 42 min

    c’est trop de la balle !
    Ce Warper devient vraiment bien.

    Je ne pense pas qu’à l’heure actuelle il y ai beaucoup de bons softs à
    émuler, mais ce qui est sur, c’est que s’il y en a , avec OS4Emu on
    aura le choix de s’en servir ou pas.

    Le choix c’est la liberté et pour cela je dis MERCI au DEV de cet
    Outil Itix.

    • serge sur 6 décembre 2004 à 0 h 34 min

    @ Sas :
    quel aspet a la demo ZERO chez toi?
    Chez moi, elle se lance, ce qui pour moi releve déja du miracle, mais
    par contre je n’ais pas le son joué par mpega et les couleurs semblent
    etre dans un mode que ma radeon 7000 ne gere pas. Ca me fait penser a
    un probleme entre du littleEndian et bigEndian.

    Y a t il moyen d’avoir simplement les bonnes couleurs et le son ?
    Merci

    • Fab1 sur 6 décembre 2004 à 0 h 42 min

    Kokinou:

    une petite rectification de vocabulaire. Quand tu dis que le workbench a beaucoup évolué et est skinnable, tu parles en fait de intuition et reaction qui ont évolué de ce point de vue (chose également valable sur morphos pour intuition et mui).

    En revanche, le workbench du 4.0, qui n’est que le bureau (qui a la responsabilité d’afficher des fenêtres avec des icones dedans et lancer des programmes), a très peu changé en termes de fonctionnalités et on y retrouve même les anciens patches genre deficons, asyncwb et cie.

    Bref, je dis juste ça pour éviter une confusion entre intuition, toolkit et desktop. 🙂

    • Niffo sur 6 décembre 2004 à 1 h 13 min

    Zero : 78 FPS sur [email protected]

    • ACE sur 6 décembre 2004 à 12 h 11 min

    Pour moi ce wrapper marche pas mal, le seul truc serais de pouvoir lancer Fpse ou E-Uae encore que …
    Bon sinon y a rien sur Os4Depot ? .. Franchement j’epsere qu’il vont avancer de ce cote la !

    • anonyme sur 6 décembre 2004 à 14 h 17 min
      Auteur

    @serge: ici l’affichage est bon sur Zero, ça semble merdouiller chez plusieurs personnes, je sais pas trop à quoi c’est dû.
    j’ai un voodoo3 AGP sur pegasos 1 pour info.
    (ou alors je suis aveugle et je trouve ça bon alors que c’est fucké mais je pense pas)

    sinon pour le son, crisot le lance depuis un script independemant de la demo elle même (runme ou un truc comme ça) via mpega 🙂

    • anonyme sur 7 décembre 2004 à 1 h 14 min
      Auteur

    Zero ne gère que le little endian car c’est le seul format qui est supportés en standard par toutes les cartes modernes et tous les drivers modernes. Le big endian relèverait pour ainsi dire de l’inutile.

    • BatteMan sur 7 décembre 2004 à 2 h 41 min

    Je confirme, je viens de réinstaller la Voodoo et la démo de Universe fonctionne à merveille alors qu’avec la Radeon, c’était un peu kitch et en 8 couleurs, bien flashy les couleurs d’ailleurs. Bref, ça c’est cool d’avoir une ch’tite démo en plus, même si à la base elle était pas pour nous.
    Merci à Messieurs de Universe et à Crisot en particulier, sans oublier Itix qui permet de la faire fonctionner sous MorphOS.


    /me est content de ça 🙂

    • thefab sur 7 décembre 2004 à 8 h 21 min

    ArticiaRoxx:

    doit on en conclure que toutes les applis modernes d’os4 genre
    jeux/démos ne fonctionneront pas sur micro-aone équipé de radeon
    embarqué car ce n’est pas un chip moderne?

    • BatteMan sur 7 décembre 2004 à 12 h 16 min

    Je voulais juste dire qu’il suffit d’ajouter « OS4Emu » devant « zero.os4 » pour avoir le son et l’image de la démo.
    Toutefois, faites gaffe aux paramètres de MPEGA, faites en sorte qu’il s’ouvre bien sur le bon canal audio.


    /me a le son maintenant 😉

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!