Atéobus et compagnie…

15 sujets de 31 à 45 (sur un total de 50)

  • CLS2086

    • Messages : 3290
    #76502

    C’est avec quelle version de l’ultrasound que tu fais tes tests ?

    http://en.wikipedia.org/wiki/Gravis_Ultrasound

    Sreg

    • Messages : 247
    #76503

    En principe c’est la toute dernière.

    PnP, 8MB de RAM embarquée.

    a+

    Sreg

    Atreides

    • Messages : 84
    #76504

    Hello,

    Entierement d’accord avec Get27 concernant l’enthousiasme des utilisateurs d’ATEO.

    Pour ma part, je n’ai plus de messages d’erreurs et toutes les cartes connectées au bus ATEO fonctionne correctement (SCSI, Réseau, Pixel64). Je n’ai pas trop compris pourquoi, mais du jour au lendemain, tout est rentré dans l’ordre sans avoir fait quoi que ce soit de particulier !!!

    En tout cas, pour répondre à Sreg, ce qui se passe autour de l’Ateobus m’interesse toujours.

    L’Ateobus me permet de surfer sur le net, d’être en réseau avec mon PC via Miami Dx et Samba.

    Et oui, j’utilise encore mon 1200 régulièrement, certes pour le fun et par nostalgie, et je m’éclate encore sur pas mal de jeux grace à WHDLoad.

    En tout cas, s’il y a du nouveau pour l’Ateobus, ça m’interesse.

    Amigalement

    Sreg

    • Messages : 247
    #76505

    Salut,

    Bon je poste pour donner quelques news quand même.

    Ca avance, ca avance.

    Je suis allé plus loin dans la conf PnP. C’est codé à l’arrache, et je vais devoir organiser un peu mieux le code mais au moins ma GUS est reconnue, et configurée.

    Mon programme lui affecte un port et j’ai pu lancer mon petit programme que j’avais pas lancé depuis des années pour lui faire downloader un sample 8 bits et le jouer. Reste encore quelques détails à peaufiner.

    Dès que le prog de conf PnP sera un peu plus élaboré je tâcherai de créer un ateobus.resource qui remplacera le couple StartAteoBus/AteoBusServer. Bien entendu, il sera possible de forcer les ports afin de fixer les plages des cartes non PnP. Il me restera ensuite à refaire l’ateoscsi.device pour qu’il soit chargé aussi en early-startup.

    a+

    Sreg

    Depanneur06

    • Messages : 840
    #76506

    Je vien de lire ce post, et la , je dis « BRAVO » ! :-)

    J’ai un bus ateo qui traine dans un vieux 1200 en tower.

    Si l’ensemble va remarcher apres un bon coup de menage, je vais le mettre en reseaux avec mon Mac et PC ;-)

    A500 rev8 1Mb

    mrodfr

    • Messages : 1178
    #76507

    salut,

    bravo sreg !!! je n ai pas d ateobus et je le regrete deja.

    Pas avoir mis la main dedans depuis des mois, se rappeler deja comment c etait fait, faire un code et deja faire tout ca, c est vraiment super, je suis admiratif !!!!

    Bravo et continue.

    A le reve d avoir quelqu un comme toi cote elbox/mediator, openPCI ou prometheus (tant que le miga avance).

    Xanxi

    • Messages : 1231
    #76508

    Oui oui!! Continue Sreg!!

    Ma config à Ateobus est toujours ma principale bien que j’ai du meilleur matos dispo.

    Je suis impatient de voir la suite.

    100% Amiga Classic
    BOING!!!!

    seg

    • Messages : 1153
    #76509

    mrodfr a écrit :

    A le reve d avoir quelqu un comme toi cote elbox/mediator, openPCI ou prometheus (tant que le miga avance).

    A quoi tu penses comme chose(s) a faire sur mediator?

    a+

    Xanxi

    • Messages : 1231
    #76510

    Je remonte juste le topic pour encourager Sreg.

    Du nouveau depuis le début du mois? :-)

    100% Amiga Classic
    BOING!!!!

    Sreg

    • Messages : 247
    #76511

    Xanxi a écrit :

    Je remonte juste le topic pour encourager Sreg.

    Du nouveau depuis le début du mois? :-)

    Salut,

    Alors j’ai bossé mais pas des masses avancé. Petites précisions:

    Du coté du PnP c’est ok dans la reconnaissance et le mappage des ports mais l’Api est loin d’etre terminée car il faut que ce soit paramétrable.

    J’ai un souci. Lorsque je branche une autre carte son type snd blaster PnP à coté de ma GUS l’une des deux cartes n’est plus reconnue. Pourtant le processus d’isolation est simple et je ne comprends pas le conflit. J’aimerai bien savoir si le conflit existe sur PC aussi.

    Enfin peu importe, voyant que ma GUS était reconnue et affectée, je me suis dit que j’allais continuer le code que j’avais commencé il y a quelques années.

    Et pas de bol, toujours le meme problème, sur l’ancienne GUS j’ai un son hyper bas, sur la nouvelle PnP j’ai carrément pas de son. Je ne comprends pas cette histoire de volume et me dis qu’il y a un truc qui m’échappe dans le mixage. Peut etre le midi qui se mixe en plus de mes samples et du coup, un volume à zéro plus un sample normal ca diminue le volume. A voir, mais j’ai encore une autre idée.

    En tous cas le son est bien joué y a pas de souci. Le curseur avance bien, la loop se joue bien. Juste pas de volume, ou volume faible. Me suis arrété là car en ce moment j’ai pas mal de soirées prises, mais je vais recommencer courant novembre. Si quelqu’un a déjà développé un driver GUS, autant qu’il me le dise que je ne bosse pas pour rien.

    Pour la partie PnP je matte les sources de IsaPnP, mais je ne comprends pas pourquoi il n’a pas une résolution intélligente du mappage. Apparemment, à chaque plage de port proposée par les cartes, il affecte automatiquement le premier port de l’intevalle. C’est bete car il se peut qu’une autre carte n’ait pas d’autre choix que de prendre ce premier port. Bref, je tache de faire cela un peu mieux mais ça demande du temps quand on est tout seul à analyser et quand les semaines sont déjà bien remplies.

    a+

    Sreg

    Sreg

    • Messages : 247
    #76512

    Bonjour,

    Suite de l’épisode Ateobus avec aujourd’hui un petit souci.

    Pour rappel, je me suis arrété quelques semaines sur mes développements Ateobus où j’ai tendance à faire plusieurs choses à la fois, mais j’ai repris ces développements depuis peu:

    Depuis l’isolation des cartes PnP (avec succès mais pas fini) je me suis penché sur la programmation de ma GUS mais avec les problèmes que j’ai cité précédemment.

    Maintenant je me penche sur StartAteobus et AteobusServer. J’utilise pour cela les derniers sources de StartAteobus que je possède de Ateo Concept.

    J’ai donc pu refaire le configdev mais en voulant m’attaquer à la partie AteobusServer je me suis rendu compte que je ne possédais en fait aucun source.

    Comme Ateo c’est vieux maintenant, j’aimerai savoir si une âme charitable pouvait me faire un petit resource sur l’AteobusServer afin de me faire gagner du temps (attention y a du code 020 dedans). Quelqu’un sait-il aussi faire un stripdebug après linkage SAS/C? Car leur programme en est gavé et serait bon à nettoyer.

    En bref, il me manque une partie essentielle qui concerne la gestion des interruptions du Bus. Je vais voir sur internet comment ca s’organise coté PC pour me donner une idée si je trouve.

    Pour info, je refais tout en C en simplifiant le tout car le but est de créer une resource avec gestion du PnP et compilable sous OS4.0.

    Une autre question: quelqu’un sait-il facilement faire un code resistant au reset? (même si c’est pas nécessaire grâce a BlizzKick). Je me penche actuellement sur la question et je n’ai jamais eu à faire se genre de code jusquà présent.

    a+

    Sreg

    seg

    • Messages : 1153
    #76513

    Vu que y a pas de reponse, je vais devoir m’y coller.

    a+

    Gilloo

    • Messages : 831
    #76514

    seg a écrit :

    Moi ca me fait marrer de voir aujourd’hui des gens qui parlent de classic ateobus alors que putain merde, on est en 2007! C’est fini tout ca! Maintenant on a le PCI!

    :-D PCI = Peripheral Component Interconnect = grosse daube pour PC et Mac.

    Vive ZORRO! (2 et 3) pour ‘Miga :-D

    sreg a écrit :

    Une autre question: quelqu’un sait-il facilement faire un code resistant au reset? (même si c’est pas nécessaire grâce a BlizzKick). Je me penche actuellement sur la question et je n’ai jamais eu à faire se genre de code jusquà présent.

    Jamais vu en C.

    Il faut mettre quelque chose d’intelligent dans CoolCapture, ColdCapture, WarmCapture… :sweat: pointeurs qui se trouvent dans Exec.

    Alex

    • Messages : 1025
    #76515

    Une autre question: quelqu’un sait-il facilement faire un code resistant au reset?

    J’ai enfin pris le remps de regarder dans ma Bible ce dont je me souvenais que partiellement.

    Deux moyens pour faire ça :

    – les XXXCapture comme le suggère Gilloo (a priori CoolCapture serait celui à privilégier : ColdCapture étant trop tôt dans la phase de boot y a rien du système de dispo encore, et WarmCapture tu ne ressorts pas de ta routine),

    – les modules résident (cf. struct Resident)

    Je peux donner plus de détails si nécessaire grâce à ma Bible de l’Amiga…

    Xanxi

    • Messages : 1231
    #76516

    Je ne comprends rien mais je vous encourage de tout mon coeur les gars :-)

    Au fait, que pensez vous de la compatibilité éventuelle de l’AteoBus avec OS4? Ca n’est pas du tout dans la liste officielle, mais tout le monde oublie toujours l’AteoBus alors on ne sait jamais…

    100% Amiga Classic
    BOING!!!!

15 sujets de 31 à 45 (sur un total de 50)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général Atéobus et compagnie…

Amiga Impact