| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site
   · Confidentialité



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

  · Inscription
  · Mot de passe oublié



 | En ligne

Aucun membre ne se trouve actuellement sur le site






 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Forum

/   Forums d'Amiga Impact
   /  Couleurs étranges lors de l’extraction de sprites et fonds graphiques

Accueil Forums Communauté Le Bar Couleurs étranges lors de l'extraction de sprites et fonds graphiques

Mots-clés : , , ,

Ce sujet a 23 réponses, 5 participants et a été mis à jour par  AmiDARK, il y a 1 an et 3 mois.

15 sujets de 1 à 15 (sur un total de 24)
1 2

Auteur Messages   
#280868 Couleurs étranges lors de l'extraction de sprites et fonds graphiques
 le 27/02/2017 à 17:06


Zeldus

Participant
  • Messages : 148

Bonjour à tous,

A tous les spécialistes du ripping de sprites et de graphiques, j’ai extrait les graphiques du jeu « Voisin d’enfer » de la version PC grâce à différentes manips, notamment la décompression des sprites et fonds graphiques du jeu mais j’obtiens des centaines de fichiers graphiques Targa (.tga) avec des couleurs vraiment bizarres. J’essaye de les ouvrir dans Photoshop ou Paint.net mais cela ne change rien. Je comprend qu’il y a de la transparence dans ces fichiers et que celle-ci ne semble pas gérée (entre autre) et que les couleurs sont totalement fausses mais comment faire ?

Ci-joint quelques exemples de ce que j’obtiens lors du ripping…

Par avance, merci

Pierre

#280874 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 27/02/2017 à 17:09


__sam__

Participant
  • Messages : 1425

La palette ne serait-elle pas inversée des fois ?

Samuel.

Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne
A1200 (Blizzard-IV/fpu/64Mo) - A500 (+ 1Mo PPS) - A500 Vampire V2+
(mais aussi TO8 - TO8D - TO9. Groupe PULS.)
Pub >>Teo 1.8.4<<

#280876 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 27/02/2017 à 17:18


Zeldus

Participant
  • Messages : 148

Ben non, quand j’inverse les couleurs, j’obtiens un résultat encore plus étrange…

C’est un jeu de 2003 et le stockage de sprites et graphiques en format TARGA (.tga) natif avec transparence est quelque chose d’étrange pour les PC, d’habitude, on utilise plus le PNG.

#280899 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 27/02/2017 à 21:17


hivernaal

Participant
  • Messages : 3970

j’ai souvent eu le cas quand j’essayais de convertir des images en milliers de couleurs en passant par différents formats pour être lisible sur amiga mais là tu n’es resté que sur pc ? C’est quoi les manipulations effectuées ?

 

 

A1200. ART member.

#280927 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 28/02/2017 à 10:41


Zeldus

Participant
  • Messages : 148

@hivernaal

En fait, j’ai analysé les fichiers contenant les sprites et les fonds graphiques avec un éditeur hexadécimal. J’ai vu qu’ils avaient été simplement compressés en GZIP. Décompression classique des fichiers avec 7Zip sous Windows et récupération des milliers de fichier .tga mais qui ont des couleurs étranges.

Si tu veux, je peux t’envoyer le fichier original d’archive.

Une possibilité serait que les images tga soient codées en 32 bits (24 bits + alpha) et que pour une raison que j’ignore, tous les lecteurs tga prennent les fichiers pour des images 16 ou 24 bits classiques, sans transparence… (c’est ce que me dit Photoshop). Il faudrait pouvoir modifier avec l’éditeur hexadécimal l’en tête des fichiers TGA pour y ajouter la transparence et corriger le nombre de bits mais cela nécessite d’avoir les spécifications complètes du format plutôt ancien et peu utilisé de nos jours…

Pour ceux que ça intéresse, j’ai trouvé les specs ici:

http://www.dca.fee.unicamp.br/~martino/disciplinas/ea978/tgaffs.pdf

Ca date de 1989 – 1991, bref, une antiquité en informatique, l’Amiga sait surement les lire. Je vais essayer de voir ce que je peux modifier avec l’éditeur hexadécimal dans l’en tête pour corriger le problème… Une piste parmi d’autres…

#280931 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 28/02/2017 à 13:34


AmiDARK

Participant
  • Messages : 2827

envoie moi une copie d’au moins 1 fichier image, je jèterai aussi un oeil ….

PS : il est possible que tes images soient en Targa 8 bits avec couleurs indexées (comme sur Amiga en fait) et du coup, ta palette de couleur (générée par défaut par le log qui te lis le TGA) n’est pas bonne car elle ne prends pas en compte l’indexation des couleurs….

 

@+

#280954 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 01/03/2017 à 08:55


Zeldus

Participant
  • Messages : 148

@amidark

Je pense que tu as raison, il y a un exemple d’erreur de palette ici:

https://en.wikipedia.org/wiki/Indexed_color

(l’image du perroquet avec les couleurs complètement fausses)

C’est exactement le phénomène des images que j’ai récupérées. D’ailleurs, il y en a en n&b et celle-ci n’ont aucun problème d’affichage. Il semblerait qu’il y ait quelque part une « master palette » ou « palette globale » partagée par toutes les images quelque part qui a été modifiée ou perdue. Du coup, les milliers d’images TGA n’ont plus la bonne palette et présentent des couleurs fausses.

Quand on les regarde, visuellement, au vue des couleurs, on voit qu’elles sont plutôt codées en 8 bits (256 couleurs max voir même moins) alors que dans l’en-tête, il y a un octet qui indique qu’elle sont en 16 bits sans palette. Bref, ca semble contradictoire.

Je t’envoie quelques images TGA originales dès que possible pour que tu me dises ce que tu en penses.

Bonne journée,

Pierre

#280967 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 01/03/2017 à 12:35


hivernaal

Participant
  • Messages : 3970

Je pense que vous avez mis le doigt dessus les gars

A1200. ART member.

#280971 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 01/03/2017 à 13:26


AmiDARK

Participant
  • Messages : 2827

ok

#281008 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 02/03/2017 à 11:30


Zeldus

Participant
  • Messages : 148

Voici quelques fichiers originaux au format tga extraits directement de l’archive du jeu… D’après l’analyse de l’en tête, ils devraient être codés en 16 bits sans palette ce qui ne semble pas être le cas, je n’ai pas de trace de palette globale ou master palette dans l’archive. Serait il possible que ce genre de palette soit livrée en standard dans les anciennes versions de Windows (le jeu marchait sur Windows 98, Me, XP) ?

P.S Bon ben pas possible d’uploader des fichiers tga sur le site pour des problèmes de sécurité, bizarre… Du coup, je les ai mis ici:

http://www.maison-sartrouville.fr/voisin/

Bonne journée,

Pierre

 

 

#281015 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 02/03/2017 à 16:27


Zeldus

Participant
  • Messages : 148

Toujours pas de piste, là, j’ai une image qui a une apparence vraiment bizarre, je l’ai convertie en jpg pour qu’elle passe sur le forum, qu’en pensez vous ? Certaines couleurs sont bonnes et d’autres pas !

 

fichiers attachés:
  1. mainmenu.jpg

#281032 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 02/03/2017 à 22:11


AmiDARK

Participant
  • Messages : 2827

Bon j’ai fait quelques tests … J’avais déjà vu ça et mon intuition a payé..

En réalité tes images sont dans un format RGB batard qui n’est pas celui par défaut…
Pour l’instant je n’ai converti que l’une d’elles mais elle va servir d’exemple.. la house00.tga

Elle est en 16 bits mais par défaut le TGA fait du 1,5,5,5… C’est à dire 1 bit pour le canal alpha, 5 pour le rouge, 5 pour le vert et 5 pour le bleu… C’est ainsi que cette image est convertie par les logiciels… Hors en réalité elle est en 0,5,6,5

Voila le résultat recrée avec un petit programme que j’ai fais sous DarkBASIC Professional :

[caption id="" align="alignnone" ] Convertion[/caption]

en BMP non compressée ( 5 Mo ) : http://www.alcahest-quantique.fr/Amiga/house00_Switched.bmp

J’espère que les couleurs sont correctes car j’ai du reconvertir du 5/6 bits par canal en 8 bits par canal….

Pour les autres, c’est pas du 16 bits (probablement 24 ou 32, je vais regarder) … Mais le problème est probablement le même…
Je te tiens au courant 😉

@+

#281038 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 02/03/2017 à 22:53


AmiDARK

Participant
  • Messages : 2827

Allez, on progresse…
Sur les 7 autres images, 6 sont en 16 bits avec canal alpha réparti 4,4,4,4. Soit 4 bits pour l’alpha, 4 bits pour le rouge, 4 bits pour le vert et 4 bits pour le bleu..
Le résultat en reconversion RGB444 en RGB888 donne ceci :

Il me reste une dernière image à ajouter dans le petit prog que je t’ai préparé … mais qui ne fonctionne que sur PC (désolé) …

Il y a un byte (octet) dans la définition de l’image qui définit la façon dont les bits sont répartis dans les couleurs … Et c’est apparemment cela qui est mal interprété…

Voila pour l’instant ..
Dès que j’ai fini pour la dernière image je t’envoie le prog, etc…

@+

#281040 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 02/03/2017 à 23:00


Zeldus

Participant
  • Messages : 148

Je tiens à te remercier AmiDark, tu maîtrises clairement le sujet… Bravo ! Je n’aurais jamais pensé à cela.

A ton avis quel intérêt que les developpeurs du jeu aient choisi ce format d’affichage sur PC ?

Bonne soirée,

Pierre

#281041 Répondre à : Couleurs étranges lors de l’extraction de sprites et fonds graphiques
 le 02/03/2017 à 23:09


AmiDARK

Participant
  • Messages : 2827

Je pense qu’ils ont trafiqué le format TGA de manière à utiliser un format connu (ils avaient peut-être des routines toutes faites pour ce format, histoire de pas se fatiguer) sans pour autant que les images ne soient clairement récupérables pour l’époque …
Ils ont du modifier leur routine de chargement des TGA pour prendre en compte ces modifications que les logiciels standard n’interprètent pas comme il faudrait…
Il reste 1 image je crois qu’elle est en interleave (entrelacé) … Je vois cela ce soir plus tard ou demain soir …


15 sujets de 1 à 15 (sur un total de 24)
1 2

Vous devez être connecté pour répondre à ce sujet.

                   
Derniers sujetsFraîcheur
 · polymega il y a 23 minutes
 · AmigaAmp sur A600 avec Vampire v2 il y a 2 heures et 32 minutes
 · Hombrew Amiga français il y a 6 heures et 42 minutes
 · (vds-ech)jeux c64 il y a 12 heures et 32 minutes
 · Aca 500/500 plus et vampire 1200 il y a 1 jour et 1 heure
 · [Amiga Camping] Ouverture du mini site et inscriptions il y a 1 jour et 9 heures
 · [VENDU] Amstrad CPC 464 il y a 1 jour et 10 heures
 · [ECHANGE] TILT hors serie n'1 il y a 1 jour et 12 heures
 · Vos bons/mauvais souvenirs de vos micros à l'époque ? il y a 1 jour et 19 heures
 · (don)ou poubelle il y a 2 jours et 13 heures





RechercheFraîcheur


Copyright © 2004-2018 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!