Eval vitesse d'un programme sur differents amigas

15 sujets de 1 à 15 (sur un total de 101)

  • __sam__

    • Messages : 2776
    #305322

    j’ai un programme amiga RTG (écran 32bits) que j’aimerais tester sur différentes configurations cpu/rtg amiga. Evidemment je n’ai pas toutes les config possibles et imaginables, aussi ej fais appel à la communauté pour tester le prog dispo >>ici<<.

    Pour le lancer il faut extraire l’archive, ouvrir un CLI/SHELL, aller dans le dossier ou le programme (monkey.xxx) se trouve, et le lancer. Il y a plusieurs xxx suivant les versions de compilateurs que j’ai pu utiliser. Le programme affiche une animation 3D avec un fps. On sort du programme avec ctrl-c et il affiche alors le dernier fps obtenu.

    La question est: quel FPS avez vous suivant votre conf machine ?

    Merci pour vos tests.

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    silversword31

    • Messages : 37
    #305323

    Sur Vampire V2+ en gold 2 : crash sur tous les exec…

     

    __sam__

    • Messages : 2776
    #305332

    Merci. Oui bon j’ai oublié de préciser qu’il fallait un FPU actif 🙂 Donc sur la vamp il faudra avoir le core 2.7 (ou l’émul soft qui va vite et bien). Sinon quid sur un 030, un 040 ou un 060 équipés de fpu ?

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    __sam__

    • Messages : 2776
    #305389

    Il n’y a donc plus personne avec un fpu parmi nous ? 😉 Les amiga serait-ils tous condamés à n’être de des consoles de jeux WHDLOAD ? Non dites moi qu’il y en a encore parmi nous (miaou!) qui savent ouvrir un cli, extraire une archive lha et lancer un executable en ligne de commande…

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    pat55400

    • Messages : 563
    #305392

    Salut ,sur mon 040,la version 3.2.2:fps 0,643

    Version 6.3.1b. Fps 0,773 à 1,057

    Version 2.95.3 fps 0,561 à 724

    Version 3.4.6  code erreurs 95

    Version 6.4.1b fps 0,768 à 1,046

    Version sascc fps 0,747 à 1,006

    Version vbcc fps 0,624 à 0,797

    Si tu plus d informations, demande le .Je vais essayer de faire le test sur mon 030

    amiga 1200 hd

    slingshot

    • Messages : 567
    #305393

    A4000 + 3660 + Mediator et Radeon

    3.2.2 = 2.033 fps

    sasc = 2.474 fps

    2.95.3 = 1.681 fps

    3.4.6 = crash

    6.3.1b = 2.505 fps

    6.4.1b = 2.390 fps

    sascc = 2.400 fps

    vbcc = 2.25 fps

    __sam__

    • Messages : 2776
    #305438

    Merci les amis pour les retours.

    Donc pour résumer 040 (je supose 25mhz?) = 0.7 fps (lent), 060 (supposé à 50mhz) entre 2 et 2.5 fps (~4x plus rapide, c’est mieux, mais pas rapide quand même).

    Je pense qu’il ne vaut mieux pas tester sur 030+881 sauf si on aime le sadisme (ou doit être à 0.1-0.2 fps, ouinnnn 🙁 ).

    J’ajoute à ça quelques retours que j’au eu sur vampire V2 avec le futur gold 2.7 qui donne environ 9-10fps (~4x le 060, ce qui commence à être correct en vitesse).

    Question compilos sur 040 et 060 SAS/C s’en sort pas si mal malgré son âge, mais ce sont les gcc6 qui sortent gros gagnants (dommage qu’ils ne tournent pas sous amigaos).

    Merci c’est très instructif tout ça. 😀

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    seg

    • Messages : 1142
    #305439

    @sam

    Je te fais un retour asap sur 060.

    pat55400

    • Messages : 563
    #305444

    C est un 040/33

    amiga 1200 hd

    __sam__

    • Messages : 2776
    #305451

    ah oui 33mhz, donc 20% plus rapide que je soupçonnais. Sur un [email protected] on doit être à 0.5fps. Une horreur de lenteur! J’ose à peine imaginer sur le 030 avec un 68881 à 25mhz.

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    goodchip

    • Messages : 518
    #305491

    Sur le Gold2.7, j’obtiens environs 8 à 10fps en fonction des versions, mais je n’arrive pas à sortir avec Ctrl+C, le pointeur gèle.

    Sylvain aka goodchip

    Vampire V4SA
    A500+/080
    A600(HS)
    A1200AT/020
    A2000(HS)
    A4000/040
    A4000/060

    huggyone76

    • Messages : 2123
    #305533

    Dommage qu’il soit nécessaire d’avoir du 32 bits, mon 060 avec bvision aurait pu servir… 😉

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 4Mo + CF - Sharp X68000 CZ-611C 10Mo + CF + ext. MIDI

    __sam__

    • Messages : 2776
    #305541

    Si ton WB est 16bits, tu peux utiliser l’option -win qui fait tourner le truc sur le wb. J’ai pas essayé avec un écran 24bits, faudrait que je sois plus souple avec le « CYBRBIDTG_Depth,32 ». Je devrais mettre 24 peut-être? Sinon il y a l’option -id 0x<modeid en hexa> qui peut être utilisée pour injecter un mode d’écran dont tu connais l’id (par exemple un écran 320x240x24).

    Pour la sortie avec ctrl-c qui plante, c’est curieux, je vais tester. ESC devrait aussi permettre de sortir. Peut-être que ca marche mieux mais j’y crois peu.

    (sinon j’améliore les perfs en ce moment… hier soir j’ai gagné 40% de vitesse à peu près, et il me reste du travail autour de ca. )

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    huggyone76

    • Messages : 2123
    #305542

    J’essaie ce soir si je peux alors

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 4Mo + CF - Sharp X68000 CZ-611C 10Mo + CF + ext. MIDI

    __sam__

    • Messages : 2776
    #305568

    (sinon j’améliore les perfs en ce moment… hier soir j’ai gagné 40% de vitesse à peu près, et il me reste du travail autour de ca. )

    Allez hop –> j’ai ammélioré les perfs ce soir. Je suis passé de 0.7fps sous uae sans jit sur un portable de 2006 à 3.5fps à l’instant (et 18fps sur vamp core beta 2.7 à ce qu’il parrait). Miam miam! Ca devrait bien mieux fonctionner sur 040/060 (mon uae sans jit donne à peu près un [email protected]).

    L’archive est téléchargeable >>ici<<

    Concernant le ctrl-c, je le fais sans soucis en mode plein écran. Je ne note pas d’instabilités sous UAE.

    Quant aux 32bits vidéo, j’ai réduit à 24 et ca marche toujours.

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

15 sujets de 1 à 15 (sur un total de 101)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Développement Eval vitesse d'un programme sur differents amigas

Amiga Impact