Installation MorphOS

15 sujets de 1 à 15 (sur un total de 54)

  • FrenchPistolero

    • Messages : 422
    #1284

    Bonjour,

    J’ai enfin reçu mon Pegasos I, et je tente de l’installer.

    Mon probléme, dans l’immédiat :

    -je démarre la bécane : OK

    -je fais un ls /pci/ide/cd : OK

    -je lance un boot /pci/ide/cd boot.img : il commence à sa charger, puis bloque qqs instants plus tard avec écrit à l’écran Quark/OpnFirmware

    Quark, c’est le kernel, c’est ok, mais pourquoi ne va t-il pas plus loin ?

    Pour infos, je précise :

    -Pegasos I April 2.

    -256Mo SDram ECC Registered

    -essais avec un lecteur de DVD, puis un lecteur de CD, placés sur des nappes 80 fils (les nappes UDMA) et testés en maitre sur second canal IDE, esclave second et premier canal IDE.

    Là, je ne vois pas trop ce qui bloque…

    Sur certains CD de MorphOS que j’ai, il me dit qu’il ne peut même pas charger le boot.img (« no such file » ou un truc du genre).

    Please heeeelp meeee !!!

    Merci d’avance.

    FrenchPistolero

    • Messages : 422
    #30688

    Oups, pretite précision : le disque ur a déja été utilisé dns mon A4000 et a donc les partoches que je n’y avais pas effacé (serais-ce ça ?). De même, le disque dur (40Go Maxtor 5400 trs/min) et en premier maitre sur une nappe 80 fils.

    M_o_Illusion

    • Messages : 976
    #30689

    pist> n’a t il pas été dit auparavant qu’il faut avoir un disque dur vierge de tout tout tout (genre possible à faire uniquement avec Partition Magic, si je me rappelle ce que j’avais lu ?) ? moi je l’ai installé sur un dur neuf, donc ca aide … mais effectivement je psen que c’est ca.

    BigTower

    • Messages : 42
    #30690

    Mon probléme, dans l’immédiat :

    -je démarre la bécane : OK

    -je fais un ls /pci/ide/cd : OK

    -je lance un boot /pci/ide/cd boot.img : il commence à sa charger, puis bloque qqs instants plus tard avec écrit à l’écran Quark/OpnFirmware

    Quark, c’est le kernel, c’est ok, mais pourquoi ne va t-il pas plus loin ?

    salut

    chez moi je me suis pris la tete 45 mn avant de comprendre

    que à boot /pci/ide/cd c’est cdrom qu’il faut que je tape sinon

    le bide complet

    essais boot /pci/ide/cdrom boot.img

    j’ai moi aussi permuter les nappes ide (ronde), etc etc avant de faire cette essais là

    a+

    BigTower

    PS:et pareil que plus haut j’avais un dur neuf enfin un non amiga c’etait un ntfs donc pas eu de mal à le formater puisque non reconnue sur amiga

    BatteMan

    • Messages : 6161
    #30691

    M_o_Illusion : Hum, non, ça ne vient pas de ça. Moi, je boote avec des HDs blindés de n’importe quoi, et ça démarre…

    Je ne vois pas d’où vient le problème perso.

    FrenchPistolero : Tu as essayé de booter juste avec le CD ? Mon conseil, tu démontes tout et tu remontes petit à petit en testant à chaque fois. Moi je verrais peut-être un soucis de master-slave.

    /me dit ça comme ça, parce qu’il voit pas de trop…

    Only Amiga makes it possible !

    FrenchPistolero

    • Messages : 422
    #30692

    BigTower : si tu me lisais, tu verrais que je lance le boot /pci/ide/cd boot.img, je l’ai dit. ;-)

    Ghost : j’étais sur cette piste, mais je n’ai pas de dur vierge…

    BatteMan : je suis juste avec la carte-mére hors boitier, une carte graphique, une barette de RAM, le lecteur de CD sur une nappe et le dur sur une autre nappe. Je vais essayer sans le dur.

    BatteMan

    • Messages : 6161
    #30693

    FrenchPistolero : BigTower te dit de taper : boot /pci/ide/cdrom boot.img au lieu de /pci/ide/cd mais je ne pense que ça changera grand chose, surtout que tu as le Quark/OpenFirmware.

    Idée !! Tu as un Pegasos 1 ? Mais sur le CD, tu as quelle boot.img ?

    Si c’est un CD de 1.4.2, tu as deux boot.img, vérifie que tu bootes bien sur l’image pour Peg I ;-)

    tu verras ce que tu as sur le CD en faisant un : ls /pci/ide/cd ou cdrom.

    Parce que si tu as un CD de 1.4.2, tu dois taper : boot /pci/ide/cd bootpeg1.img

    /me souhaite bonne chance à FP ;-)

    Only Amiga makes it possible !

    FrenchPistolero

    • Messages : 422
    #30694

    Eh eh, on a eu la même idée BatteMn : pendant que tu écrivais ces lignes, j’essayais justement ça !!! Je suis con parfois…

    L’installation continue !!!

    lugduweb

    • Messages : 999
    #30695

    BatteMan vient de repondre au problème il me semble ;-)

    Pistolero: Sur certains CD de MorphOS que j’ai, il me dit qu’il ne peut même pas charger le boot.img (« no such file » ou un truc du genre).

    Sur Pegasos I avec MorphOS 1.4.2, il faut effectivement taper :

    boot /pci/ide/cd bootpeg1.img

    Ensuite il faut avoir un disque vierge ou alors un disque ou le secteur de boot est remis à zéro (Partition Magic le fait bien).

    Jete éventuellement un coup d’oeil à la page suivante :

    WikiPeg – Installation de MorphOS

    FrenchPistolero

    • Messages : 422
    #30696

    PUT1 mais je suis vraiment une vieille merde !!!

    Bon, j’ai démarré, j’ai créé les deux partoches (une FFS 100Mo avec le masque qui se finit par […]ffe et les options boot et mount cochées, l’autre en SFS de 500Mo avec juste mount de coché), j’ai installé… Jusque là, tout va bien.

    Ensuite, ça merde à nouveau : l’installeur me propose de reboote, j’enléve le CD et je le fais. Je rentre la ligne de commande suivante :

    boot /pci/ide/[email protected],0:0 boot.img

    Et là, je me retrouve avec la même erreur que précédemment, à savoir bloqué sur le message Quark/SmartFirmware. Pourtant, les partoches sont bonnes

    Bon, je reboote sur CD, je lance un shell, je copie bootpeg1.img sur la partoche en SFS, je reboote et je lance la ligne suivante :

    boot /pci/ide/[email protected],0:0 bootpeg1.img

    Et là, toujours le même blocage…

    Rââââââââhhh !!! Je suis foutu d’installer un Classic sous OS 3.9 et un Peg me résiste !!! A moi qui ai déja installé du Nunux à l’époque de la Red-Hat 4.1, qui ai installé du BeOS, du QNX pour faire mumuse, du DOS et du Windows 95 à XP et NT4 à Serveur 2004 !!!

    Mais où est ce foutu probléme bon sang !!!

    lugduweb

    • Messages : 999
    #30697

    Normalement une fois installé ca devrait booter sans pb (faut enlever le CD mais tu l’as fait).

    Pas de ligne à taper, normalement ca boote tout seul automatiquement (attention le clavier est sensible, qq resets et ca repart).

    sinon comprends pas le pb :-(

    Re-verifie toutes les options de tes disques ils doit y avoir une coquille. Moi j’ai pas eu de pb (alors que je ne connaissais rien à MorphOS).

    [edit]

    Je crois que j’ai trouvé ton pb :

    FFS : mount coché

    SFS : mount coché, boot coché

    apparemment tu as fait l’inverse

    [/edit]

    FrenchPistolero

    • Messages : 422
    #30698

    Ouh là, ouh là !!! Pour que ça boot seul, il faut avoir fait un sentenv normalement, non ?

    Je récapépéte :

    -partition 1 (BOOT:) : 100Mo, FFS, 0xfffffffe, boot et mount cochés, buffers à 600.

    -partition 1 (MOS:) : 511Mo, SFS 0xfffffffe, mount coché, buffers à 600.

    l’encien sentenv avait été fait par l’ancien propriétaire, donc je ne le laisse pas finir et j’essaie de booter. Je fais tout dixit le manuel…

    FrenchPistolero

    • Messages : 422
    #30699

    OK, erreur de ma part, je le vois maintenant… J’agissais comme si je mettais les fichiers de l’OS et l’image noyeau sur la même partoche.

    GuyMay

    • Messages : 52
    #30700

    Bon, j’ai démarré, j’ai créé les deux partoches (une FFS 100Mo

    ….

    Bon, je reboote sur CD, je lance un shell, je copie bootpeg1.img sur la partoche en SFS, je reboote et je lance la ligne suivante :

    boot /pci/ide/[email protected],0:0 bootpeg1.img

    Et là, toujours le même blocage…

    Juste au cas ou, tu est sur d’avoir copier bootpeg1.img sur la première partition (en FFS).

    Car tu dis l’avoir copié sur la partition SFS, c’est pas bon.

    GuyMay

    • Messages : 52
    #30701

    Je récapépéte :

    -partition 1 (BOOT:) : 100Mo, FFS, 0xfffffffe, boot et mount cochés, buffers à 600.

    -partition 1 (MOS:) : 511Mo, SFS 0xfffffffe, mount coché, buffers à 600.

    .

    Pas bon ça !!

    La partition de boot doit être la partition ou ce trouve MOS.

    Tel que tu est configuré, il faut placer l’image de boot (peg1) sur ta partoche 1 (FFS avec seulement mount coché) et activer « boot » pour la partoche SFS (MOS).

    [Edité]

    Ensuite tu fait

    boot /pci/ide/[email protected],0:0 bootpeg1.img

    Selon le nom de ton image de boot.

15 sujets de 1 à 15 (sur un total de 54)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général Installation MorphOS

Amiga Impact