MacOS ou MacOSX sur MorphOS

14 sujets de 1 à 14 (sur un total de 14)

  • lugduweb

    • Messages : 999
    #1324

    Salut à tous et à toutes,

    je voulais savoir si il existe un emulateur pour MacOS ou MacOSX qui tournerait sur MorphOS (j’ai peur de connaitre la réponse mais je tente).

    J’ai bien vu l’article dans Obligement de Mac On Linux, mais comme je n’ai pas installé Linux sur mon Pegasos (et que je n’ai pas la place de le faire pour le moment) je voulais savoir si il y a moyen de le faire sur MorphOS.

    Niffo

    • Messages : 603
    #31274

    Il suffit d’une partition de 100 ou 200 Mo (grand max) pour installer le Linux minimum pour faire tourner MOL.

    lugduweb

    • Messages : 999
    #31275

    Bon, en fait j’ai la place mais il va falloir que je pete une partition en 2 :-/

    Sinon avant que je me lance dans des installations sans fin, est ce que ça tourne correctement sur un PegI G3 avec MacOSX ?

    jchap

    • Messages : 434
    #31276

    Lugduweb: Apparement en G3 mieux vaut rester à MacOS9 sinon c’est pas la peine. MacOSX tournerai sous G4 mais ça ne serait pas le pied. Peut être que MacOnPeg tournerai plus vite! ;-)

    serge

    • Messages : 4346
    #31277

    J’ai vécu l’experience des deux:

    PEG I MACos9 et OS X

    PEG II MACos9 et OS X

    Résultats:

    Toutes les venrsions sont fonctionnelles. Seule la version OSX sur PEG

    I est limite car le G3 est juste au niveau puissance et il faut aussi

    beaucoup de mémoire, hors je n’ai jamais réussi a faire reconnaitre

    plus de 256MO à ma distribution PEGxMAC sur PEG I.

    Par contre, sur PEG II c’est du 100% tout bon car le G4 blast de la

    mort et la mémoire n’est plus un problème.

    pour conclure, je dirais qu’un MACos9 sur ton PEG I va fulgurer et te

    servira pour la majorité des taches que tu voudra. Si tu veux OSX, tu

    peut aussi l’installer pour utiliser des applis qui n’existent pas

    sous OS9, mais il faudra être un peut patient avec l’affichage.

    Je rappelle que l’affichage du bureau d’OSX est en OpenGL, et que si

    les drivers de la carte graphique ne supportent pas l’openGL »ce qui

    est le cas sous MOL » c’est le procésseur qui se tape le rendu en soft.

    D’où la lenteur sur un G3.

    PS: rien ne t’enpeche aussi d’avoir les deux systemes sur la même

    partition ;-) les Macs sont très doués pour jonglé entre les systemes.

    RyZen Rulez 😉

    lugduweb

    • Messages : 999
    #31278

    Salut !

    Merci pour vos reponse, encore une (enfin 3) questions importante :

    1)mon Peg1 est equipée d’une Voodoo 5. Ca marche sous Mac ça ?

    2)

    Je rappelle que l’affichage du bureau d’OSX est en OpenGL, et que si les drivers de la carte graphique ne supportent pas l’openGL »ce qui est le cas sous MOL » c’est le procésseur qui se tape le rendu en soft. D’où la lenteur sur un G3.

    Mais il n’y a pas moyen d’installer les drivers Mac OpenGL des cartes graphiques ?

    3)

    PS: rien ne t’enpeche aussi d’avoir les deux systemes sur la même

    partition les Macs sont très doués pour jonglé entre les systemes.

    Tu parles de MorphOS et MacOSX je suppose.

    Pour Linux il faut de toute façon une nouvelle partition.

    Sinon est-ce qu’il y a moyen d’agrandir une partition comme avec PartitionMagic sous Windows car ca me fait un peu ch… d’avoir tout à reinstaller :-(

    Admin

    BatteMan

    • Messages : 5748
    #31279

    Lugduweb : Alors là, tu n’as rien compris, mais rien de rien :-D

    Oui, la Voodoo 5 fonctionne sous MOL, enfin je pense, vu que ça fonctionne nickel avec ma Voodoo 3.

    Alors, non, y’a pas moyen d’installer les drivers OpenGL des cartes graphiques… Pourquoi ? Car MOL s’appuye sur Linux pour ce qui est des drivers, et la redirection vers les drivers 3D n’a pas été encore faite, et apparement, elle ne risque pas d’arriver.

    Ensuite, MacOS gère très bien le démarrage sur MacOS9 ou MacOSX très facilement, et cela sur la même partition. Mais le mieux étant d’avoir une partoch’ pour chaque système.

    Si tu veux un conseil pour tes partitions, achète un HD, ça ira plus vite et tu te casseras moins le fondement.

    /me a un HD de 40 Go avec une partoch’ Linux, une swap, une pour le système MacOS et une pour les applis Mac.

    Only Amiga makes it possible !

    Pensez à vous inscrire sur www.annuaire-amiga.org, l'Annuaire des Amigaïstes toutes saveurs confondues ! ^^

    lugduweb

    • Messages : 999
    #31280

    OK j’avais effectivement rien compris du tout :)

    Je suis cons des fois (enfin c’est le matin c’est excusable).

    Bon… donc il faut que je casse tout car je n’ai pas de sous pour acheter un HD de plus en ce moment :(

    Ca va être l’occasion de refaire une installation propre du systeme MorphOS.

    Mon HD fait 10Go, je voyais bien les partitioons suivantes :

    Boot 100Mo

    DH0 MOS 2Go

    DH1 MOS 3Go

    MacOS 2Go

    Linux le reste soit environ 3Go (avec le swap)

    Ca devrait être OK avec la contrainte des 8Go de MOL non ?

    Reste après à se procurer une version de MacOS9 et MacOSX pour les tests (car 125$ ca fait un peu cher l’essai quand même non ?)

    GuyMay

    • Messages : 52
    #31281

    Franchement, un disque multiOS, c’est minimum 40Go voir plus.

    Avec 10 go tu vas pas allez loins et tu vas vite le regréter quand il faudra jongler entre les filesystem pour trouver de la place.

    Trouve toi un autre disque par pitié même un « petit » 20go d’occase pour faire tes experiences LinuMACOStiques et garde MorphOS pépère tout seul sur son disque. C’est plus sur, je pense.

    lugduweb

    • Messages : 999
    #31282

    Je vais suivre votre conseil mais à long terme,

    je vais déjà essayer de bricoler un truc avec ce que j’ai (10Go) pour voir comment ça marche.

    De toute façon je n’ai pas tant de choses que ça à réinstaller en fait vu que je n’ai mon Peg que depuis 2 mois.

    falcon1

    • Messages : 689
    #31283

    si tu prends 2Go pour macOSX, ca va craindre un max, tu arriveras a

    peint a y mettre le systeme… pour MacOS9, la pas de probleme de

    place…

    sinon un 40Go c’est dans les 45 euros en ce moment (neuf), alors fonce

    :)

    lugduweb

    • Messages : 999
    #31284

    ouin ! l’installation de Linux en netboot ne marche pas !

    je tape la commande magique :

    boot /pci/ide/[email protected],0:0 vmlinuz-chrp-initrd

    un petit slash mouline et ça en reste là :-(

    Pourtant si je fais ls /pci/ide/[email protected],0:0 je vois bien le fichier. J’ai également copié les autres fichiers du repertoire Debian au même endroit mais nothing happens.

    J’ai essayé avec un autre vmlinuz est c’est pareil :-(

    Ma conf :

    Pegasos I / G3

    Voodoo 5 5500

    Bon je vais essayer de télécharger le CD… A moins que qq ai une idée.

    Admin

    BatteMan

    • Messages : 5748
    #31285

    Lugduweb : On dirait que tu essayes une image Peg II sur un Peg I… Sinon, je vois pas.

    /me ne sait pas s’il est très utile sur ce coup là :-?

    Only Amiga makes it possible !

    Pensez à vous inscrire sur www.annuaire-amiga.org, l'Annuaire des Amigaïstes toutes saveurs confondues ! ^^

    lugduweb

    • Messages : 999
    #31286

    [edit] supprimé : création d’un nouveau thread [/edit]

14 sujets de 1 à 14 (sur un total de 14)

Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Émulation et autres OS MacOS ou MacOSX sur MorphOS

Do NOT follow this link or you will be banned from the site!