MorphOS 1.4.5 et l’USB 2

15 sujets de 1 à 15 (sur un total de 18)

  • 1
  • 2
  • sayasupacrew

    • Messages : 3909
    #7052

    Ayant renvoyé mon Pegasos 2 au printemps 2008 chez bplan, je me suis toujours demandé se qui etais arrivée a ma machine, les symptômes étais a l’époque de gros plantage lors du démmarrage de Morphos 145. Par la suite j’ai découvert que cette carte usb2 avait un port de cramé.

    Je relance le sujet afin de receuillir des informations sur d’éventuelles détails encore inconnu.

    j’ai en ma possèssion une carte usb2 VIA6212L et une Nec 72xx. Je retenterais bien de la mettre dans le pegasos2 sur Mos145, mais j’ai peur !!!! vos conseilles sont le bien venue.

    Il dois y avoir peut de chose pour y remèdié.

    j’ai fais le tèste de la carte usb2 Nec, mais Mos145 l’ignore, puisque je crois que morphos ou poséïdons(3.3) ne la prenne pas en compte.

    Rèste plus que de faire le tèste de la Via6212l ?

    Saya

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    sayasupacrew

    • Messages : 3909
    #111810

    suite a une conversation sur irc avec Fab1.

    sayasupacrew fab: question comment devrais réagir mon Peg2 avec mos 145 et une carte usb2 (via6212L)

    Fab ça dépend de ta chance

    Fab il se peut que ça meurt pendant le boot

    Fab comme tu l’as constaté pendant longtemps

    sayasupacrew ouais

    sayasupacrew:j’ai l’intention de remettre une autre carte usb 6212l !

    sayasupacrew pas de pb parcontre en bootcd ?

    Fab pareil

    Fab c’est juste une histoire de timing

    sayasupacrew c’est changeable ce timing ?

    sayasupacrew ou ajustable ?

    Fab le truc en gros, c’est que pendant un certain temps, ta carte usb2 s’amuse à écrire n’importe où en ram (et ailleurs)

    Fab jusqu’à ce que ce soit stoppé, tu peux planter, ou non

    Fab c’est vraiment la roulette russe, et ça dépend du timing

    sayasupacrew en gros cest un bugg !

    Fab oui

    sayasupacrew en tous cas c’est très intérrèssant !

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    sayasupacrew

    • Messages : 3909
    #111811

    Une fois inséré la carte usb2(via), je lance la machine sous Mos14 et la je constate que non seulement la carte usb2 ne fonction pas (elle rèste inerte) mais qu’en plus l’usb de la carte mère non plus ???

    J’en conclu que sous windows l’on appel cela un conflit ou si vous voulez les deux famille d’usb se gène mutellement ou si vous voulez aussi le chipset de la carte usb2 et l’usb de la carte mère utilise le mêmes tuyau, lorsqu’il y a la place que pour un, du coup sa détraque le système.

    J’ai désactivé l’usb de la carte mère en l’hinibant dans l’Open Firmware. De retour sous Mos14, ma clef usb d’1 go est dans un port de la carte usb2 (via) et est reconnue.

    je fais des tèste de rapidé de copie. un fichier de 200mo

    mos14 –> 4 minutes 15 secondes

    mos2.1–> 0 minutes 40 secondes

    en ayant le pilote usb2 de Nicolas DET

    j’en tire les conclusions que ma carte usb2 fonctionne à la vitèsse d’une carte usb1.

    Si non plus de problème de plantage du système jusqu’as maintenant. Il est donc possible d’utilisé une carte usb2(via6212L) avec Morphos 145, il faut aussi pour cela eteindre l’usb de la carte mère.

    Je vais laissé comme ça, pendant quelques jours. Voici un liens qui parle du Pilote usb2(version mos14)

    forum en anglais

    Saya

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    sayasupacrew

    • Messages : 3909
    #111812

    Hier samedi, aucun problème d’utilisation de l’usb2. Puis ce matin au premier démarrage du pegasos2 plus icones de l’onglet de 1 go sur le bureau de morphos14 et pourtant celui est bien inséré dans un port de la carte usb2 (via). Un bref tour sur Morphos2.xx histoire de voir si ma carte usb2 n’est pas défaillante, mais non elle ne l’est pas, puis celle celle ci fonctionne bien sur la nouvelle mouture de Morphos.

    Comme Fab1 en parle deux post plus haut, le pilote bugg aléatoirement.

    Soi je me contente d’une utilisation au hasard ou je retourne avec l’utisation de l’usb du pegasos.

    Saya

    Ps: j’ai quand mêmes fais une observation, cela s’est passé après un demarrage a froid, et je peux me souvenir du problème du port ethernet qui lui après un passage sous ubuntu restait bloqué, il faillais pour y remédié soi une longue intérruption de la machine soi utilisé le patch de Fab1. Je vais tenté une intérruption longue de 4 heures, en espérant que le pilote se charge correctement après ce long arrèt. (chose pas évidente)

    Apparement cela a l’air de se confirmé. donc après un redemarrage a froid ma carte usb2 remarche, donc les prochains redemarrage a chaud elle devrais aussi fonctionné.

    Saya

    Modération de BatteMan : Utilisez le bouton « éditer » au lieu de multiplier les posts. Merci.

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    JiDeWe

    • Messages : 5717
    #111813

    saya:) hello

    quelle version de pegII as-tu?

    1 A500 2mo, 1 A500 512ko, 1 Atari 520Ste 4mo + UltraSatan dual, un MSX2 8235 avec Carnivore2, 1 PoBO 1,67 avec Morphos.
    maxime perpétuelle : si je cours en zigzag ce n'est pas pour éviter le balles, mais les c..s,
    maxime conne de la semaine : pourquoi avoir voter l'abolition de la peine de mort des condamnés alors qu'il fallait commencer par abolir celle des victimes

    sayasupacrew

    • Messages : 3909
    #111814

    j’ai ouvert le boitier et Rev 2b3 , mais pourquoi cette question.

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    henes

    • Messages : 2606
    #111815

    Encore une fois, nul besoin d’attendre « 4 heures » pour ce genre de chose. Il suffit de vider les condos de la carte mère en débranchant le cable d’alimentation (puisque l’ATX fourni du courant en permanence, vive les économies d’énergie…) puis en appuyant sur le bouton de démarrage de la machine… Les pauvres condos vont donner tout ce qu’ils ont pour tenter d’alimenter la carte mère et se décharger instantanément.

    Puis remettre le cable d’alimentation et allumer la machine.

    4 secondes au lieu de 4 heures

    sayasupacrew

    • Messages : 3909
    #111816

    Téste effectué, exacte henes ! mais les deux possibilités ne sont pas fausse. Mais ces manipulations tue le bugg le temps d’une fois. Donc après le redémarrage une nouvelle chance ou pas que l’usb puisse fonctionné.

    Brumiga:

    donc la revision sur la carte mère du pegasos2 est a droite sur la largeur de la carte mère.

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    sayasupacrew

    • Messages : 3909
    #111817

    A la niffo party, Fab1 nous révèle que certaines carte USB2 peuvent posé des problèmes sous Mos2.xx par rapport a d’autres sans cité de marques, puis il a rajouté moi » j’ai une NEC 7xxx qui pose apperement pas de problème.

    Donc avec la carte usb2 Via6212l pose ici un problème avec usb de la carte mère (qui je rappel est aussi du Via), puisque aucun des deux ne fonctionne en mêmes temps, un remède, l’hinibé dans L’OpenFirmware l’usb du pegasos pour laissé la place a la carte usb2.

    Ou bien ce que je viens de faire pour avoir l’usb1 et l’usb2, j’ai mis une carte usb2 Nec 7xxx, du coup je peut utilisé l’usb de pegasos et ne être géné par le cumule des deux chipset (nec et via) puisque celui-ci n’est apparement pas pris en compte par le pilote de Nicolas Det. Aussi sous Mos2 utilisé les deux usb sans aucun problème, puisque il n’y a aucune gène avec deux type de chipset. (chipset via et nec du coup)

    Saya

    A2000, blizzard 2060, 128 mo edo Add, VA2000 + CX scandoubleur, xsurf1, MegChip
    A500 Classic .
    A2000, cm 6.xx (boîtier, alimentation Patch ATX to PSM200, souris, clavier), vampirisé 128 mo, HDMI out, mini SD, AGA soft, VirtuaCPU Core.
    Amiga 4000(T)quickpak, Eagle 060, PIV, Xsurf, Delfina LITE, VariO
    TF328 + 8 Mo + RVB + Clavier Ps2
    TO770+ Basic, To8D avec un Gotek, Mo6, Mo5 + Lect Disq 3,5
    TI99A4 https://www.youtube.com/watch?v=Y2_5gzYgg7M
    Jopac Brant + 60 cartouches
    Morphos On G5.

    pat

    • Messages : 30
    #111818

    Salut Saya

    Quelle est la commande pour inhiber le port usb du peg dans l’OF et peut-tu être plus précis pour la référence du chip de ta carte usb NEC ?

    Moi aussi j’ai des soucis avec ma carte usb 2.0 (via vt6212L), elle est bien reconnue par Poseidon mais lors des copies de fichiers elle plante rapidement.

    Merci d’avance Pat

    henes

    • Messages : 2606
    #111819

    set usb-enable? false

    pat

    • Messages : 30
    #111820

    Merci Henes

    Le mot set n’est pas compris par l’OF et si je tape « usb-enable? false » après le boot dans poseidon j’ai toujours les 2 « controllers ».

    A+ pat

    Fab1

    • Messages : 1578
    #111821

    setenv

    henes

    • Messages : 2606
    #111822

    Oops, comme fab le dit :

    setenv usb-enable? false

    Et printenv pour obtenir la liste de toutes les variables existantes.

    pat

    • Messages : 30
    #111823

    Merci pour vos réponses mais poseidon voit toujours les 2 controleurs usb.

    Je vais essayé avec une carte usb avec chip nec D720101F1.

    A+ pat

15 sujets de 1 à 15 (sur un total de 18)

  • 1
  • 2
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Matériel MorphOS 1.4.5 et l’USB 2

Do NOT follow this link or you will be banned from the site!