[RESOLU] OS 3.2.1 : Crash Pref « Font »

10 sujets de 1 à 10 (sur un total de 10)

  • Mahen

    • Messages : 51
    #363593

    Salut tout le monde,

    j’ai besoin d’un coup de main pour un souci qui arrive sur une installation d’Amiga OS 3.2.1 / Kickstart 3.2.1 sur 1200 émulé (même souci sur MiSTer FPGA et sous FS-UAE, les deux en mode 68020/AGA).

    –> le changement de polices via Prefs/Font crashe systématiquement quand je clique sur certaines polices, par ex. Diamond. <--

    Code erreur : 80000004

    MAIS cela n’arrive pas sur une installation antérieure de la 3.2.1 (sauvegarde, donc même hardfile à la base) qui pour le coup n’avait eu aucun ajout ni aucune configuration.

    Donc, qu’est-ce qui diffère entre les 2 installations ? Ben mon installation courante a reçu plein de trucs pour un usage de base, mais absolument rien de sale, et je n’ai ajouté aucun patch ni modifié de biblio système. Parmi tout ce que j’ai ajouté (et désactivé à tour de rôle pour essayer de trouver le coupable) : MUI, Picasso 96, WHDLOAD, RoadShow, Reqtools et qques autres trucs.

    J’ai recopié toutes les LIBS: et FONTS: d’origine. J’ai viré toutes les préférences. J’ai tout désactivé dans DEVS: et dans les startup. J’ai monté les buffers et la stack. J’ai tout essayé. Cf. un thread que j’ai ouvert sur EAB mais pour le moment par de réponse probante : http://eab.abime.net/showthread.php?p=1524915

    Mais voilà, ça crashe toujours, à tous les coups. Et ça ne crashe pas sur mon install d’origine, grrrr ! Vous allez me dire : pars de ton install qui marche, ajoute les trucs un à un jusqu’à ce que ça crashe… Relouuuu !

    Accro de manière totalement déraisonnable à l'Amiga depuis 1993...

    Mahen

    • Messages : 51
    #363600

    COUPABLE : DEVS:Monitors/Native

    Bon diou, quel pas doué, j’ai tout désactivé sauf ce monitor (qui n’avait pas d’icône….).

    Alors pquoi ça faisait crasher le sélecteur de polices c’est une autre histoire…

    Accro de manière totalement déraisonnable à l'Amiga depuis 1993...

    Yoda

    • Messages : 1429
    #363604

    🙂

    Suivez BoingBall.net Chronicle - Toute l'actualité Amiga en continu !

    Gribouille

    • Messages : 92
    #363605

    Hello,
    Merci pour l’info.
    Comment quoi, faut être persévérant.

    A1200 avec ACA1233n-40
    Lecteur GOEX drive et OLED display.

    Mahen

    • Messages : 51
    #363610

    Ouais c’est un truc qui m’a toujours fait tourner zinzin, les instabilités dont on ne sait pas si elles sont causées par qqchose qui n’a rien à voir. D’où l’envie d’avoir un truc propre / minimaliste / à jour, d’où la satisfaction de voir arriver ce 3.2 quelque peu anachronique, ahah ! Mais finalement utile avec les nouvelles machines FPGA et autres développements récents 🙂

    Accro de manière totalement déraisonnable à l'Amiga depuis 1993...

    Mahen

    • Messages : 51
    #363615

    Précision par rapport au bug : le monitor Native faisait pourtant partie de la distribution de Picasso 96 2.x (pour utiliser le RTG sur AGA – ce dont j’ignore si ça a un intérêt, à part sauvegarder de la CHIP, mais y’a déjà fblit).

    Mais ce truc a évolué significativement sous P96 3.x.

    –> qui a testé P96 3.x sur classic, a fortiori sous Minimig RTG ? Cela a-t-il un intérêt ?

    Accro de manière totalement déraisonnable à l'Amiga depuis 1993...

    BatteMan

    • Messages : 6161
    #363617

    Aucune idée pour toutes les questions posées mais j’adore ce genre de fil de discussion, même si tu t’es finalement répondu à toi même 😉

    Bien joué Calagan pour cette traque de bug !


    /me aime comment un rien peut faire n’importe quoi 😀

    Only Amiga makes it possible !

    stephbb75

    • Messages : 430
    #363623

    Salut,

    Oui si tu a fblit et native en même temps cela plante !
    En gros, il font (presque) la même choses.
    Bien que fblit semble plus « puissant »….

    J’avais vue je ne sais plus ou que fblit était déconseillé avec le 3.2 car il fait des truc pas tip top, mais finalement il fonctionne bien 😉

    Steph

    Mahen

    • Messages : 51
    #363624

    Nope, pas mis FBlit en l’occurrence !
    Oui ma phrase était pas claire ; je voulais dire, pour ceux qui n’ont pas de carte graphique et qui veulent sauver de la chip, pas obligé de foutre P96+Native ils peuvent utiliser FBlit, mais effectivement les devs du 3.2 suggèrent de faire le contraire pour avoir un système plus propre 🙂

    Accro de manière totalement déraisonnable à l'Amiga depuis 1993...

    Anonyme

    • Messages : 66
    #363657

    fblit est vraiment dépassé et met vraiment la merde avec le 3.2
    oublie direct
    si tu veux un affichage vraiment super rapide sans bugs, change la icon.library et met p96 3.2.1

10 sujets de 1 à 10 (sur un total de 10)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général [RESOLU] OS 3.2.1 : Crash Pref « Font »

Amiga Impact