[Utils] AmigaAMP 3.21

12 sujets de 1 à 12 (sur un total de 12)

  • Aladin

    • Messages : 1087
    #280757

    http://www.amigaamp.de/

    AmigaAMP relased in the Version for 3.21 PPC/OS4.x and 68k/OS3.9.

    Changes:

    * Replaced connection popup window with info in title bar (reaction) or info line (skin mode).
    * ReAction: Added iconify gadget to main window.
    * Fixed long filename handling.
    * Set default for « Show TagEditor » to FALSE. If this setting doesn’t exist in the prefs file then info window will not be shown.
    * 68k: Fixed internal memory overflow when calculating plugin data.
    * « Engine » part of amigaamp.prefs is now compatible with AmigaAMP2.
    * 68k: Changed visualisation routine to support high resolution and peak-dots.

    Tarzin

    • Messages : 1879
    #350381

    Je cherche à faire fonctionner la version 3.27 sur un A1200 avec WB 3.1.4 sans carte graphique.
    J’ai téléchargé l’archive d’AmigaAmp, la mpega.library, xad.library

    1) Quand je le lance, ça plante. Quand j’exécute les préférences, il m’est indiqué qui’il manque windows.class
    Avec snoopdos, il m’est indiqué qu’il manque plein de classes dans gadget.

    J’ai dans l’idée qu’il me manque un truc dans mon installation (un truc genre gadtools.lbrary que je ne trouve pas sur Aminet)

    2) il est requis également la popup.library, ça se trouve où tout ça?

    Bon sinon, l’objectif est de tenter de lire un MP3 sur A1200+68030, pas sûr que ça tourne…

    Tarzin

    • Messages : 1879
    #350396

    Je viens de voir qu’il y a Eagleplayer 2.06 qui est dispo depuis ce jour sur Aminet, vais tester celui-ci.

    Jedi

    • Messages : 1134
    #350397

    En 2000, sur mon A1200 + Typhoon 1230 à 40 MHz sans carte graphique, j’utilisais SongPlayer :

    http://aminet.net/package/mus/play/SongPlayer

    Et les MP3 passaient mais en baissant la qualité… 🙂

    (j’ai eu ensuite rapidement une Blizzard 1260 où là ça passait nickel en haute qualité)

    Après (2001), c’est sûr qu’avec Mediator et carte graphique Voodoo3-3000 + Sound Blaster 128 + Blizzard 1260 à 64 MHz, je n’utilisais plus qu’AmigaAMP 😉

    Et j’utilise encore régulièrement AmigaAMP (version 68k) sur MorphOS ^^

    Lion

    • Messages : 1311
    #350409

    d’après la doc :
    AmigaAMP makes use of the following 3rd party code
    ————————————————–
    AHI Audio System © Martin Blom
    MHI © Paul Qureshi, Dirk Conrad and Thomas Wenzel
    mpega.library © Stephane Tavenard
    asyncio.library © Magnus Holmgren
    sndfile.library © Erik de Castro Lopo, ported by Sigbjørn Skjæret
    popupmenu.library © Henrik Isaksson
    guigfx.library © Timm S. Müller
    XAD © Dirk Stöcker
    AmigaAMP preferences © Daniel Westerberg
    MPEG Layer-3 technology licensed by Fraunhofer IIS and Thomson Multimedia

    et aussi plus loin :
    Absolute minimum requirements (not included in this archive!)
    ————————————————————-
    AmigaOS 3.1 or higher
    68020 processor or better
    asyncio.library (Aminet:dev/c/AsyncIO.lha)
    AHI audio system (Aminet:mus/misc/ahiusr.lha)

    For non-skinned GUI, info window and preferences to work
    – ClassAct 3.3 or AmigaOS 3.9

    For MP2/MP3 support on 68k systems (optional)
    – mpega.library (Aminet:util/libs/mpega_library.lha)

    For AIFF, WAV and 8SVX support (optional)
    – sndfile.library v1

    For HTTPS support (optional)
    – AmiSSL v4.3

    je suppose que tu dois donc au min avoir ClassAct3.3 d’installer sous OS3.1.
    L’ami Foul avait un site ftp accessible avec les libs mises à jour mais apprement il n’est pluis dispo http://amiga.foul.fr/index.php mais il y a aussi http://www.amiga-storage.net/ en marge d’Aminet

    Lion

    • Messages : 1311
    #350410

    la popupmenu.library est dispo dans l’archive wbstart -> http://aminet.net/util/libs/WBStart.lha

    Tarzin

    • Messages : 1879
    #350412

    Merci pour tout ça lion, j’avais vu cette partie dans la doc mais j’ai sauté le passage Classact!
    Je teste cela ce matin et vous tiens au courant

    Tarzin

    • Messages : 1879
    #350415

    J’ai pour le moment laissé tomber AmigaAMP à cause de ClassAct, visiblement, ça fait mélange avec certaines classes du WB 3.1.4 (le 3.2 solutionnerait ce problème)
    J’ai testé EaglePlayer et SongPlayer qui n’ont pas du tout les mêmes perforamances (Songplayer s’en tire mieux)

    Je pense que je vais devoir convertir certains MP3 pour les ‘dégrader’ afin que le 030 s’en sorte.

    CrashMidnick

    • Messages : 2233
    #350455

    Je viens de refaire un WB3.1.4 update1 (avec ROM 3.1.4) et j’ai le même souci avec la dernière version d’AmigaAmp = windows.class introuvable.
    En vérifiant avec le shell, ma version installée est supérieure à celle requise. J’ai installé toutes les dépendances possibles et rien à faire, il plante toujours sur cette class. Je suis retourné à mon ancienne version d’AmigaAmp (2.25) et tout roule.

    Pour le moment je suis sur winUAE avant de transférer tout ça dans mon A500 mais d’une manière générale je suis bien déçu du 3.1.4 si les problèmes ne viennent pas d’UAE = Scala plante, tornado3D plante, conso abusive de la chipram (même avec fblit/ftext/fastrom etc…), rien de bien nouveau et pas franchement visible à l’utilisation.

    /me qui ne rachètera pas de combo 3.1.4.

    EndCLI >NIL:

    Tarzin

    • Messages : 1879
    #350462

    Merci pour l’info, je vais télécharger la 2.25 et voir ce que cela donne par rapport à Songplayer et Eagleplayer.

    CrashMidnick

    • Messages : 2233
    #350466

    Si tu veux lire du mp3 avec un 030 faudra réduire un max la qualité (mono 22k ou 11k), tu risques d’avoir des coupures quand bien même.

    Sinon tu peux essayer song player 1.53 (http://hostuje.net/file.php?id=8af04980d0264b3ca33ccdce64ad8156) et désactiver AHI (pas possible sur les versions supérieure) et tester cette lib de remplacement : http://meynaf.free.fr/pr/mpega030.lzx.

    Pour les petites config, un MAS player est idéal pour lire du MP3.

    EndCLI >NIL:

    Tarzin

    • Messages : 1879
    #350486

    Bon, pour le moment Amigaamp 2.25 démarre mais j’ai un beau plantage à la lecture du MP3.
    Faut que je vérifie les paramètres. Pour le moment:
    – AHI, unit 0: Paula Fast 8bit stéreo++
    – Forçage de l’utilisation de Mpega.library
    – J’ai mis la qualité à medium pour MP2/MP3
    – Fréquence maximale passéée à 24000 au lieu de 48000
    – Désactivation de l’utilisation de skin de base

    J’ai testé vite fait avec un MP3 avec 128kbps

12 sujets de 1 à 12 (sur un total de 12)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général [Utils] AmigaAMP 3.21

Do NOT follow this link or you will be banned from the site!