Perfect Paint : version pre-68k-fix

Marco ‘Blackbird’ Möring a mis en ligne une première version de sa conversion de Perfect Paint qui permet de le faire fonctionner sur AmigaOS 4.0 et MorphOS.

Perfect Paint était développé à l’origine par Georges Halvadjian en BlitzBasic. Blackbird a porté ce dernier vers AmiBlitz2 en évitant d’utiliser les CIAs d’origine de l’Amiga afin de le faire fonctionner sur les nouvelles machines.

La version actuelle est provisoire et contient encore quelques erreurs mais les fonctions de base devraient déjà être utilisables. La liste de ce qui fonctionne et de ce qui reste à faire se trouve dans le fichier ItschiWitschi.txt (en allemand).

Site internet : http://www.blackbird-net.de/

Télécharger : PfPaintV2-93fix.lha (AmigaOS 4.0 & MorphOS) [3,1 Mo]

(14 commentaires)

Passer au formulaire de commentaire

    • BatteMan on 12 février 2006 at 22 h 58 min

    Rah !! Que du bonheur ! Vivement la version finalisée, mais ça tourne déjà autrement mieux.


    /me est E-R-E.

    • BatteMan on 13 février 2006 at 9 h 22 min

    Bon, j’ai quand même des soucis avec les « menus » qui ne s’affichent qu’un dixième de millième de seconde de temps à autre (pour charger, sauver par exemple, mais aussi le menu des polices de caractères). Et j’ai également quelques bugs graphiques sur les icones des outils une fois que je les ai sélectionné.

    Par contre, c’est le jour et la nuit par rapport à la version BB sous MOS, et dans le bon sens.

    Vivement bientôt donc !


    /me adore ce genre de petites surprises (même si ça avait été annoncé en septembre).

    • crisot on 13 février 2006 at 10 h 38 min

    Can’t find render.library

    bon, je la récupère…

    Can’t find guiggfx.library

    elle est dans la meme archive, ça tombe bien, je l’installe…

    Can’t find pfpaint.font

    Elle est dans le rep, il pourrait faire un effort! Bon, je la copie.

    Can’t find ttengine.library

    Nom de dieu!!! D’autant que cette lib ne sert à rien sous Os4! Bon, je fais un effort, je vais la choper!

    Can’t find jpeg.library

    J’hurle 3 fois tellement ça me gonfle, mais je la chope quand meme, après tout, ça ne fait que rajoute une pref de plus pour bien pourrir le systeme.

    Can’t find xpk.library

    Bon, je suppose qu’il vas me demander d’installer 23 whateveryouwant.library, que je vais devoir réinstaller un Os3 par dessus mon Os4, booter sans startup, et le lancer en tenant la souris dans la main gauche en faisant le poirier, en allumant des bougies aux 4 coins de mon appartement pour invoquer Zeus… J’ai abandonné.

  1. Whoaw, je n’espérais plus, quelle bonne nouvelle ^^

    .. plus qu’un tracker potable, et je suis au paradis 😉

    • elwood on 13 février 2006 at 11 h 21 min

    @Crisot

    😀 😀 😀

    @Fenrix

    Merci pour la trad.

    • fenrix on 13 février 2006 at 11 h 32 min
      Author

    @ Crisot
    Pas de problème de ce genre sur MOS

    Vu que le gars développe sur AOS4 apparement, c’est quand même étrange…

    @ Batteman
    j’ai bidouillé pendant 10 minutes hier soir et je n’ai pas remarqué de problèmes de ce genre ici. Par contre les effets sur les textes ne fonctionnent pas.

    C’est quoi la version BB?

    • crisot on 13 février 2006 at 11 h 50 min

    Pas de problème de ce genre sur MOS

    Non bien sur, MOS invente les library manquante et les fonts, c’est bien connu. Meme si t’a pas la render, meme si t’a pas la guigfx, meme si t’a pas xpk, ça créé les libs sur le disque et ça se lance. 😀

    • DaddyDav on 13 février 2006 at 11 h 52 min

    Can’t find ttengine.library

    Nom de dieu!!! D’autant que cette lib ne sert à rien sous Os4! Bon, je fais un effort, je vais la choper!

    pfff l’avantage de cette lib c’est quelle existe pour 68k, Aos4 et MOS donc permet de faire du portage…

    Oui je sais t’en a rien à foutre de porter les applications…

    • crisot on 13 février 2006 at 12 h 00 min

    Je vais finir par croire que plus auccun Amigaiste sur cette planète ne pige le second degrée.

    Quoi qu’il en soit mon rien à foutrisme vas encore beaucoup plus loin que ça

    • BatteMan on 13 février 2006 at 12 h 01 min

    Crisot : Sûrement que MorphOS a déjà ses bibliothèques d’origine.

    Parce qu’ici, ça s’est aussi lancé du premier coup… Après, peut-être que j’avais déjà installé tout ça avant… C’est possible. Mais comme ça fait plus de 3 ans que j’ai ma machine et mon OS, forcément, j’ai oublié depuis.


    /me ne se souvient plus, il a la mémoire qui flanche.

    • petrol on 13 février 2006 at 12 h 02 min

    Pas de problèmes particuliers ici sur OS4. J’avais tout ce qu’il fallait. Ca bloque le programe seulement sur raytracer. Sinon, l’ajout de couleur un peut partout le rend plus sypathique.
    Ah oui une chose m’a surpris. La taille du tirroir une fois décompressé (11MB 😮 )

    Petrol

    • fenrix on 13 février 2006 at 12 h 42 min
      Author

    je n’ai pas la xpk.library installée et il ne m’embete oas pour ça. Pour le reste, comme Batteman.

    Enfin franchement raler pour ça…

    Je vais conseiller au programmeur d’aller développer ailleurs, vu que ça a l’air de faire plaisir.

    • BatteMan on 13 février 2006 at 13 h 15 min

    Fenrix : Bizarre, parce que les soucis décrits plus haut arrivent assez facilement chez moi.

    La version BB, c’est la version BlitzBasic d’origine de Georges, à différencier de la version AB2 pour AmiBlitz2 de Blackbird 😉

    Bon, vivement la suite quand même, mais ça fleure bon tout ça.

    [EDIT]
    Tiens, j’ai aussi remarqué que certains boutons ne fonctionnaient pas chez moi (genre le « x2 » « /2 » dans la taille de l’image), ou encore le choix effectué dans le requester pour les chemins, dans les préférences, n’est pas mémorisé.
    [/EDIT]


    /me est content, et est comme Highlander, il attend un tracker digne de ce nom.

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!