MorphOS 4.1 par #Amigazeux

Une nouvelle version d’OS4Emu vient de voir le jour, il s’agit de la version 2.0, apportant quelques ajouts et corrections de bugs.

  • newlib.library amélioré,
  • implémentation des fonctions DOS 64bit d’OS 4.1,
  • implémentation des fonctions Exec d’OS 4.1,
  • implémentation des fonctions Picasso96 d’OS 4.1,
  • amélioration de la compatibilité,
  • correction du loader ELF.

Les appels DOS 64bit sont supportés dans MorphOS 1.x mais la taille des fichiers est limité à 2 Go. Dans MorphOS 2.x, les appels natifs DOS 64bit sont utilisés.
L’Altivec est supporté uniquement dans MorphOS 2.

L’ancien loader ELF avait de nombreux bugs et certaines relocalisations dans les exécutables étaient calculées de façon incorrectes causant des plantages. Plus de types de relocalisations sont également supportées et l’erreur « file not executable » ne devrait plus apparaître. Le linkage dynamique n’est pas supporté (ce qui empêche les titres SDL de fonctionner par exemple).

Picasso96 implémente désormais p96WritePixelArray() complétant ainsi l’émulation.

La Warp3d.library permet de n’exécuter que certains programmes Warp3D natifs OS4 et couvrent les fonctions jusqu’à la version 4. Les extensions Warp3D Nova ne sont pas supportées.

L’application.library est expérimentale est uniquement incluse pour test.

Télécharger : os4emu.lha (MorphOS) [200 ko]

Merci également à Falcon1 pour avoir soumis cette information.

(7 commentaires)

Passer au formulaire de commentaire

    • serge on 14 juillet 2008 at 14 h 43 min

    Je suis curieux de savoir si cette version permet de lancer Cygnix.
    Ce serait vraime bien d’utiliser Cygnix OS4 à défaut d’un X-window natif.

  1. Je suis curieux de savoir si cette version permet de lancer Cygnix. Ce serait vraime bien d’utiliser Cygnix OS4 à défaut d’un X-window natif.

    non ça ne marche pas, et Itix ne semble pas très motivé n’étant pas vraiment intéressé par cygnix lui même.

    Pas réussi à faire tourner TuneNet et Epistula, les deux applis qui m’intéressaient. Dommage.

    • centaurz on 14 juillet 2008 at 15 h 17 min

    @SoundSquare
    Tunenet a besoin de la pthreads.library (incluse dans OS4 depuis la dernière maj, fonctionne peut-être avec la vieille version sur os4depot ?) ainsi que d’AISS, et utilise probablement abondamment l’application.library.

    • K-L on 14 juillet 2008 at 17 h 13 min

    TheFab: pas mal le jeu de mots de la news 😉

    A note qu’aucune appli SDL ne fonctionne non plus (pas d’OWB).

    Je dirais que les anciennes applis sdl fonctionnent encore. Seules celles utilisant les shared objects ne sont pas supportées j’imagine (me demande pourquoi il n’a pas ajouté le support des .so d’ailleurs).

    • K-L on 14 juillet 2008 at 17 h 48 min

    Y a eu un loupé dans la réponse (édité plutôt que répondre)? 😀

    • serge on 14 juillet 2008 at 19 h 57 min

    l’interêt pour OWB en ce qui me concerne est NULL puisque Sputnik fait tout en mieu et plus rapide et plus intégré.
    Par contre, un coup d’Abiword aurait été vraiment un PLUS.
    Comme SSQ, les rares applis OS4 qui m’interessent et qui n’existent pas sous MOS, bah elles ne fonctionnent donc pas avec OS4emu. 🙁
    /me est déçu.

    • LorD on 15 juillet 2008 at 11 h 36 min

    juste pour dire que OWB, bien que très insuffisant et pas très véloce, affiche mieux les sites que Sputnik et son moteur Javascript semble bcp mieux fonctionner… pour le moment j’espère 😉

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!