Wazp3D beta 55 disponible

Alain Thellier vient de rendre disponible Wazp3D beta 55, une bibliothèque permettant une compatibilité avec la bibliothèque Warp3D, l’API 3D de Haage & Partner. Cette nouvelle version est la première à être compatible MorphOS (même si la compatibilité n’est pas aussi bonne, pour le moment, que sur les autres plates-formes).

Wazp3D beta 55 pour Amiga 68040 et plus, OS4, MorphOS et WinUAE est disponible sur Aminet.

 

Télécharger : Wazp3D.lha (AmigaOS 68020-40, AmigaOS4, Aros et MorphOS) [1,4 Mo]

(24 commentaires)

Passer au formulaire de commentaire

    • leo on 3 janvier 2014 at 11 h 26 min

    C’est avec ou sans accélération 3D ?

    • on 3 janvier 2014 at 13 h 00 min

    Merci Allain 🙂 Et bravo pour ton travail !!!

    • Sa on 3 janvier 2014 at 15 h 18 min
      Author

    Je m’excuse auprès d’Alain Thellier mais je suis un peu déçu, ça ne supporte que très partiellement les applis Warp3D…wipeout 🙁
    On est loin de GOA 3D qui enterrait littéralement l’API originale (bon ce n’était pas un gros défit).

    /me rêve d’un retour de GOA supportant le R300.

    • K-L on 3 janvier 2014 at 22 h 18 min

    Sa : Alain explique pourquoi sur meta-motphos.fr

    • leo on 4 janvier 2014 at 12 h 12 min

    K-L: tu as un lien ?

    • K-L on 5 janvier 2014 at 0 h 24 min

    Léo : sans déconner….

    http://www.meta-morphos.fr/viewtopic.php?topic=1415&forum=52

    Comme quoi Papi a encore du boulot pour faire connaître ce superbe site.

  1. Merci K-L pour le compliment, c’est en grande partie grâce à toi si il a vu le jour 😀

    Le tiens est très bien aussi 😉

    • thellier on 6 janvier 2014 at 13 h 03 min

    @Sa

    Crois bien que je suis decu aussi…
    Mais moi en plus d etre decu je me suis aussi casse’ la tete a essayer
    de trouver les bugs pour le faire (un peu) marcher
    Apparemment le probleme vient que la library est pas wos comme il faut…
    Mais la ca depasse largement mes connaissance ( presque nulle) du dev sur morphos
    Esperons que BSszili, qui avait fait fait le portage initial de wazp, saura corriger ce probleme
    Alain

    • Sa on 6 janvier 2014 at 13 h 15 min
      Author

    @Alain : Je me doute qu’en tant que développeur ce n’est pas satisfaisant.
    Excuse ma déception, mais j’avais cru comprendre que tu abandonnais le projet et que tu passais définitivement à autre chose, si BSzili se penche sur le (les ?) problème alors l’optimisme est donc de nouveau de mise. 😉
    Après l’abandon de GOA, Henes ne semblant pas du tout motivé à en réaliser une version R200/R300 (c’est vrai que c’est sûrement beaucoup de boulot pour une poignée de softs) je croyais que nous pouvions définitivement faire une crois sur Wipeout, Heretic 2 et autre Shogo.

    • thellier on 6 janvier 2014 at 19 h 25 min

    >j’avais cru comprendre que tu abandonnais le projet (Wazp3D)

    C’est pas faux… mais je suis sympa 😉
    Moi mon but avec Wazp3D c’ étais de pouvoir développer pour Warp3D dans WinUAE. Si QuarkTex avait marché correctement alors jamais j’aurai écris mon propre wrapper Warp3D (le futur WaZp3D)
    Depuis lors ça fait longtemps que Wazp3D marche tip top sur WinUAE en hardware 🙂 donc Moi je suis satisfait (pour moi Wazp3D/WinUAE est PARFAIT)

    Par la suite si j’ai fait UAE pour Aros / OS4 / Morphos c’est juste pour faire plaisir aux Amigaistes sympas

    BSzili s’est proposé pour porter Wazp3D sur Morphos et je lui ai proposé de l’aider. Il est arrivé à faire fonctionner le rendu soft de Wazp3D
    Puis j’ai ajouté le rendu hard OpenGL de Aros à cette version
    Ensuite j’ai enlevé ou patché qques erreurs….

    Mais au final je m’y connais pas plus que ça en dev sur Morphos…
    Donc dès que les bugs sur Morphos concernent pas la 3D je suis un peu largué…

    Mais Wazp3d_Morphos c’est potentiellement pas un mauvais produit car Cow3D ou BlitzQuake tournent hyper vite sur Morphos

    Alain

    • thellier on 6 janvier 2014 at 19 h 33 min

    >pour moi Wazp3D/WinUAE est PARFAIT
    La preuve:

    • henes on 6 janvier 2014 at 21 h 25 min

    > Henes ne semblant pas du tout motivé à en réaliser une version R200/R300

    Ca marche depuis des années sur r200.

    • Sa on 6 janvier 2014 at 21 h 35 min
      Author

    erreur, je voulais dire R300/350.

    • leo on 7 janvier 2014 at 9 h 54 min

    Moi je pense qu’il faut juste qu’Henes se penche dessus. C’est bien celui qui doit avoir le plus d’expérience 😉

    • serge on 7 janvier 2014 at 10 h 36 min

    + 1 😉

    • serge on 7 janvier 2014 at 10 h 40 min

    il y a aussi cette question dont Henes doit avoir une petite idée de comment faire 😉
    Je cite Alain sur Meta-morphos.org

    « Un des plus gros problème est le manque de perspective-texturing car TinyGL ne supporte pas glTexCoordPointer(4,…); »

    • Sa on 7 janvier 2014 at 15 h 18 min
      Author

    Henes à surement une vie sociale, tout le monde n’a pas la capacité de dormir 15 mins par nuit comme Fab 😉

    • thellier on 7 janvier 2014 at 15 h 38 min

    BSzili vient de m envoyer un correctif (source) : je compile ca demain
    et on verra si ca change qque chose….

    Alain

    • Sa on 8 janvier 2014 at 16 h 50 min
      Author

    Alors Alain, il y a du mieux ?

  2. J arrive pas a compiler le correctif : ca connais pas la struct EmulHandle
    je cherche et je reessaye ce soir

    • henes on 9 janvier 2014 at 10 h 54 min

    include emul/emulinterface.h
    include emul/emulregs.h

    • thellier on 11 janvier 2014 at 8 h 21 min

    Merci Henes
    La ca compile mais ca marche toujours pas…
    BSzili cherche….

    • serge on 11 janvier 2014 at 13 h 12 min

    Serge qui traîne dans les parages silencieusement à l’affût d’une nouvelle release 😉

    • Sa on 11 janvier 2014 at 15 h 16 min
      Author

    Merci Alain de finalement persévérer.

Les commentaires sont désactivés.

Do NOT follow this link or you will be banned from the site!