A-One + OS 4.0: topic officiel [1]

15 sujets de 1 à 15 (sur un total de 47)

  • Tigrou

    • Messages : 276
    #883

    Bon, vu que l’autre thread est parti en live, en voici un nouveau, premier d’une (je l’espère) longue série :-). Voici ce qui fonctionne donc très très bien chez moi:

    -le Net (ADSL, iBrowse, Voyager, Yam, A.Web)

    -TV Paint

    -MakeCD

    -les dockies (marrant, c’est très « MacOS-style » :-))

    -le visionnage Mpg et Avi

    -Wordworth ne veut pas s’installer, mais ça marche chez les autres (quelques assign à revoir ;-))

    L’ensemble est très rapide, d’une réactivité plutôt impresionnante (affichage des grosses z’images en instantané…)

    -Une orgie de détails pour la personnalisation du bureau

    Quelques trucs à corriger:

    -Une certaine lenteur lors de l’effacement de fichiers

    -Quelques bugs graphiques au niveau d’Amidock

    -Quelques plantages sous iBrowse et Voyager lors d’une orgie de Javascript ou d’un protocole SSL trop poussé.

    C’est tout pour le moment :-)

    Tigrou

    anonyme

    • Messages : 8171
    #23657

    Pour les fichiers. Faudra voir en DMA sans doute.

    Pour Amidock, de quels buggs graphiques parle tu? Il n’a pas de buggs à proprement parler, par contre il n’a pas de vrai layer, donc faut pas toucher au fond (déplacer une fenetre en dessous, etc…), sinon ça fait moche.

    Pour IB: Lorsqu’un Javascript traine, IB fige une minute (en fait il bosse) puis il t’affiche une requete pour annuler ce JVS. Est ce ton problème? (IB qui ne répond plus). Ou est ce que ça plante vraiment?

    Voyager ne fonctionne plus depuis 3 ans, ne fonctionne pas, et ne fonctionnera sans doute jamais.

    anonyme

    • Messages : 8171
    #23658

    Salut !

    Voyager a tendance a « fige » un peu:-)

    Mais, il reste, à mon avis le plus compatible (niveau SSL, JS, HTML

    …). Certains site passe pas tu tout avec IB et d’autre affiche

    n’importe quoi avec Voyager…

    Les deux a mon avis se valent:

    – Voyager a des crash complement aléatoire (du mois jamais réussi a

    reproduire proprement)

    – IBrowse crash précisement sur certain site :-)

    Mais V crash aussi dans des cas précis. Et inversement, IB a des crash

    aléatoire. Alors bon…

    Bref, il faut les 3 (+AWeb) pour arriver a naviguer !

    Sinon, c’est IBrowse complet ou démo fournit avec l’OS4 ?


    @Tigrou
    : Tu as toujours des patch dans WBStartup ?

    Bye

    Tigrou

    • Messages : 276
    #23659

    Hello,

    Crisot/Nico: iBrowse plante carrément. Sur eBay, par exemple, je ne peux pas accéder à mon compte (alors que je peux avec Voyager); ça m’affiche la requête de débug (kill, ignore errors, etc…). Dans, euh allez, 60% des cas, la tâche en cours est récupérable, sinon, c’est reboot obligatoire (heureusement que ça ne me prend que 25 sec ;-)).

    Pour Voyager, il fonctionne bien. Quelques plantages aléatoires, comme le dit Nico, mais rien de bien méchant. On le sent un peu plus lourdaud qu’iBrowse. Les deux se complètent bien au final…

    Pour iBrowse, il s’agit de ma version enregistrée; selon la source que je récupère (celle sur disks, celle sur Aminet, ou celle sur le site de iOspirit), soit il plante peu, soit il plante tout le temps. J’utilise désormais la moins restrictive ;-)

    Pas de patchs dans la WB Startup, si ce n’est ceux pré-définis lors de l’installationde l’OS 4.0.

    Pour ce qui est d’AmiDock, c’est pas bien méchant; il s’agit de bouts de fenêtres qui restent dans la barre de docks, parfois au cours des utilisations. Un petit « refresh-fresh, exciting », et tout s’arrange. Un bug réellement mineur, en sorte.

    Le plus déroutant reste en effet la lenteur d’effacement de fichiers…

    A+

    Tigrou

    anonyme

    • Messages : 8171
    #23660

    @Tigrou:

    Merci de ta réponse!

    C’est quoi, justement les patchs prédéfinis ?

    Tigrou

    • Messages : 276
    #23661

    Re :-)

    Nico: les patchs inclus d’office sont l’AmiDock, ASyncWB, Deficons et RAWBinfo. Rien qui ne puisse justifier en fait la lenteur d’effacement de fichiers :-/. Si ce n’est le DMA

    Au passage, Boum (le démineur de Stan) ainsi qu’ArTkanoïd fonctionnent impecc’. Pour ce dernier, bien penser à récupérer les render.library et guigfx.library sur la Minette, dans dev/misc…

    Tigrou

    anonyme

    • Messages : 8171
    #23662

    Je suis sûr qu’un jour on dira qu’Intuition est un patch… Enfin.

    Lanza

    • Messages : 895
    #23663

    ASyncWB, Deficons et RAWBinfo sont bien des patchs puisqu’ils remplacent des comportements par défaut du système et s’amusent avec setfunction.

    AmiDock par contre n’en est pas un à priori.

    anonyme

    • Messages : 8171
    #23664

    Intuition est un patch…

    anonyme

    • Messages : 8171
    #23665

    ça vous suffit ?

    Désolé pour les autres, j’ai perdu assez de temps à faire tout ça (grab, uploader….)

    Lanza

    • Messages : 895
    #23667

    Elwood : et puis ? ça reste un patch. Par contre je ne vois pas en quoi ça te dérange. On a bien dit patch, hein, pas hack.

    anonyme

    • Messages : 8171
    #23668

    C’est sûr que si « fonctionnement normal », tu penses un un OS 1.3, alors les datatypes sont un patch, l’AGA est un patch, la doslib en PPC est un patch aussi.

    Et tout le contenu du répertoire Prefs sont des patchs aussi, vu qu’ils altèrent le comportement par défaut du système.

    Vraiment, vous êtes trop forts.

    anonyme

    • Messages : 8171
    #23669

    C’est encore Nico qui à réussi à enflammer le thread, mais pour une fois reconnaissons lui l’avantage de l’innovation : il à réussi à le faire sans parler de DMA.

    Rien que pour ça je l’appaludis tiens….clap clap clap !!! :-D

    anonyme

    • Messages : 8171
    #23670

    Elwood:

    Lors d’un boot un coup, pour je ne sais plus quelle raison, y’a une requete qui s’est ouverte, (comme sur classic donc, en plein boot), et évidement, elle n’était pas skiné (look basic 3.0).

    On m’a sorti que c’était la preuve par A+B que le « skinage » de l’os 4 était un patch :-)

    La vérité, en fait, c’est qu’à ce moment du boot, les préférences ne sont pas encore chargées, et qu’on a donc le look par défaut, tout simplement :-)

    Les autres: Pour ce qui est d’IB 2.3 je suis relativement surpris. Je m’y suis enregistré lors de sa sortie et force est de constater que j’ai du planter en tout et pour tout moins de 10 fois, les motifs étant à chaque fois mon 4000 qui se pétait un délire (tout qui se met à planter, pas seulement IB).

    Je fais de l’ebay, et je gère TOUT avec IBrowse pourtant, y compris la rubriques « mon ebay » :-) D’ailleur je surf exclusivement avec IB 2.3 sur Amiga, et lorsque ça passe pas, je sors le PC.

    Sinon pour le débats « patch », ça peut durer longtemps. Je tiens néanmoins à signaler que la plupart ne fonctionnent que sur 3.5 et 3.9 par ce que l’os avait été « upgradé » dans l’optique d’une intégration plus simple et plus propre de ces patchs qui, si on joue sur les mots, deviennent donc des « extensions ».

    anonyme

    • Messages : 8171
    #23671

    Elwood: nul besoin de délirer sur l’os 1.3,… ce sont des patchs, point. Et alors ? On s’en fou… Pas la peine de s’énerver :)

    (Si ca peut te rassurer, ton « WB+patch » est nettement plus fonctionnel que l’Ambient actuel :))


    @Nico
    : même avec les 3 réunis, je vois pas comment on peut parler de « naviguer » sur Amiga/MOS… Et malheureusement ca va rester longtemps comme ca on dirait: je ne vois pas sortir du Mozilla ou AWeb/KHTML dans un avenir proche :(

    @+,

    Léo.

15 sujets de 1 à 15 (sur un total de 47)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général A-One + OS 4.0: topic officiel [1]

Do NOT follow this link or you will be banned from the site!