Revenir à Émulation et autres OS

Amiga sous Linux via Amikit

Forums AmigaOS, MorphOS et AROS Émulation et autres OS Amiga sous Linux via Amikit

  • Ce sujet contient 21 réponses, 7 participants et a été mis à jour pour la dernière fois par ness62, le il y a 11 années.
15 sujets de 1 à 15 (sur un total de 22)
  • Auteur
    Messages
  • #6553
    fofo
    Participant
    • Messages : 69

    Bonjour,

    suite a un espace restreint je m’essaye d’emuler mon 1200 sur mon pc (linux) avec e-uae, et amikit.

    j’ai donc copié amikit dans mon /home/joffrey/amiga/amikit tous le dossir le concernant

    je lance e-uae, je le configure, mais en fait quand jje laisse juste le dossier amikit dans harddrive de E-uae, il demarre nickel et me propose installer mon os préféré.., donc je selectionne le mien os 3.5 ( je precise qu’il faut bien evidament posseder une rom 3.1 ainsi que le cd origiinal de l’OS 3.5 ou 3.9 :) )

    mais mon cd n’est pas reconnu, je stop donc l’emulateur, retourne dans hard-drive, indique le chemin du cd et la quand je relance je tombe sur un shell??

    peut etre une mausaise config des units?

    Amikit > unit 0

    cd0 > cd3.5 > unit 1

    merci de votre aide, j’aimerai vraiment arriver a demarrer amikit qui a l’air super !!!

    Joffrey

    #106563
    ness62
    Participant
    • Messages : 815

    Essaye ceci :

    Lance Uae a partir d’une console en root

    Pour le chemin de ton Cd

    Place ton cdrom avec le nom du cd ,ce doit être AmigaOs3.5

    #106564
    fofo
    Participant
    • Messages : 69

    j’ai procéder exactement a cette manip cet après-midi, en fait il ce lance, mais sans résultat, j’ai cette page qui resemble a un shell.

    je ne comprend vraiment pas, quand j’indique le chemin du cd, cela ne marche pas, par contre si je laisse le chemin vers amikit uniquement il démarre et me propose le menu, mais ne détecte tjrs pas le cd!

    Joffrey

    #106565
    ness62
    Participant
    • Messages : 815

    as-tu bien pris la version linux de Amikit?

    Pour le mode console en root , je disais çà car il existe un problème de droits sur les fichiers du CD de l’AmigaOS 3.5.

    Me semble que jegougou avait fait l’installation,tes ou mon pote?

    #106566
    Tarzin
    Participant
    • Messages : 1806

    Ah Ness, merci de venir à mon secours.

    Fofo m’avait envoyé un message mais face à Linux, je ne suis d’aucune utilité.

    Sinon, il faudra que Fofo se dirige sur le forum d’AMiKit s’il n’y a pas de réponse donnée ici.


    #106567
    fofo
    Participant
    • Messages : 69

    ok salut les gars,

    bon ça avance ya du mieux et du pire :)

    en fait, j’ai simplement copier le répertoire amikit, que j’ai installer via virtualbox coté xin, en suite j’ai recopié et hop je pensé que c’était bon!! :(

    bon j’ai recommencer l’install linux mais avant j’ai installé la libsdl1.2, (oupps je l’avais oublié) est mon install c’est bien déroule.(sauf au moment ou il fallait mettre le chemin du cd (ex:dev/sc0) la j’ai mis /media/cdrom1

    donc je lance uae, puis rien, j’essaye de recopié juste mes ancien fichier amikit dans hardfiles, puis je l’ai relancé!

    la! je retombe sur le menu qui me propose les differents os, je choisi tjrs le 3.5 et la rien, j’ai beau le mettre dans uae, que dalle !!!!

    pouff, je commence a en avoir marre :(

    Joffrey

    #106568
    ness62
    Participant
    • Messages : 815

    De rien , chef

    Fofo va réussir .

    Quand je vais dans l’arborescence ,je clique et quand je vois tous les répertoires s’afficher c’est ok puis je tape le nom amigaos3.5 dans volume Name et cd rom dans device name .

    Mais bon, il est vrai que l’installation de amikit sous linux me parrait pas simple du tout et de plus comme la doc est en anglais c’est chiant pour moi.C’est a partir de là que l’on se met a crier help a la communauté pour les traductions .

    Sur le forum de Amikit il découvrira une autre façon d’installation qui je pense peut détourner ce problème.

    et si vraiment fofo n’ accroche pas,il lui reste la solution d’un install sous Windows/winuae et de transferer le dossier complet sous nunux ,comme je l’avais fait au début sous mandriva.

    Ajout:

    pouff, je commence a en avoir marre :(

    Meu non ca va aller ,la première fois que j’ai bidouillé Amikit sous linux ,j’ai pris 30 euphitose ,mis des baffes a mon clebs(le pauvre), puis j’ai passé une semaine dans un cadre agréable ,verdoyant ,un tiot bois et des oiseaux ,cool quoi!

    #106569
    fofo
    Participant
    • Messages : 69

    bon,

    Alors, y a du nouveau!!

    j’ai sauvé la partie (hardfiles) est j’ai viré le reste, ensuite j’ai pris l’installeur linux, qui cette fois a demarré, il manqué une lib, donc tout c’est installer, j’ai indiquer le chemin de mon cdrom, j’ai mis dev/cdrom1 (je pense que c’est ça) ensuite j’ai recopié harfiles (fichier amikit pour l’install du 3.5), je lui indique egalement le chemin (en root) puis je choisi os install 3.5 et je demarre puis rien, amiga os

    1 ect que dalle !!!!

    peut etre que j’ai mal configuré le cd, je c’est pas, je c’est plus !!!!

    Joffrey

    j’ai reinstallé en mettant /media/cdrom1 (le chemin du cdrom) et maintenant j’ai :

    prefs/presets/amikit/install/mount/mount failled returcode 20

    #106570
    fofo
    Participant
    • Messages : 69

    Bonjour,

    bon, ça avance:), j’ai effectué une recherche sur le fichier uaerc sur mon dd, j’en ai trouvé 2, un d’une ancienne version, qui ne c’est pas supprimer (dans usr/share) avec le fichier de config uae, en effectuant une nlle sauvegarde, il ma dit que le fichier se triouve dans /home je procède au modif du cdrom ect– esst la il démarre

    Enfin, bon il rame un peu chez moi, j’ai athlon xp 2600+ est 2 Giga de ram pourtant :(

    mais bon, je vais voir, au pire je rinstalle juste le 3.5 avec mes bon vieux jeux favoris, tel slamtilt,pinball illusion,projet x,cannon fodder 2,super stardust aga, la liste est très longue Vive l’AMIGA….

    par contre, comment proceder a l’install de certain jeux non installable avec wbload, comment fonctionne t’il? ou trouver les scrips pour les jeux?

    Merci

    Joffrey

    #106571
    coolcoyote90
    Participant
    • Messages : 471

    Salut Ness !

    Je vous que tu taquines bien e uae ;-)

    Peux tu me dire quelle est la derniere version de E UAE pour linux ( j’ai vu la WIP4 )

    J’ai un ami qui me dit que par rapport à la version WIN UAE, il

    n’y a pas de filtres , donc çà pixelise un peu.

    VOilà

    AMc

    CC90, j’espere te voir le week end du 13

    #106572
    fofo
    Participant
    • Messages : 69

    la deniere version E UAE sur linux est la (a ma connaissance) 0.8.29-WIP4

    Joffrey

    #106573
    mikedafunk
    Participant
    • Messages : 4206

    Il parait que winuae fonctionne vraiment très bien via la couche logicielle wine. (architecture X86 obligatoire, non testé)

    A1220/28 - A1230/50 - A1240/40 - A1260/64 - A500 - A500+Gotek - CD32 - A600 - MOS / Mac mini - Lubuntu / eeepc - http://mikedafunk.over-blog.org

    #106574
    jegougou
    Modérateur
    • Messages : 2516
    #106575
    fofo
    Participant
    • Messages : 69

    j’ai testé, chez moi, j’ai des probleme avec la souris, elle reste figé, par contre e uae la gere tres bien.

    #106576
    ness62
    Participant
    • Messages : 815

    @coolcoyote90

    Je ne suis pas non plus un expert ,disons que je me débrouille et franchement j’ai encore des problèmes a comprendre.

    Je tourne avec un E-uae 08.27 et 08.29 .

    Oui çà pixelise un peu et pour tout dire la version E-uae et moins rapide que Winuae en mode fenétré par contre en overscan c’est a peu près identique. Le clavier a des difficultés a passer en français .La souris y a un bug de temps en temps (en mode fenetré) faut la sortir de l’émulateur et cliquer parfois en haut,bas ,gauche ou droite. Quand je lance un mp3 çà plante.

    A savoir , en émule E-uae et peu importe le pack je ne suis jamais en 68020 mais 68040,le 68060 n’apporte pas grand chose de plus sauf peu être pour des grosses démos en .exe ,8Mo de chip et pas de fast,Z3 a 128 ,la p96 a 8 ou 16Mo.

    Pour les Whdload sous E-uae j’ai pas encore bien essayé.

    Lequel est le plus stable Winuae/Winprout ou E-uae/linux ? ,je parle pas sous OS4 ou Morphos ,hien!

15 sujets de 1 à 15 (sur un total de 22)
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Émulation et autres OS Amiga sous Linux via Amikit

Do NOT follow this link or you will be banned from the site!