Editer startup-sequence. Commande inconnue ?

15 sujets de 1 à 15 (sur un total de 32)

  • bigbernie

    • Messages : 743
    #249529

    Bonsoir

     

    Decidement…

    Je dois editer le user-startup pour assigner des disquettes de jeu.

    Je ne vais pas me servir de Memacs pour ça.

    Je cherche a utiliser ED.

    ED est bien dans C et user-startup est bien dans S

    J’ai le bouquin  Amiga DOS sous le nez

    J’ouvre une fenetre shell  qui m’affiche SYS:>

    Ensuite je tape ma commande

    J’ai donc SYS:> ED:s/user-startup

    Commande inconnue.  L’Amiga et moi c’est pas facile

    Merci

     

    Anonyme

    • Messages : 1528
    #249531

    salut bigbernie,

    Vérification de base, as-tu vérifié la présence de ed dans C ?

    Tu peux éviter les majuscules sur l’Amiga. hé hé

     

    bigbernie

    • Messages : 743
    #249533

    Bonsoir

    J’avais verifie dans C

    En plus de mon bouquin Amiga Dos…pas utilise depuis 20 ans….J’avais regarde aussi dans Obligement

     

    http://obligement.free.fr/articles/editer_startup_sequence_amigaos1.php

    Il met bien ED en majuscules.

    J’ai a la fois mon bouquin Commodore et Obligement qui me donnent la meme commande.

    Je ne vais pas assigner dans la startup mais dans user c’est pareil.

    Je tente de me debrouiller sans poster mais je constate que entre l’Amiga et moi il y a toujours des trucs bizarres.

    J’ai achete la cle WHDL

    Mais je reinstalle  mes jeux sur disquettes.

    Pour CIV je me refabrique donc 4 disquettes neuves. J’instakke et…ça me reclame la disquette 8. Ca aussi je l’avais oublie depuis 20 ans.  CIV 1 depuis disquettes a besoin de se faire assigner les 4 disquettes.   Eh oui. D’ou ED …eh oui encore

    Merci.

     

     

    Foul

    • Messages : 722
    #249534

    CygnusEd stou :p

    Anonyme

    • Messages : 956
    #249535

    Ed, pour les vrai! 🙂

    Anonyme

    • Messages : 1528
    #249536

    Dans le bouquin, ils mettent en majuscule pour mettre en évidence la commande !

    Par contre, bizarre  qu’il ne voit pas la commande.

    Comme si tu avais fait un CD DF0: avant… Mais là encore, pas normal !

     

     

    Sodapop

    • Messages : 1011
    #249539

    j’ai lu vite fait, je suis au boulot, mais il me semble que la commande correcte est:

    ED s:user-startup

    A500 (1.3 / 2.0 / ACA500+) - A2000 - A1200

    cyb0rg

    • Messages : 1004
    #249540

    GoldED, c’est le top ! 🙂

    sinon : c:ed sys:s/startup-sequence

    Only amiga makes it possible
    XTR Games
    Magic Productions
    tilde

    bigbernie

    • Messages : 743
    #249541

    Bravo sodapop

    J’avais donne le lien pour  Obligement qui donne donc une syntaxe incorrecte.

    Ca alors.  Je tente de ne pas questionner s’il est possible de trouver sur des topics. Mais si des commandes sont fausses

    CygnusEd n’est pas nécessaire pour ça. Memacs est bien trop complique.  Bien  que j’ai tout ça d’explique dans Amiga DOS.

    Bon, pour la mauvaise syntaxe je suis scie. En fait Obligement considère que ED est un volume.

    Comme je disais ça n’est pas parce que j’ai achete la cle…que j’aurai dans qq jours pour tester, que j’ai renonce a mes qq jeux sur disquettes installables.

    L’installeur de CIV 1 inclus dans le jeu et pas invente ensuite,  nécessite que le jeu soit assigne. Comme ceci

    ASSIGN CIV1: DHO: Civilization/

    Civ 2  3 et 4

    Un utilisateur basique de l’Amiga ou un jeune joueur en 1994 n’aurait pas ete capable  d’installer le jeu automatiquement.

    Ce jeu, qui deconne de maniere extravagante sous WHDL ( je vais voir plus tard avec la cle)  a une particularite  négative majeure, jamais rectifiée par la suite meme sur les  versions PC sur CD.

    Il est impossible de recuperer un Save sans devoir quitter puis  retourner au DOS.. Sous emulation que ça soit WHDL, DOSBOX ou WINUAE pour prendre  un Save on est oblige de relancer l’emulateur depuis zero.   Et donc dans sa version native avec installeur  sans assignation ça ne peut pas fonctionner.

    Un mega super jeu pour l’epoque, comme Dungeon Master sur Atari mais alors une programmation farfelue.

    Bonne soire et merci.

     

    Anonyme

    • Messages : 1528
    #249543

    C’est un gag ou quoi ?

    Chez moi, ça fonctionne ed s/user-startup !

    J’ai toujours fait comme ça!

    L’autre syntaxe fonctionne aussi bien sûr

     

    __sam__

    • Messages : 3038
    #249549

    J’ai donc SYS:> ED:s/user-startup

    Commande inconnue. L’Amiga et moi c’est pas facile

    Normal: tu as toutes les lettres mais dans le désordre. Tapes
    [code] ED (blanc) S:user-startup[/code]
    le tout sans slash et sans le mot (blanc), hein là tu place un blanc au clavier :P. Bref il faut un blanc entre ED et le S:user-startup.

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    bigbernie

    • Messages : 743
    #249551

    Merci

    J’avais eu diverses rectifications ci dessus.

    Suivre sans reflechir la syntaxe erronée donnée dans Obligement  amène a ça.

    Il faut dire que ce foutu installeur de CivAga  est mal programme car ce jeu oblige a assigner les disquettes.

    Au point de vue programmation, de l’installeur et de la methodologie des saves  c’est vraiment mal ficelé ce jeu.Et pas du tout rectifie dans ses innombrables versions.

    Bonne soiree.

     

    Anonyme

    • Messages : 1528
    #249562

    ah ok, je n’étais pas allé voir le lien.

    Une petite coquille !

    Admin

    bigdan

    • Messages : 4721
    #249573

    Tout le monde à bon, 3 manières de faire dans un shell amigados (du moment que Ed est bien dans le répertoire C: du volume de boot) :

    ed s:user-startup

    ou

    ed sys:s/user-startup

    ou

    ed x

    (ed s’ouvre avec un document vierge « x », ensuite tu n’as plus qu’à charger ton fichier user-startup via le menu et à faire tes modifs puis enregistrer).

    Tu peux aussi vérifier que ton fichier s:startup-sequence lance bien le fichier s:user-startup (à la fin de la startup-sequence).

    C’est beaucoup plus simple d’utilisation qu’un vi de base sous unix ou bsd 😉

    henes

    • Messages : 2619
    #249594

    ou, 4e manières en étant déjà n’importe où dans sys:,
    ed :s/user-startup

    Le deux-points situé au début d’un chemin sert à revenir à la racine du volume courant.

15 sujets de 1 à 15 (sur un total de 32)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général Editer startup-sequence. Commande inconnue ?

Amiga Impact