Revenir à Émulation et autres OS

Commande groupée PCB multi Kickstart (Kickstart 2 pour A500)

Forums AmigaOS, MorphOS et AROS Émulation et autres OS Commande groupée PCB multi Kickstart (Kickstart 2 pour A500)

15 sujets de 151 à 165 (sur un total de 172)
  • Auteur
    Messages
  • #321522
    Killerklown
    Participant
    • Messages : 205

    Killerklown parle de faire de l’asm, mais effectivement la question reste la cible limitée à ceux qui ont un 500 en 3.1.

    Ou alors peut-être ceux qui ont une extension pour l’IDE ou SCSI et la ROM 3.1 gère mieux les disques/partitions de grande taille (pure supposition de ma part…).

    Pour ma part je crois que je vais partir sur :
    => 1.2 (premiers jeux su l’A500)
    => 1.3
    => DiagROM
    => soit Logica (si j’arrive à la faire fonctionner) soit la 2.0

    Pour ma part je pense que la 1.3 et la 2.04 suffiront, je n’utiliserai de toute manière principalement que la 2.04, pour le reste, 2 ou 4, après chacun va utiliser ce qu’il veut, de toute manière je ne suis pas sur non plus que la diagrom sera utilisée très souvent, c’est plutôt une question pratique je pense.

    #321523
    Doctoritchy
    Participant
    • Messages : 855

    la compatibiliter avec un max de jeu c’est la 1.3 , quelque un en 2.04 et rarement en 3.1 (plus pour un wb installer sur cf + whdload , ou des appli sous workbench )  donc je dirais 1.3 /2.04 /3.1 /diagrom ou logica 🙂  (veiller a ce que la 2.04 gere l’ide aussi ! )

    Amiga 500 , ide68k cf 4go sur TV lcd LG 22"
    atari 1040ste 4mo , megafile 44 , megafile 30 , gbs8200 + lcd17"
    Amiga 2000 ,carte ide 8mo fast wb3.1 hdd 15go cdrom
    atari TT030 4mo+64mo +crazydot ecran lcd nec 17" + old computer (xt ,x86 , 2686 , 386 , ect )

    #322105
    Amigars
    Modérateur
    • Messages : 1209

    Ayant reçu les pins expédiés d’un lointain pays…j’ai pu enfin assembler le tout et tester.

    Verdict : ça a marché du premier coup ! Pour le moment j’ai mis les ROMs suivantes : 1.2, 1.3, 3.1.4 (la toute dernière) et le diag Logica. Tout passe impeccable !

    @ Giants : aucun problème avec le ROM de diag Logica…j’ai bien vérifié qu’elle était décryptée et ensuite je l’ai simplement collée aux autres puis byteswap de l’ensemble.

    @Killerklown : un grand merci d’avoir lancé ce sujet car j’ai pu y trouver pleins de conseils et ton fichier de test m’a bien aidé pour voir comment le fichier final devait être.

    PS1 : les ROMs avant la 1.4 alpha 18 ont une taille de 256Ko, donc comme il faut remplir 512Ko par slot le plus simple reste d’assembler 2 fois la même ROM (sous Windows faire par exemple « copy /B Kick1.2.rom + Kick1.2.rom Kick1.2.bin »). J’ai l’impression que c’est ce que tu as fait Giants.

    PS2 : Pour tester mon petit montage avant l’installation dans l’Amiga, j’ai programmé l’EPROM, je l’ai installée sur mon montage et ensuite j’ai basculé mon programmateur d’EPROM pour lire une 27C400 (c’est comme une 27C160 mais 4 fois plus petite, typiquement l’EPROM à utiliser quand on veut juste programmer un seul kickstart). J’ai pu donc relire/vérifier l’EPROM en 4 fois en basculant les 2 DIP switches pour accéder aux 4 banques.

    A500 recap / KS switcher 1.2-1.3-Logica-DiagROM / Ext 512Ko / Gotek Cortex interne / Floppy externe
    A1200 recap / KS3.1 / Fast 8Mo / Floppy / Audio Fix
    Commodore 64 recap + 1541 + JiffyDOS + CRT + Carte mère de secours
    Pi16 (Raspberry Pi dans un boîtier de Commodore 16)
    Un RPI sous Amibian (surprise pour l'Alchimie treize 🙂 )
    CPC 6128 + Floppy externe 3.5" + CTM644
    ATARI 520 STF "stock"
    TO7/70 / Ext 16Ko
    Un PC en WinXP avec WinUAE-TinyLauncher-WHDLoad
    2 PS1, 2 PS2, PS3, PSP, Gamecube, Wii,

    #322109
    Giants
    Participant
    • Messages : 2552

    Impec.
    Ba je sais pas pour la rom logica, j’ai du merder quelque part, je t’avoue ne pas avoir plus que ça creuser le sujet.
    sûrement mon fichier qui n’était pas bon des le départ.

    Tiens d’ailleurs je suis preneur de ton fichier de la rom logica histoire de comparer par rapport a celui que j’ai (ou au pire le crc32).

    Thks

    Région : Yvelines
    Site : http://sasfepu78.fr
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/

    #322127
    Killerklown
    Participant
    • Messages : 205

    Bon, tout le monde a du être livré (à part peut être astro qui le sera lundi au plus tard, par contre pas de retour à part hamstermaniac.

    Du coup je viens aux nouvelles, les autres c’est tout bon ?

    #322157
    Astro68k
    Participant
    • Messages : 270

    Salut Killerclowon,

    reçu aujourd’hui, merci !

    Je testerai la version assemblée sur le 500 que je tente de re démarrer en ce moment. Je te ferai un retour le moment venu (mais ça peut prendre du temps avec moi…)

    #322166
    Mathdea
    Participant
    • Messages : 227

    Tout bien reçu avant hier. Il me reste à tester cela. Merci encore à toi.

    Amiga 500 Rev6
    Amiga 500 Rev5
    Amiga 1200 + MTEC68030
    Amiga 4000/030

    #322194
    Killerklown
    Participant
    • Messages : 205

    Nickel, n’hésitez pas à revenir une fois testé.

    #322218
    Mathdea
    Participant
    • Messages : 227

    Pour sur, dès que cela sera fait, je reviens vers toi. Pour ceux que cela intéresse, il y a ce lien pour la documentation de logica:

    https://www.amigawiki.org/lib/exe/fetch.php?media=de:service:basics:logica_diagnostic_manual_v1.pdf

     

     

    Amiga 500 Rev6
    Amiga 500 Rev5
    Amiga 1200 + MTEC68030
    Amiga 4000/030

    #322254
    Astro68k
    Participant
    • Messages : 270

    Salut,

    une fois n’est pas coutume je suis allé assez vite, j’ai soudé et monté la V1.2 ce soir et ça fonctionne sur mon 500 Rev5 !

    J’ai eu du mal à insérer l’adaptateur dans le support de la CM mais ça semble l’avoir fait finalement faire.

    J’ai eu 1 ou 2 mises sous tension qui m’ont donné l’impression que ça ne démarrait pas, mais c’est vrai que la rom diag surprend au début, c’était peut-être celle-la.

    Reste à tester sur la durée.
    Je vai d’abord recapper le 500.

    Merci Killerclown pour la proposition, le taff réalisé, et ta gentillesse.

    #322410
    Killerklown
    Participant
    • Messages : 205

    Salut,

    Nickel, par contre il faut recaper aussi la rev 5 ? Je pensais que ça démarrait à la rev8 et le 500+

    #322414
    Astro68k
    Participant
    • Messages : 270

    Salut,

    bonne question, je ne me l’était pas posée en partant du principe qu’à long terme c’était toujours bon à faire, même si les 500 sont « costauds ».

    J’ai prévu de faire le Rev8a quand j’aurai regardé s’il veut bien repartir. Je n’étais pas non plus au courant qu’il fallait le faire plus sur cette rev que sur d’autres.

    Des avis de spécialistes ?

    #322416
    Amigars
    Modérateur
    • Messages : 1209

    Non aucune rev de l’A500 n’a le risque d’avoir ses condensateurs couler car ce sont des capacités en techno « traversante » et fiable :

    Ce type de capa a tendance plutôt à « sécher » et à se mettre en court-circuit, mais pas seulement après 25-30 ans normalement. Le remplacement est recommandé surtout si l’image ou le son n’est plus stable, sachant que c’est bien plus facile à remplacer ce type de condos.
    La priorité reste de remplacer les capas dans l’alim (qui elle chauffe et détruit bien plus vite les capas), et quand l’alim lâche c’est l’Amiga qui trinque !

    Les capas qui ne tiennent pas sont dans l’A600, l’A1200 et l’A4000. Les capas sont en techno CMS/SMD (montés en surface) et ces Amigas ont inauguré cette nouvelle techno au début des années 90 :

    Après 20-25 ans ces capas se mettent à fuir (au lieu de sécher) et l’électrolyte coule (doucement mais sûrement) sur la carte mère, attaque le vernis et bouffe le cuivre des pistes. La cata quoi…

    A500 recap / KS switcher 1.2-1.3-Logica-DiagROM / Ext 512Ko / Gotek Cortex interne / Floppy externe
    A1200 recap / KS3.1 / Fast 8Mo / Floppy / Audio Fix
    Commodore 64 recap + 1541 + JiffyDOS + CRT + Carte mère de secours
    Pi16 (Raspberry Pi dans un boîtier de Commodore 16)
    Un RPI sous Amibian (surprise pour l'Alchimie treize 🙂 )
    CPC 6128 + Floppy externe 3.5" + CTM644
    ATARI 520 STF "stock"
    TO7/70 / Ext 16Ko
    Un PC en WinXP avec WinUAE-TinyLauncher-WHDLoad
    2 PS1, 2 PS2, PS3, PSP, Gamecube, Wii,

    #323785
    Mathdea
    Participant
    • Messages : 227

    Hello killerclown

    Une question idiote mais dans quel sens branche t on le multikickstart une fois la rom enlevée? Les pin des inter sont tournees vers l interieur (cm) ou du cote du port d extension?

     

    Merci!

    Amiga 500 Rev6
    Amiga 500 Rev5
    Amiga 1200 + MTEC68030
    Amiga 4000/030

    #323795
    Killerklown
    Participant
    • Messages : 205

    Hello killerclown Une question idiote mais dans quel sens branche t on le multikickstart une fois la rom enlevée? Les pin des inter sont tournees vers l interieur (cm) ou du cote du port d extension? Merci!

    Salut,

    Les jumpers doivent être placés vers l’extérieur, tu suis le détrompeur (eprom et carte mère).

    A plus.

15 sujets de 151 à 165 (sur un total de 172)
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Émulation et autres OS Commande groupée PCB multi Kickstart (Kickstart 2 pour A500)

Do NOT follow this link or you will be banned from the site!