[MorphOS] Blender 2.57

15 sujets de 16 à 30 (sur un total de 30)

  • 1
  • 2
  • ACE

    • Messages : 2370
    #146053

    ben non il y a un message et pouf rien ne se passe, moi j’ai une install mos2.7 neuve, par contre pas essayé avec mos1.4

    Le PSG qui gagne la ligue des champions c'est possible ... Que dans Swos.
    Amiga Morphos Rules.

    Yomgui

    • Messages : 1589
    #146054

    rien ne se passe? pas de hits dans logtool?

    tu utilises bien la 2.57a-RC1 (cf mon wiki)?

    config?

    Yomgui

    • Messages : 1589
    #146055

    @Highlander:

    Bon j’ai eu 5 minutes pour ton problème: effectivement c’est compilé pour G4 uniquement!

    Ca crash sur mon G3 aussi.

    Je fixe cela, je te fais une release perso. Un fix définitif sera fait pour la RC2.

    Note pour ceux à qui cela arrive: on peux faire un « ignore » sur le popup demandant le répertoire HOME: … c’est ENVARC: qui sera alors pris.

    … corrigé aussi dans la RC2.

    Highlander

    • Messages : 501
    #146056

    pfiou… et dire qu’on m’a reproché d’avoir un sys fucké hein !! ;)

    Anyway, j’essaierai avec plaisir cette nouvelle version lorsqu’elle sera dispo, merci Yomgui de t’être penché sur ce problème ^^

    Don't lose it... and don't lose your head

    Yomgui

    • Messages : 1589
    #146057

    Le truc c’est que c’est un peu chiant de recompiler pour G3 uniquement avec juste une partie pour G4… vaudrait voir l’impacte générale.

    Ou alors 2 binaires, mais là pfuuuu déjà qu’il faut 1h30 à un mac mini 1.5GHz pour compiler un binaire!

    BatteMan

    • Messages : 6076
    #146058

    Yomgui : Bah, ça ne fera que 3h de compilation ^^

    Bon, ben avec tout ça, j’ai encore plein de choses à remettre à jour sur ma machine ! Limite plus de trucs en une semaine de vacances qu’en 6 mois de machine HS, j’vous jure ! ^^

    /me applaudit des deux mains !

    Only Amiga makes it possible !

    Yomgui

    • Messages : 1589
    #146059

    @Bat: ça sent le copier-coller dans le coin…

    BatteMan

    • Messages : 6076
    #146060

    Yomgui : Tout le monde ne lit pas les commentaires de news, vil sacripan ! ^^

    /me préfère copier-coller que plagier ^^ En même temps (© officiel … moi), je m’auto-plagie ! ^^

    Only Amiga makes it possible !

    Yomgui

    • Messages : 1589
    #146061

    bon niveau vitesse, y a pire que moi: 257b!

    http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/changelog_257b

    C’est pas possible j’ai même pas le temps de faire une RC2!

    henes

    • Messages : 2618
    #146062

    Pour info, n’importe qui (programmeur, utilisateur…) peut tester sur son G4 si un programme fonctionne sans altivec. Il suffit d’utiliser l’argument noaltivec de la boot.img

    Ex : boot boot.img noaltivec

    Cela fonctionne aussi sur Mac si l’on a lu le readme expliquant où rajouter ce type d’argument et quelle commande exécuter ensuite pour que ça continue de démarrer… :)

    Yomgui

    • Messages : 1589
    #146063

    @Henes: sauf qu’ici cela ne suffit pas.

    L’instruction qui fout la merde c’est un « mfspr r0,256 ».

    Soit charger le contenus du registre VRSAVE dans r0.

    C’est un registre AltiVec certe, mais il n’est pas protégé par le bit MSR[VEC].

    Donc je pense (j’ai pas testé en vrai) que cette instruction marche même avec un G4 sans altivec.

    Alors qu’avec un G3 le crash est assuré.

    henes

    • Messages : 2618
    #146064

    Et pourtant, cela fonctionne bien :

    On peut aussi noter que si highlander ne tournait pas avec le log server de MorphOS désactivé alors qu’il apparait automatiquement dans ce genre de situation… le problème aurait pu être trouvé beaucoup plus tôt. Bouh !

    ACE

    • Messages : 2370
    #146065

    j’ai exactement le meme probleme :-) sur mon peg1

    c’est vrai que le log server doit etre activé mais à la base il ne l’est pas

    Le PSG qui gagne la ligue des champions c'est possible ... Que dans Swos.
    Amiga Morphos Rules.

    Yomgui

    • Messages : 1589
    #146066

    On peut aussi noter que si highlander ne tournait pas avec le log server de MorphOS désactivé alors qu’il apparait automatiquement dans ce genre de situation… le problème aurait pu être trouvé beaucoup plus tôt. Bouh !

    D’ailleurs cela devrait être actif par défaut. Car logtool est au debug ce que le Shell est la GUI ;-)

    Sinon Henes je suis pas sûr que ce que tu montres soit provoqué par l’instruction que je cite, car j’ai trouvé la mienne après une modif + recompilation, donc pas le même binaire.

    Il faudrait testé avec un bout de code simple + ASM… mais j’ai pas de PPC sous la main pour tester.

    mikedafunk

    • Messages : 4415
    #301056

    Chouette court métrage réalisé avec blender :

    Lubuntu / eeepc - A1260/64 - Mon blog Mikedafunk

15 sujets de 16 à 30 (sur un total de 30)

  • 1
  • 2
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Général [MorphOS] Blender 2.57

Amiga Impact