| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site
   · Confidentialité



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

  · Inscription
  · Mot de passe oublié



 | En ligne

Illustration du profil de amigaouf Illustration du profil de TuKo Illustration du profil de riugohan






 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Forum

/   Forums d'Amiga Impact
   /  [RÉSOLU] Problème de démarrage si connexion lecteur externe

Accueil Forums AmigaOS, MorphOS et AROS Matériel [RÉSOLU] Problème de démarrage si connexion lecteur externe

Ce sujet a 37 réponses, 5 participants et a été mis à jour par  Killerklown, il y a 3 mois et 1 semaine.

15 sujets de 16 à 30 (sur un total de 38)

Auteur Messages   
#317679 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 14:40


Killerklown

Participant
  • Messages : 195

Dernière info que je n’ai pas donné, le gotek est flashé avec flashfloppy et les 2 ont été achetés au même vendeur qui en vend régulièrement sans souci.

#317681 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 15:09


Killerklown

Participant
  • Messages : 195

Sans grosse surprise le test d’entrée du 5v fonctionne.

Du coup je vais essayer de voir pour fabriquer un autre adaptateur en DIY, ou alors un boitier externe, pour voir, ça me perturbe cette affaire, surtout que l’adaptateur n’a apparemment aucun truc qui cloche.

#317682 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 15:57


Killerklown

Participant
  • Messages : 195

Bon du coup j’ai poussé les investigations un peu plus loin, j’ai testé la nappe aucun souci.
Par contre si je teste la 5v lorsque l’adaptateur est branché, j’ai 1.2v et l’adaptateur chauffe, comme s’il y avait une résistance, du coup à mon avis sans doute un composant (y’en a 2 ça va aller vite) qui est cramé.

A suivre

#317688 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 17:24


Killerklown

Participant
  • Messages : 195

Bon, faut vraiment pas avoir de bol, en fait le bornier du connecteur 5v en sortie a un pont apparemment, du coup +5 relié à la masse, y a comme un souci.

Du coup un fois ce souci réglé, l’amiga démarre, mais, ce serait trop facile sinon, uniquement si je ne branche pas ce fameux 5 volt sur le gotek, du coup maintenant je vais souder un câble de FDD en direct des 2 broches afin de voir ce que ça donne.

La suite au prochain épisode.

#317696 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 18:11


Giants

Participant
  • Messages : 1643

Ok, ras sur tes photos hormis l’alimentation du gotek que l’on ne voie pas.

==> Ok, du coup il ne sera pas possible avec ce hack d’accéder au lecteur interne si je switch le lecteur externe en DF0 du coup.
#Tout à fait et ne switch pas l’Amiga Allumé, tu risquerais de cramer le CIA

==> j’ai mis une photo avec une résistance ..
#Ras, normal

Au passage, elle est zarb ta clée USB 🙂

Alors en cherchant sur le site tu trouveras des posts que l’on a fait a propose des firmw flashfloppy et hxc.

Pour faire simple, Flashfloppy est un gros pompage du firmware Hxc, il est gratuit et… bein tu en as pour ton argent (en clair il est pas top pour rester poli).

Celui de la HXC est à la pointe de la techno, C’est d’ailleurs le créateur de la carte HXC (jef) qui la crée.
Quand on parle de HXC on peu parler des carts HXC comme simplement du firmware HXC (Le firm est constamment MAJ mais il est payant 10€+TVA)

Pour info, normalement sur ton adapt externe, tu as un CI (un 74LS…).
Si il est cramé, il va chauffer (donc en posant le doit dessus t’es en général fixé, surtout sur un court circuit, ceci dit il peut aussi être cramé et ne pas chauffé).

Il chauffera a coup sur par contre si court circuit il y a.
Pour info, ce genre de composant coute que dalle.

Concernant ton court circuit…
Si tu regardes le schéma de la gotek (https://cortexamigafloppydrive.wordpress.com/), tu verras qu’au niveau protection, c’est simple, y’a RIEN. (pour ça qu’il faut acheter une vrai carte, une carte Hxc)

Tu as donc de forte chance que ta gotek soit grillée (et tu as du bol que l’amiga a encaissé le court-circuit).

Sur la gotek tu as un petit régulateur de tension 3.3Volt (U4 de mémoire)
(https://cortexamigafloppydrive.files.wordpress.com/2014/02/gotek_pcb_top.jpg)
Tu peux tester la tension en entrée et en sortie.
En entrée du devrait avoir le 5V de l’amiga (du connecteur d’alim donc)
et en sortie un jolie 3.3V

Si c’est pas le cas, le régulateur est mort et donc le chipset principal n’est pas alimenté.

Si tu as ton 3.3V en sortie, il te reste plus qu’a poser ton doigt sur le chipset principal pour voir si il chauffe.

Mais… court circuit au niveau du 5v sur une gotek en général, ça ne pardonne pas.

Après… c’est encore une fois le problème de la gotek, elle coute pas chère donc on a du pas chère, pas de protection, juste un petit ‘nettoyage’ via 1 condo.

Si c’est ton régulateur, tu peux le changer MAIS ça ne garantie en RIEN que ton chipset principal n’a pas pris un coup dans l’aile.

Il faut savoir que ce genre de régulateur, comme aussi les 7805 and co, supporte TRES MAL l’inversion de polarité et les courts circuits.
Autant, ils ont une plage de tension en général assez large, autant sur un court circuit c’est… One shot, pouf

Un ‘affichage’ sur le gotek aurait apporté un plus dans le debug, c’est de suite beaucoup plus parlant 🙂

Région : Yvelines
Site : http://sasfepu78.fr
H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc

#317704 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 19:22


Killerklown

Participant
  • Messages : 195

Merci de ta réponse, pour le switch, oui effectivement lorsque je change, je le fait l’Amiga éteint.

Pour le court circuit, j’ai shooté le bornier pour l’alim, ça boote, je vais tester en remplaçant le câble d’alim, j’ai un doute la dessus du coup.

J’ai fait les tests suivants :

  • 5v connecté au gotek, boot floppy ok, gotek ne s’allume pas
  • 5v + nappe connectés au gotek, boot A500 ko, gotek ne s’allume pas
  • nappe connectée au gotek, boot floppy ko

J’ai testé à nouveau le gotek en interne, ça roule il démarre sans souci, ça c’est déjà une bonne nouvelle, du coup je pense qu’on peut écarter tout problème du gotek en lui même à priori.

Concernant le firmware, je pensais que le FF était un fork du hcx et qu’il en était une version améliorée, je vais regarder ça, je présume qu’on peut le reprogrammer via USB en le mettant en programming mode.

Je regarde ça et ferai un retour ASAP.

  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.
  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.
  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.

#317708 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 19:39


Killerklown

Participant
  • Messages : 195

C’est bon ! Ca fonctionne enfin, du coup en plus du bornier, le cable d’alim en avait aussi un coup dans l’aile, je vais pouvoir enfin démarrer l’ASM.

J’attends plus que le WB que Mandrake doit m’envoyer et ce sera tout bon.

Merci à tous pour votre aide et vos pistes.

Et à bientôt pour de nouvelles aventures, dans la section dev très certainement.

  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.

#317720 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 06/11/2018 à 21:02


Giants

Participant
  • Messages : 1643

Bein mon gars, si t’es croyant tu peux aller mettre un cierges.

Le flashfloppy est un gros pompage du code/idée original, il fonctionne mais n’a pas la stabilité qu’a le firm. xhc et encore moins les évolutions.

Essayer c’est l’adopter.
Après, tu verras à l’utilisation, si le flashfloppy te convient, tu le garde.

et du coup pourquoi tu as besoin de disquette?
Suffi de mettre une image adf qui va bien et hop.
Si tu veux j’ai ça pour asmone.
Ça prends 2minutes à créer ça sous winuae.

Région : Yvelines
Site : http://sasfepu78.fr
H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc

#317738 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 07:29


Killerklown

Participant
  • Messages : 195

Salut,

Je vais voir pour l’autre firmware.

Pour les disquettes, on en a parlé sur un autre topic, c’est pour faire vivre le support, et j’aime bien.

#317741 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 07:46


GothDevil

Participant
  • Messages : 136

@ killerklown

+1 pour l’aspect j’aime bien les disquettes. On est 2 au moins comme ça… Et en dépit de ce qu’on entend et voit sur le net, j’ai toujours des disquettes d’il y a 25 ans qui fonctionnent toujours . Et toutes celles que j’utilise en ce moment, 3’1/2 et 5’1/4 (pour les raisons spécifiées dans l’autre post), jamais de souci non plus. Certes il y en a qui sont à jeter (ce que je fais de suite si secteur défectueux avant de les utiliser) mais en attendant moi ça colle parfaitement à mes attentes. Génial donc qu’on soit deux exceptions :-)… Meme si je sais que Giants ne partage pas cet avis 🙂

#317742 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 07:58


Killerklown

Participant
  • Messages : 195

Ouep, c’est aussi une des raisons pour lesquelles j’ai repris un ordi old school, ce claquement est vraiment cool.

Je me suis tâté pour un VG5000, le tout premier que j’ai eu, mais pour le moment je mets en pause, pas nécessaire pour ce que je veux faire, par contre sur celui là, avec le lecteur cassette, le ‘bruit’ des données et le défilement sur le bord, c’est idem, c’est carrément sympa (de ce que je me souviens).

L’aspect nostalgie, pour ma part, représente plus de la moitié de la raison de l’achat de l’A500, pour mes achats en arcade, c’est carrément 90% !

GothDevil wrote:

Meme si je sais que Giants ne partage pas cet avis

C’est ce qui fait que le monde est comme il est, nous avons tous des approches qui sont les nôtres y compris sur des points qui nous rassemblent, et ça c’est cool, ça permet de partager nos idées, de participer en fonction des nos préférences, et tout le monde y gagne.

  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.
  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.

#317746 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 08:19


Killerklown

Participant
  • Messages : 195

Giants wrote:

Le flashfloppy est un gros pompage du code/idée original, il fonctionne mais n’a pas la stabilité qu’a le firm. xhc et encore moins les évolutions.

Pas bien compris sur le site HxC2001, c’est comme pour l’unibios, tu l’achète une fois et tu as les updates gratuitement ? ou bien il faut repayer tout ou partie ?

Merci

  • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par  Killerklown.

#317751 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 09:10


GothDevil

Participant
  • Messages : 136

En fait pour le HXC, tu achètes sur le site ensuite avec le programme de flash (qui est sur le site) et le code reçu tu pourras mettre à jour ton Gotek, il faut bien entendu que celui ci soit relié avec un cable FTDI à ton port USB de ton PC pour lancer l’update de l’E²Prom du Gotek.

Une fois que c’est fait, les mises à jour sont gratuites et se font via un fichier .UPD que tu téléchargeras et placeras sur une clé USB à la racine (clé usb vierge de préférence). Si ma mémoire est bonne il faut appuyer sur un ou les 2 boutons du Gotek pour qu’il lance la mise à jour mais ça à vérifier. Tout ça pour dire que tu ne paies qu’une seule fois et que pour le prix, ça vaut vraiment la peine.

#317753 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 09:20


Giants

Participant
  • Messages : 1643

Ah oui exact pour les disquettes, on en a déjà parlé 🙂
Pas grand chose à ajouté à ce que viens de dire gothdevil c’est exactement ça 😉

Région : Yvelines
Site : http://sasfepu78.fr
H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc

#317758 Répondre à : [RÉSOLU] Problème de démarrage si connexion lecteur externe
 le 07/11/2018 à 09:31


Killerklown

Participant
  • Messages : 195

Merci à vous 2

GothDevil wrote:

il faut bien entendu que celui ci soit relié avec un cable FTDI à ton port USB de ton PC pour lancer l’update de l’E²Prom du Gotek.

Du coup ce câble se branche en USB sur le PC et sur les broches de l’arrière du gotek je présume, et une fois le firmware en place, l’update se fait via USB, ok compris.

J’ai le matos pour fabriquer le câble je vais me mettre dessus ce week end et voir ça.

Merci


15 sujets de 16 à 30 (sur un total de 38)

Vous devez être connecté pour répondre à ce sujet.

                   
Derniers sujetsFraîcheur
 · Gotek en détails, ça existe? il y a 7 heures et 12 minutes
 · Petit question pour avoir une machine plus puissante il y a 8 heures et 13 minutes
 · (VENDU) A vendre + dons il y a 10 heures et 15 minutes
 · Petite présentation il y a 10 heures et 23 minutes
 · Programmateur d éprom il y a 10 heures et 34 minutes
 · Commande groupée Abbaye des Morts (C64) il y a 15 heures et 47 minutes
 · Amiga 500 et Moniteur 1084S révision ? il y a 17 heures et 21 minutes
 · Dune de Jodorowsky il y a 18 heures et 10 minutes
 · [DONNE] Livre: Learning C il y a 1 jour et 11 heures
 · [RECH] Lecteur D7 A500 il y a 1 jour et 12 heures





RechercheFraîcheur


Copyright © 2004-2019 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!