WHDLOAD crash

15 sujets de 1 à 15 (sur un total de 21)

  • 1
  • 2
  • Phil

    • Messages : 59
    #225492

    Bonjour..

    J’ai un Amiga 600 fraichement installé avec une carte CF 4GB, workbench 3.1 (+ better workbench 3.9).

    2mo chip mem + 8mo  fast mem

    J’ai installé le whdload en dernière version v18.00

    Je rencontre le soucis pour certains jeux au lancement voir image jointe.

    Est ce que l’A600 nécessite des kickstarts spécifiques ou ce sont exactement les mêmes que ceux utilisés pour le 1200.

    Car je n’ai aucun soucis sur mon 1200 avec les mêmes jeux.

     

     

     

    CrashMidnick

    • Messages : 2236
    #225494

    C’est quel pourcentage de jeux qui te font ce problème ? Car si c’est 1 par ci-par là, ça veut dire que le slave doit être réécrit.

    Tu peux également installer une version antérieure de whdload pour tester.

    EndCLI >NIL:

    huggyone76

    • Messages : 2114
    #225497

    Hormis les jeux avec de l’AGA (évidemment…), théoriquement le 600 pourra les faire fonctionner.

    Tu n’as pas de carte accélératrice ? « juste » de la RAM en plus ?

    En tout cas, ce que dis CrashMidnick est juste : Parfois il faut réutiliser de vieilles versions de WHDLoad (lire les infos qui accompagnent le slave pour savoir avec quelle version il fonctionnait à l’origine).

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 10Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

    Anonyme

    • Messages : 988
    #225499

    Salut.

    Je mise sur la version de Whdload qui fait planter. Donc, réecrire les slaves est nécéssaire. J’ai eu le cas sur mon 1200 en passant de la 16.9 à la 17 de Whdload. 🙂

     

    Jay

     

    dlfrsilver

    • Messages : 513
    #225509

    Quels autres jeux te présente ce plantage ?

    huggyone76

    • Messages : 2114
    #225510

    En tout cas le slave qu’on trouve sur ton exemple (F17 Challenge), s’il vient du site whdload.de, date de 2006 avec whdload « 10+ ». Donc bien possible que le slave soit incompatible avec whdload 18…

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 10Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

    Foul

    • Messages : 721
    #225511

    Je viens de tester de mon coté F17 Challenge v1.1 passe bien avec Whdload 18  sur ma config (A1200/060/OS3.9).

     

    J’ai récup tous les whdload ici : http://www.pleasuredome.org.uk/details.php?id=25bb7df754f8b79e0fcd690b60f5aa175483ece5

     

    Il faut être enregistré…

    huggyone76

    • Messages : 2114
    #225525

    Faut tester sur un 600 (j’ai pas eu le temps hier), les 1200 semblent faire mieux passer… à peu près tout ! Sans que je ne sache encore pourquoi…

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 10Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

    CrashMidnick

    • Messages : 2236
    #225531

    WHDLOAD a été essentiellement développé sur 1200 + blizzard 1230 ce qui est et restera la meilleure machine pour whdload. Chaque carte accélératrice a ses spécificités au niveau accès RAM (fast et chip) et synchro sur la carte mère (et j’en passe). Chaque machine réagira différemment suivant la config.

    Pour rappel, il suffit de placer l’exécutable de la version de whdload voulue dans le dossier du jeu pour qu’elle soit appliquée, sinon il utilisera celle de sys:c

    EndCLI >NIL:

    huggyone76

    • Messages : 2114
    #225554

    Je viens de tester. Je suis en 17.2 sur mon 600 (j’ai le 18.0 dans un coin, mais pour le moment cette version ne me semble pas encore « utile », et puis… j’ai eu la flemme de le copier. 😀 ). Ca fonctionne parfaitement sur mon 600 + Vampire. Mais bon, comme l’explique CrashMidnick, il suffit parfois d’un rien pour que ça ne passe pas…

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 10Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

    dlfrsilver

    • Messages : 513
    #225567

    la 17.2 est une mauvaise version, qui a posé des problèmes.
    Passe en version 18.0 sans te poser de question (la 18 corrige pas mal de bugs, donc certains importants).

    Et y a pas de support sur la 17.2 puisque la 18 est sortie y a déjà un moment 🙂

    huggyone76

    • Messages : 2114
    #225586

    Mauvaise version la 17.2 ? Ah… En tout cas je l’ai utilisé plus d’un an sans souci particulier me semble-t-il… Enfin bref, j’ai pris le temps (surtout que je l’avais sur CF… et puis comme j’ai une licence, ce serait dommage…) de mettre la 18.0 mais le constat est le même : Ca fonctionne.

    Quant au support de WHDLoad, pas encore eu besoin… Mais tu as raison dlfrsilver, autant prendre la dernière (sauf slaves incompatibles…) 😀

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 10Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

    Phil

    • Messages : 59
    #225587

    Merci à tous pour vos réponses.

    En fait, c’est vraiment au cas par cas pour les jeux.

    J’ai fini par trouver certains éléments de réponse.

    Oui a priori le slave doit être réécrit parfois mais pour des soucis de compatibilité avec le cpu 68000.

    Réecrire le slave ne fait pas partie de mes compétences.

    Dans le cas de F17 Challenge, il passe très bien dans winuae avec un 68020 et plante dès le début avec un 68000.

    Donc certains jeux a mon avis doivent être réécrit pour passer sur un 68000.

    Forcément sur un 1200, tout passe puisqu’il est équipé au minimum d’un 68020 (après il reste a avoir de la fast).

    Brian the Lion aussi quelque soit la version 1.2, 1,3 ne passe par avec un 68000 en whdload. Dès le 68020 il fonctionne!

    J’ai contourné le problème en installant la version HD a partir de disquettes. 🙂

    Ensuite une erreur sur un jeu, mal répertorié il était en version AGA au lieu de la version ECS. Forcément sur un A600, ça marche moins bien 😀 (jungle strike).

    Pour retrouver des versions anciennes et les installer c’est parfois galère car pour trouver les disquettes qui conviennent ce n’est pas évident.

    >> Donc forcément avec ta vampire Huggyone tu es tranquille 🙂

    On peut donc écarter pour l’instant un problème de version whdload.

    Ma config. A600 2mb chip / 8mb fast . cpu inchangé 68000.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    huggyone76

    • Messages : 2114
    #225604

    Tranquille, tranquille… Pour l’instant, grosso modo, la Vampire implémente un 68000 et quelques instructions 68020 + émulation soft par librairie. Ah oui, et plein de RAM. 🙂 Mais bon, j’avoue… ça marche plutôt bien !!!

    A500+ACA500 - A600+Vampire 2+indivision ECS - A1200+ACA1230+indivision MK2 - A1200+Vampire V2 1200 - Mac Mini 1.42 sous MOS - Just CPC 128k - CPC 6128 - Atari STE 4Mo/CosmosEx - Atari Falcon CT60/SuperVidel 🙂
    C64C + 1541-II + Lecteur K7 + SD - Sharp X68000 CZ-601C 10Mo + CF - Sharp X68000 CZ-611C 4Mo + CF + ext. MIDI

    Foul

    • Messages : 721
    #225607

    même 060 !!! sur les dernières version … je passe pas mal de temps sur l’IRC le soir et j’apprend plein de truc avec les devs 😉

15 sujets de 1 à 15 (sur un total de 21)

  • 1
  • 2
  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Matériel WHDLOAD crash

Do NOT follow this link or you will be banned from the site!