Amiga 500 MàJ 2022 – mémoire / sortie vidéo / accélération

15 sujets de 76 à 90 (sur un total de 127)

  • kix

    • Messages : 182
    #366947

    Je vais la changer alors… Quelle aventure 😂 !!!

    kix

    • Messages : 182
    #366948

    Je recommence à zéro…

    kix

    • Messages : 182
    #366949

    Et c’est un… Echec 😞 !!

    J’ai absolument refait toutes les étapes avec une alim d’iPad mini de 10W et un câble usb de qualité.
    J’ai réinstallé la carte SD, j’ai suivi les étapes.
    Et à la ligne  » ./flash.sh  » >> Could not detect CPLD

    Giants

    • Messages : 5003
    #366950

    Alors plusieurs choses….
    Pour ‘flasher’ ton CPLD il est évident qu’il doit être alimenté.
    Chose qui est fait via le 5V* de l’amiga (ou de l’USB et je dis bien OU et pas ET)
    *Et ensuite le régulateur 3.3V qui fournis les tensions pour le chip.

    Donc pour mettre à jour ton firmware le mieux est de faire la manip avec la pistorm NON CONNECTé à l’Amiga mais alimenté UNIQUEMENT via ton câble USB.
    Envoyé du 5V via l’amiga (Pistorm connecté sur le slot 68000) ET envoyé du 5V via l’adapt USB n’est pas du tout (mais alors du tout) une bonne idée.
    MAIS, ce n’est surement pas la cause de ton problème.

    Pour en savoir plus, tape dans ton terminal la commande suivante et post le résultat.
    sudo openocd -f nprog/detect.cfg

    PS : Aucune chance que ce soit un problème d’alim pas suffisante car on parle ici de mA
    un CPLD comme celui-ci ne devrait consommer pas grand chose.
    Pour info, j’ai mesuré sur le mien en utilisation ~300mA

    Région : Yvelines / France
    Réparation Amiga and co.
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne craignez jamais de vous faire des ennemis ; si vous n'en avez pas, c'est que vous n'avez rien fait.

    kix

    • Messages : 182
    #366951

    C’est le cas.
    Je suis simplement sur le Raspberry pi alimenté par un chargeur USB iPad mini de 10W via un câble USB et connecté sur ma TV.
    Et j’écris ces lignes avec un clavier Logitech qui communique avec le PI par un dongle bluetooth.

    Voila ou j’en suis.

    kix

    • Messages : 182
    #366952

    Voici le résultat de la ligne

    Attachments:

    Giants

    • Messages : 5003
    #366954

    Peux tu prendre une photo de ta carte Pistorm
    assez NET que je puisse lire ce qu’il y a d’écrit sur tes chips.
    Merci

    Parce que la, la commande n’arrive pas à lire les info via le driver JTAG…

    JTAG scan chain interrogation failed : all zeroes

    Comme si, le CPLD n’était pas alimenté OU que tu avais un conflit dans tes GPIO
    #Un conflit dans les gpio ou mauvaise conf viendrait du fichier cfg (peu probable vue que tu l’as pris sur le github)
    #Pas d’alim sur le CPLD…alors la… à moins que ton PCB n’est pas de régulateur 3.3V(U8 pour info) (ou qu’il soit HS).*
    Quand à un CPLD cramé alors que la carte est neuve, jamais vue encore.

    as tu essayé la commande dmesg |egrep -i « error|warn »
    Affiche aussi le fichier de conf : cat nprog/detect.cfg

    Tu as soudé quelque chose sur ta pistorm ou tu l’as acheté déjà toute prête ?

    *If a GT variant is chosen, the the 1.8v regulator in U9 needs to be specified and the 0 Ohm resistor in R5 needs to be removed.
    https://github-wiki-see.page/m/captain-amygdala/pistorm/wiki/FAQs

    Région : Yvelines / France
    Réparation Amiga and co.
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne craignez jamais de vous faire des ennemis ; si vous n'en avez pas, c'est que vous n'avez rien fait.

    kix

    • Messages : 182
    #366956

    Je crois que je viens de tilter… J’avais prévenu, je suis un peu nul !

    Je test et reviens.

    kix

    • Messages : 182
    #366957

    Bon, ça y est… J’ai compris grâce a ton message @giants
    En fait, j’ai fait tout ça sans le pistorm. Je viens de le connecter.

    Et maintenant, je vois que (mais l’écran est tronqué):
    CPLD… EM240 detected!
    WG…
    WG successful!

    Giants

    • Messages : 5003
    #366958

    >En fait, j’ai fait tout ça sans le pistorm. Je viens de le connecter

    O_O’

    Effectivement… il ne risque pas de détecté le CPLD, lol
    Arf.
    Et bien tant mieux, y’a plus qu’à maintenant 🙂

    Région : Yvelines / France
    Réparation Amiga and co.
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne craignez jamais de vous faire des ennemis ; si vous n'en avez pas, c'est que vous n'avez rien fait.

    kix

    • Messages : 182
    #366959

    Maintenant à l’étape « démarrage de l’émulateur en même temps que le Pi »:

    https://raw.githubusercontent.com/beeanyew/pistorm/wip-crap/boot_scripts/pistorm.service

    Cette ligne mène à une erreur 404.

    kix

    • Messages : 182
    #366960

    >En fait, j’ai fait tout ça sans le pistorm. Je viens de le connecter

    O_O’

    Effectivement… il ne risque pas de détecté le CPLD, lol
    Arf.
    Et bien tant mieux, y’a plus qu’à maintenant 🙂

    Après coup, maintenant que cette difficulté est franchie ce n’est pas un peu nul mais un peu débilos…
    😉

    kix

    • Messages : 182
    #366962

    Maintenant à l’étape « démarrage de l’émulateur en même temps que le Pi »:

    https://raw.githubusercontent.com/beeanyew/pistorm/wip-crap/boot_scripts/pistorm.service

    Cette ligne mène à une erreur 404.

    Est-ce qu’il existe une autre manière de passer cette étape ?
    Arghh, si près du but 🙂

    stephbb75

    • Messages : 594
    #366964

    Oui tu peut le démarrer par le crontable, mais la je ne sais plus comment on fait !

    Sinon regarde dans la doc officiel :

    https://github.com/captain-amygdala/pistorm/wiki/PiStorm-Software-Installation#Auto-starting-PiStorm-emulator

    https://youtube.com/@stephbb75

    Giants

    • Messages : 5003
    #366966

    La crontab ne sert pas à ça.
    La crontab (chrono table), sert à effectuer des taches régulières, example lancer une application tout les 5 minutes, ou toutes les semaines, ou tout les jours à 15H15, etc.

    Si tu veux lancer quelque chose en ‘automatique’ au lancement d’une distrib linux il faut passer par la case init ou service.

    Quelques liens :
    https://tech.webit.nu/?s=piStorm&submit=Search

    tu as aussi pas mal de vidéo sur le net en Français comme celle de Rodrik
    https://www.youtube.com/watch?v=flCb91TBJjo

    MAIS, les liens sur https://tech.webit.nu (juste au dessus) sont plus à jour, plus techniques et…. bref, ils sont ‘mieux’.

    Après…. pour un débutant ne connaissant rien sur linux j’aurais quand même commencé par regarder (sans faire les manips) les deux vidéo de Rodrik histoire de mieux comprendre le fonctionnement global.
    ET ENSUITE, faire plutôt ce qu’il y a d’indiqué sur le site tech.webit.nu

    Sinon, si tu connais le scripting et linux, tu peux ensuite te faire tout une floppé de lancement de conf facilement.

    Région : Yvelines / France
    Réparation Amiga and co.
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne craignez jamais de vous faire des ennemis ; si vous n'en avez pas, c'est que vous n'avez rien fait.

15 sujets de 76 à 90 (sur un total de 127)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Matériel Amiga 500 MàJ 2022 – mémoire / sortie vidéo / accélération

Amiga Impact