Pb. Installation Linux DEBIAN sur PegI/G3

15 sujets de 16 à 30 (sur un total de 56)

  • lugduweb

    • Messages : 999
    #31479

    Re-bonsoir,

    j’ai ré-essayé et… hélas… ca ne marche toujours pas.

    En reprenant à zéro, voilà exactement ce que je fais :

    Le peg boot, j’appuie sur ESC (si si !) et je tape :

    boot /pci/ide/[email protected],0:0 vmlinuz-chrp.initrd

    Linux démarre…

    * Language : French

    * Country : FR

    * Keyboard layout : FR

    * Detecting network hardware (semble OK)

    * Configuring network with DHCP (semble OK)

    * hostname : debian (nom par défaut)

    * domaine name : (je laisse vide)

    * Choose a mirror of the debian archive : France

    * Site : ftp2.fr.debian.org

    * HTTP proxy : (je laisse vide)

    * Downloading the release file : n’abouti jamais :-(

    Le seul truc louche c’est la MAC FF-FF-FF-FF-FF-FF détectée par mon routeur.

    Pourquoi diable ne reconnait t’il pas la bonne MAC ?

    – J’ai également essayé d’ajouter une entrée DHCP statique :

    debian 192.168.0.101 FF-FF-FF-FF-FF-FF

    Mais rien n’y fait !

    Pourtant sous MorphOS la MAC est OK.

    – J’ai aussi essayé de configurer en manuel les paramètres reseau : pareil !

    Honnetement je ne vois pas quoi faire :-(

    Surtout que même sans routeur c’est pareil.

    N’y aurait il pas un driver magique pour la carte réseau à charger ?.

    En même temps maintenant que j’y pense la detection auto ne fonctionnait pas du premier coup sous MorphOS, il a fallu que je fasse un « probe ». Y’a t’il quelque chose à faire dans Smartfirmware ?

    HELP ! :-(

    Admin

    BatteMan

    • Messages : 5771
    #31480

    Lugduweb : Il faudrait que tu testes avec une carte réseau RTL 8139… Peut-être que cela résoudrait ton problème… De toute façon, ça améliore grandement le réseau et ça coûte moins de 10 euros. Enfin, si tu pouvais tester avec, je pense que ça marcherait mais j’en suis pas sûr.

    /me n’a plus de soucis depuis qu’il a une RTL8139…

    Only Amiga makes it possible !

    Pensez à vous inscrire sur www.annuaire-amiga.org, l'Annuaire des Amigaïstes toutes saveurs confondues ! ^^

    SoundSquare

    • Messages : 3568
    #31481

    @Lugduweb

    je pense pas contrairement à BatteMan que changer de carte réseau résoudra ton probleme. C’est plutôt ton routeur qui est en cause puisqu’apparement il t’attribue bien une IP par le DHCP mais il ne transmet pas le domaine et les DNS (indispensables pour que l’installeur se connecte)

    Quand l’install te demande le domaine, il ne faut pas laisser ça vide. Chez moi « wanadoo.fr » (mon provider) s’affiche par défaut, l’install récupère cette information par mon routeur. Regarde dans la config de ton routeur si le domaine est spécifié, si c’est le cas, recopie la même chose dans l’install de Debian, si c’est pas le cas, ajoute le dans ton routeur(souvent c’est le nom de ton provider, wanadoo.fr ou club-internet.fr par exemple)

    essaye ça, vérifie la config de ton routeur (comme quoi il forward bien les DNS) et dis moi ce que ça donne.

    bon courage

    PS : en aucun cas ce ne peut être un probleme d’iimage, avec une mauvaise image tu n’arriverais pas jusque là :)

    Admin

    BatteMan

    • Messages : 5771
    #31482

    SoundSquare : Tu as probablement raison, mais je n’ai pas de routeur qui m’ennuye ;-)

    Et en plus, la RTL est utile sous MorphOS pour éviter d’utiliser le driver via-rhine MOS. Mais elle est aussi utile pour installer un linux 2.6.8 sans avoir à reconfigurer le net avant de finir l’installation (mais ça s’installe et c’est au reboot que ça déconne).

    Lugduweb : Essaye l’astuce de SSQ ;-)

    /me ne peut plus rien d’autre, il ne connaît rien d’autre :-D

    Only Amiga makes it possible !

    Pensez à vous inscrire sur www.annuaire-amiga.org, l'Annuaire des Amigaïstes toutes saveurs confondues ! ^^

    SoundSquare

    • Messages : 3568
    #31483

    @BatteMan

    je ne conteste pas l’intérêt de mettre une carte ethernet realtek dans un Peg, effectivement ça résoud qq problèmes, et c’est plus performant, tu as raison. Mais dans le cas de Lugduweb ça ne vient pas de là, je ne pense pas, à moins que son routeur ait du mal avec le chip ethernet du Peg, possible aussi. En gros, changer la carte réseau pourra être interessant si Lugduweb ne s’en sort pas.

    lugduweb

    • Messages : 999
    #31484

    Comme je l’ai précisé même sans le routeur cela ne marche helas pas :(

    SoundSquare

    • Messages : 3568
    #31485

    @Lugduweb

    tu as essayé de faire ce que je t’ai dit au moins ? je t’ai pas demandé d’enlever ton routeur, juste de le configurer.

    c’est quoi ton fournisseur d’accès ?

    lugduweb

    • Messages : 999
    #31486

    j’essaye de suite et je vous tiens au courant.

    [edit]

    fournisseur : free

    [/edit]

    SoundSquare

    • Messages : 3568
    #31487

    ok dans ce cas, renseigne « free.fr » dans les paramètres de ton routeur (domaine) et l’installeur Debian devrait trouver ça, sinon rajoute le à la main quand l’installeur te demande le domaine.

    lugduweb

    • Messages : 999
    #31488

    C’est re-moi.

    Bon rien de mieux.

    Je n’ai pas d’endroit où renseigner le nom de domaine de mon routeur (à part le nom local du domaine sur le LAN mais ca n’a rien à voir).

    Sinon quand tu vas sur dnsstuff sur Internet

    le nom de la machine a la gueule suivante « lns-vlq-33-ren- » (ip avec des tirets).adsl.proxad.net

    exemple : lns-vlq-33-ren-82-253-111-10.adsl.proxad.net

    Par rapport à ma conf précedente (qui marchait aussi bien sous Windows et MorphOS) j’ai ajouté les serveurs DNS de free mais ca ne change visiblement rien.

    J’ai essayé à tout hasard dans la configuration de Linux, mais c’est bien le nom local qu’il veut (si je le paramètre sur le routeur, je retrouve bien le paramètre sous Linux).

    Sinon je t’ai envoyé un message avec ma conf…. au cas où tu vois un paramètre foireux.

    Sinon j’ai 2 machines connectées directement sur le routeur, sur mon LAN :

    – takinou (le PC)

    – pegasos (le Pegasos)

    Quand je suis sous MorphOS comme je l’ai dit ca marche nickel, quand je suis sous Linux avec la même machine comme tu pourras le voir la MAC du Pegasos n’est plus reconnue (je me repete).

    Je n’ai pas l’impression que ca vienne du routeur, peut être un pb de driver Ethernet ?

    Sinon autre piste, peut être qu’il y a un probleme de configuration avec la Freebox.

    Je vais refaire la manip à zéro sans routeur et noter les paramètres qui different (nom machine, DNS & cie).

    lugduweb

    • Messages : 999
    #31489

    Sans le routeur, les parametres sont détectés correctement (machine de nom ln-vlq….adsl.proxad.net) et …

    toujours le même problème au moment du chargement de la release.

    Niffo

    • Messages : 603
    #31490

    SoundSquare

    • Messages : 3568
    #31491

    j’ai jeté un oeil sur ta config routeur

    désactive le static DHCP (disabled) et refais un essai

    lugduweb

    • Messages : 999
    #31492

    Merci à tous les 2.

    Je vais essayer ce que vous proposez.

    @+

    lugduweb

    • Messages : 999
    #31493

    Bon j’ai mis le nouveau fichier de boot,

    enlevé le static DHCP.

    résultat :

    … toujours bloqué au même endroit :( ouuuiiinnn ! :'( :'( :'(

    Et j’ai toujours dans les logs du routeur :

    Feb/04/2005 13:24:02 DHCP lease IP 192.168.0.102 to FF-FF-FF-FF-FF-FF

    C’est un truc de fous je vous dit ! Mon Peg doit être vérolé.

    Je crois que je vais finir par le mettre sur un PC ce Linux moi !

    Meme à la disquette j’aurai déjà fini :-(

    Bon faut que je retourne au boulot.

    @+

15 sujets de 16 à 30 (sur un total de 56)

Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Émulation et autres OS Pb. Installation Linux DEBIAN sur PegI/G3

Do NOT follow this link or you will be banned from the site!