68030 et usage du mmu

11 sujets de 1 à 11 (sur un total de 11)

  • johnz

    • Messages : 192
    #8646

    salut

    ayant monté une elbox 68030 lc dans mon 1200 j’ai voulu un peu optimiser le matos pour améliorer mes parties d’alien breed 3d 2 ( d’ailleur j’ai fini le premier et il est génial!). donc sur sysinfo le mmu est reconnu mais il n’est pas utilisé. quand sur whdload j’essaie de forcer l’usage du MMU ( commande -mmu) l’ordinateur se fige. a quoi cela est du?

    y a t’il des librairies a installer ou autres programmes d’optimisation?

    henes

    • Messages : 2622
    #132471

    Qu’est ce qu’une « elbox 68030 lc » ? Je n’en vois pas trace sur le site d’Elbox : http://www.elbox.com/products.html

    Il est possible que ton 68030 soit un 68EC030 ou un autre CPU vendu un peu moins cher parce que son unité MMU est défectueuse ou absente…

    Il n’y a aucune bibliothèque à installer (contrairement aux 68040 et 68060) en tout cas.

    johnz

    • Messages : 192
    #132472

    il s’agit de cette carte accélératrice

    http://www.amiga-hardware.com/showhardware.cgi?HARDID=121

    sur sysinfo il est marqué que j’ai un mmu mais qu’il n’est pas utilisé.

    a priori utiliser le mmu devrait ameliorer les performances de la machine.

    sinon dans la config des jeux whdload quelle commande est la meilleure ?

    DCache ou bien Cache?

    Voxel

    • Messages : 1400
    #132473

    il semblerait que ton 030 soit un ECO30 avec mmu désactivée si ça fige. bien qu’inutilisable la mmu apparait sous sysinfo puisque elle est présente sur la puce. les processeurs ECO30 sont en fait des processeurs avec un défaut de fabrication sur la mmu, motorola les désactivent et vends le chip en ECO, oui ce serait bête de jeter la puce complète alors que tout marche sauf la mmu et tout le monde n’a pas besoin d’une mmu… au prix du waffer de silicium c’est pas une petite économie :-)

    pour les caches, il y en a deux D(ata)cache et Burst, si tu fait « cpu cache burst » ta 030 travaille plus vite mais sache que tous les jeux ne supportent pas les caches et peuvent planter…

    johnz

    • Messages : 192
    #132474

    j’ai un peu regardé mon proc et il s’agit bien d’un 68030 cadencé a 25 mhz

    pour en revenir a la commande sous whdload, c’est la commande burst qu’il faut taper?

    Voxel

    • Messages : 1400
    #132475

    essaie donc ça : dans ton shell tu tapes  » cpu fastrom cache burst  » si ça plante c’est que ton 030 est naze car l’option fastrom copie le kickstart en fast ram avec la MMU.

    johnz

    • Messages : 192
    #132476

    je vais voir ça

    johnz

    • Messages : 192
    #132477

    j ai tapé la command « hd0:>cpu fastrom cache burst » il n’y a pas eu de plantage mais une ligne mentionnant « system 68030 68882 FastRom (INST: Cache Burst) (DATA: Cache Burst)

    kezako?

    Brumiga

    • Messages : 754
    #132478

    @johnz,

    La commande cpu permet d’obtenir des informations sur le processeur, voir aussi sur le coprocesseur, présent dans ton amiga. L’option fastrom copie le contenu de celle-ci en mémoire vive, du coup les accès à la rom sont plus rapides. L’option cache active les caches processeur et l’option burst active le mode burst pour les instructions et les données. Si tu tapes « cpu check mmu » tu sauras enfin si ton processeur dispose ou non d’une mmu. Pour connaître toutes les options de la commande cpu présente dans ton os 3.x tape « cpu ? » dans un cli. Quand tu as trouvé tu peux ensuite insérer la ligne « cpu option1 option2 option3… >nil: » dans ta startup-sequence ou dans ton user-startup pour ne pas avoir à reconfigurer ton processeur, le « >nil: » évitera toute fenêtre de sortie de la part de la commande cpu.

    Attention, il est possible que certaines options que je peux obtenir sous morphos n’existent pas pour 68k.

    Brumiga

    JoeCoco

    • Messages : 11
    #132479

    salut,

    après avoir tapé la commande:

    cpu fastrom cache burst

    il est intéressant de voir que la MMU est utilisée (merci Sysinfo)

    johnz

    • Messages : 192
    #132480

    uep tout est activé apres sur sysinfo

11 sujets de 1 à 11 (sur un total de 11)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Matériel 68030 et usage du mmu

Amiga Impact