[TABLEAU] perf WinUAE

15 sujets de 1 à 15 (sur un total de 71)

  • Giants

    • Messages : 4171
    #362610

    Blup !

    Alors l’idée ici est faire un ou plusieurs tests avec des config Amiga standards.
    De lancer sysinfo et de recup plusieurs infos afin de crer un joli tableau qui sera partagé et mis jour.

    Il faut déjà que l’on se mette d’accord sur les confs amiga standard à tester via WinUAE.
    Ensuite, sera mis à dispo les fichiers .UAE correspondant.
    Ne sera pas inclus le kickstart, à vous de les avoir sachant que ne sera utiliser dans ces tests QUE les officiels.
    On prendra aussi une base commune de sysinfo que je mettrai aussi à dispo via une adf à charger pour faire le test sous WinUAE.

    Le but étant ici de récolter plusieurs chiffres et de monter un tableau par rapport aux conf testées ET le matériels PC de votre coté.

    Je propose déjà comme test de conf :
    – Amiga 1200 + Workbench 3.1 + Conf memoire standard Amiga, Option ‘Cycle-exact’

    Sera retenu et à donner comme valeur :
    – Votre conf PC :ex Intel Core I7-4790 @3.6Ghz
    – Ram dispo dans votre PC : ex 32Giga de ram
    – Version de Windows : ex Windows 10 x 64
    – Version de winUae : ex : 4.4.0 64b
    – Fichier de test de conf WinUAE : ex : A1200.uae
    – Version du kickstart utilisé.
    – Resultat de sysinfo (Dhrystone / Mips / Chip Speed vs A600)

    Si vous voyez d’autres trucs à ajouter et/ou changer avant de se lancer.
    NE FAITES PAS DE TEST de suite, cela ne sert à rien si on n’a pas mis les bases avants 🙂

    Tout sera mis à dispo Lien test WinUAE :

    Dernier Test : 18/11/2021 – 16h35
    Sysinfo

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne soyez pas pressé, la seul chose qui arrive rapidement, c'est les emmerdes.

    stephbb75

    • Messages : 193
    #362611

    Je vais voire a faire ce test…

    mikedafunk

    • Messages : 4415
    #362615

    On va se faire du mal! même sur un vieux pcul winuae explose nos machines en performances pures…
    Mais pour la synchronisation du son, les lags sur certains effets, la latence clavier/souris/manette, ça c’est autre chose…

    Lubuntu / eeepc - A1260/64 - Mon blog Mikedafunk

    Giants

    • Messages : 4171
    #362616

    Ajout de profils de test :
    Workbench 3.1 BASIC.uae
    A500.uae

    – PC : Core I7-4790 @3.6Ghz
    – RAM : 32Giga
    – Version de Windows : Windows 10 x 64
    – Version de winUae : ex : 4.4.0 64b
    – WinUae Conf : Workbench 3.1 BASIC.uae
    – Kickstart : 1483A091,KS ROM v3.1 (A1200)*
    – Dhrystones : 18951
    – Mips : 19.78 Mflops
    – ChipSpeed vs A600 : 28.98

    *regardé dans le fichier de conf uae <kickstart_rom_file_id>

    – PC : Core I7-4790 @3.6Ghz
    – RAM : 32Giga
    – Version de Windows : Windows 10 x 64
    – Version de winUae : ex : 4.4.0 64b
    – WinUae Conf : Workbench 3.1 BASIC.uae
    – Kickstart : C4F0F55F,KS ROM v1.3 (A500,A1000,A2000)
    – Dhrystones : 4432
    – Mips : 4.62 Mflops
    – ChipSpeed vs A600 : 9.17

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne soyez pas pressé, la seul chose qui arrive rapidement, c'est les emmerdes.

    Bwah Bwah

    • Messages : 234
    #362617

    C’est paradoxal d’activer le CE pour des tests de perfs ( au CPU j’entends ).

    Dans ce cas autant activer MMU par défaut ( pliage de WinUae garanti :p ) Mais les tests seront biaisés ( excepté si une solution PiStorm en dispose par défaut ).

    Il faudrait définir exactement ce qui doit être comparé.

    Et ces nouvelles solutions, elles fonctionnent comment ? Un emu 68xxx + JIT, autre chose ?

    Giants

    • Messages : 4171
    #362619

    Ce thread n’a pas du tout le but de faire une comparaison avec une solution hardware.
    Le but est de voir comment se comporte WinUae sur différent configuration de PC.
    Mais comme dit dés le départ, si tu as mieux à proposer comme fichier de conf, va y.
    Je suis preneur de toute idée.

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne soyez pas pressé, la seul chose qui arrive rapidement, c'est les emmerdes.

    Bwah Bwah

    • Messages : 234
    #362625

    Le cycle cpu ne sert qu’à ralentir pour coller aux vraies machines ( 500 ou 1200 ). Ce n’est pas utile, nous allons tous avoir des résultats similaires. De la 4 ailes à la F1.

    La preuve ( ce n’est que pour l’exemple, à ne pas prendre en compte pour l’heure ) :

    Prenons ta 1ère configuration Workbench 3.1 basic. Voici mes résultats :

    Dhrystones : 3763
    Mips : 3.92 Mflops

    Sur un Core2Duo à 2Ghz-4Go ram-Windows 8-WinUae 4.4.

    A mon avis, une bonne base de comparaison serait :

    De 68030 à 060 + FPU en softfloat +MMU ( sous WB et avec les bonnes librairies ). Cycle CPU ( quoique pour ce qui est au dessus du 030 cela n’a plus trop de sens ) + Cycle Chipset + RAM. Et si on veut pousser le vice, on monte le cycle à 28 Mhz.

    Sous ces conditions les différences seront manifestes entre les machines les plus faibles et les autres.

    Giants

    • Messages : 4171
    #362628

    Ok : pour CycleExtact à desactiver

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne soyez pas pressé, la seul chose qui arrive rapidement, c'est les emmerdes.

    Bwah Bwah

    • Messages : 234
    #362631

    Je n’ai plus le temps ce soir ( et je suis sur autre chose ), je ferai une ou deux configurations demain.

    __sam__

    • Messages : 3013
    #362635

    Perso j’activais toujours le JIT (je fais de la compile et c’est jamais assez rapide). Mais depuis les dernières mises à jour de « Amiga Forever »(*), le jit accélère les interruptions timer. Résultat: utilities/clock du WB avance 3 ou 4 fois trop vite, et le clavier déconne complètement. On est obligé de désactiver le « Fastest Possible » et revenir au « cycle exact » pour avoir une machine qui ne déconne pas trop. Mais du coup le JIT ne sert plus à rien.
    ____
    (*) ou alors j’ai pété un truc dans la config et je ne sais pas quoi…

    Samuel.

    Amiga A500 + GVP530 (8Mo/fpu/mmu/scsi) - en panne 🙁
    A500 (+ 1Mo PPS), A1200 (Blizzard-IV/fpu/64Mo)
    A500 Vampire V2+ ^8^ 🙂
    (mais aussi TO8, TO8D, TO9. Groupe PULS.)

    stephbb75

    • Messages : 193
    #362636

    Salut,

    Test de Giants A500.uae

    On vas tous avoir a peut pert le même résultat 😉

    J’ai vite fait un fichier config (patate), avec 68030, 68882, JIT, (c’est lui qui vas vraiment utiliser le potentielle de la machine hôte) …. et la disquette Sysinfo

    Peut pas mettre mon fichier config uae 🙁

    Bien sur on pourrais encore affiner pour quelques Mips en plus 😉

    Ma config :
    – PC : Core I5-2300 2.80Ghz
    – RAM : 8Giga
    – Version de Windows : Windows 10 x 64
    – Version de winUae : ex : 4.4.0 64b
    – WinUae Conf : patate.uae
    – Kickstart : 1483A091,KS ROM v3.1 (A1200)*
    – Dhrystones : 1960304
    – Mips : 2046 Mflops
    – MFlops : 52.24
    – ChipSpeed vs A600 : 27402

    Steph

    Giants

    • Messages : 4171
    #362644

    @Bwah Bwah : Pas de conf ‘exotique’, sert à rien.
    Yep, fait nous deux conf bien gonflé au niveau CPU tout en restant cohérent.
    Le but je le rappel est de voir comment se comporte WinUae.
    Processeur sur la carte mere / conf WinUAE


    @stephbb75
    : Salut !
    #On vas tous avoir a peut pert le même résultat.
    Ba le but c’est de ne pas avoir le même résultat avec des proc différent.
    Si on a le même résultat c’est que la conf que l’on utilise de WinUae n’est pas ‘bonne’ pour ce test.
    D’où le ‘chantier’ en amont pour que l’on se mette d’accord sur LA ou LES quelques conf à tester (et tjrs en restant ‘réaliste’, pas de conf chelou exotique qui n’existe QUE sur WinUAE).

    Je regarde ton mail tout à l’heure, j’ai un truc à faire ce matin.

    Région : Yvelines
    Site : http://sasfepu78.ddns.net/
    H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
    http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
    Dicton du jour : Ne soyez pas pressé, la seul chose qui arrive rapidement, c'est les emmerdes.

    Bwah Bwah

    • Messages : 234
    #362646

    Alors, comme une image sera plus révélatrice qu’un long discours, voici le  » simple  » résultat sur une ému 040 standard sur le même portable décrit plus haut en guise de nouvel exemple. Ce n’est plus du tout la même musique.

    Et ce ne sont pas des configurations exotiques, pour rappel un simple 030 ( non EC ) a une MMU d’intégrée d’origine + un cache de données. Un 040 peut monter à au moins 25Mhz. En version standard, il dispose des FPU/MMU.

    Je n’ai pas le temps de développer. Ni d’expliquer pourquoi le cycle cpu n’est pas forcément une bonne idée avec des 040+.

    Après, pour des perfs  » brutes  » c’est le JIT. Mais il n’y a alors plus rien de  » réaliste  » par rapport à une vraie machine. Là on part dans du  » à fond les gamelles et aux chiottes une partie de la compatibilité « . 😀

    Attachments:

    Bwah Bwah

    • Messages : 234
    #362649

    Voici donc 2 configurations au 040. Une au cycle, l’autre en Fastest. Sans JIT.

    Les tests doivent se réaliser sous WB avec les bonnes librairies ( mmulib sur Aminet ). En roms et WB 3.1. Dernière version de

  • https://aminet.net/package/util/moni/SysInfo
  • C’est une très bonne idée ce comparatif mais un protocole est impératif pour ne pas biaiser les résultats.

    Giants gèrera donc la suite pour ce faire et décider du protocole à mettre en place. Ce que j’ai écrit au dessus n’est qu’une idée de base sur laquelle s’appuyer ( ou pas ). 😀

    Ma  » contribution  » s’arrête donc là pour aujourd’hui.

    Attachments:

Giants

  • Messages : 4171
#362653

Impec, merchi.
J’ai copié ça sur mon site (voir lien au début).
L’image ADF de sysinfo à été mise à jour aussi. (au cas ou)
J’ai aussi copié le MMULIB.lha

Donc recap pour ces tests :
– 040-MMU-Cycle.uae *
– 040-MMU-Fastest.uae *
– A500.uae (a voir si on le garde…)
– Patate.uae

* Les tests doivent se réaliser sous WB 3.1 et kickstart 3.1 pour rester dans les clous avec les bonnes librairies mmulib.**
**(mmulib sur Aminet) ou fichier MMULib.lha sur mon site (c’est le même).

Les fichiers UAE sont à copier dans le directory de conf de votre WinUAE (voir section Paths dans celui-ci), normalement : C:\Users\Public\Documents\Amiga Files\WinUAE\

L’adf est à chargé normalement via WinUAE
Pour les deux tests specifique avec la lib qui va bien, transfert simple.
Vous copier le LHA dans un répertoire sur votre DD PC.
Vous charger la conf désirée de test.
Vous faites un <Add Directory or archive> dans la section HardDrive de WinUAE en pointant vers votre repertoire sur le PC qui contient l’archive MMUib.lha
Vous decompresser (soit sur amiga soit via votre PC avant) et vous installer la lib.
Vous lancer le test.

Région : Yvelines
Site : http://sasfepu78.ddns.net/
H/W : Bartop, borne d'arcade, Amiga500 x 3, Atari STF, Amstrad, etc, etc
http://www.retrotaku.com/parution-retro-gaming/interview-de-giants-fondateur-du-site-abandonpub-com/
Dicton du jour : Ne soyez pas pressé, la seul chose qui arrive rapidement, c'est les emmerdes.

15 sujets de 1 à 15 (sur un total de 71)

  • Vous devez être connecté pour répondre à ce sujet.

Forums AmigaOS, MorphOS et AROS Émulation et autres OS [TABLEAU] perf WinUAE

Amiga Impact