| Amiga Impact

  · Accueil
  · Actualités
   · Proposer une info
  · Agenda
   · Proposer une date
  · Articles
  · Forum
  · Petites Annonces
  · Chat IRC
  · À propos du site



 | Connexion

Identifiant :

Mot de passe :

 Mémoriser

  · Inscription
  · Mot de passe oublié



 | En ligne

Illustration du profil de HamsterManiac Illustration du profil de darkmiky Illustration du profil de sayasupacrew Illustration du profil de EdVirus Illustration du profil de widow88 Illustration du profil de Lion Illustration du profil de number-one Illustration du profil de Alexandre JALON




 | Nous suivre

Flux RSSGoogle+TwitterFacebook





Actualités


   E-UAE 0.8.28-RC2
   | 13 août 2005 | Logiciels,

uae

Richard Drummond vient de rendre disponible E-UAE 0.8.28 RC2.
Presque toutes les versions sont disponibles (Linux PPC, Linux x86, Mac OS…) sauf AROS, MorphOS et AmigaOS4-non SDL.

Les principaux apports sont :

  • noyaux d’émulation amélioré suivant WinUAE 1.0,
  • émulation 68k interprétive améliorée avec un gain de 30%,
  • corrections pour une compilation avec Gcc 4.0,
  • correction d’un bug du système de fichier virtuel qui faisait planter IBrowse,
  • amélioration de l’émulation bsdsocket,
  • meilleur support des modes écran par les drivers SDL.

La liste complète des améliorations suivant les plateformes est disponible dans le Readme.

Télécharger :




Les commentaires appartiennent à leurs auteurs.
Nous ne sommes pas responsables de leur contenu.


Auteur Conversation
Merlin Posté le 13 août 2005



Avec cette nouvelle version j’ai re-tenté E-UAE.

J’ai picasso96-uaegfx installé sur ma partition ou se trouve AOS3.9. (3.9 récupéré de mon 1240)
pourtant dans ScreenMode seul les mode PAL: apparaissent et dans P96settings, je n’ai pas de board « UAEgfx »

Un conseil ?



Fab1 Posté le 14 août 2005



Pour les versions Morphos, vous pouvez essayer :

http://fabportnawak.free.fr/uae/uae-0.8.28-RC2.lha

Deux versions sont incluses : la version sdl avec support P96, et une version hybride (son/joypad sdl et gfx natif) à laquelle j’ai ajouté le rendu overlay. Avec cette dernière, on gagne 20% de cpu, et on peut retailler la fenêtre via le hardware.

voila.



serge Posté le 14 août 2005



@ Merlin :

Je pense que tu n’as pas activé l’émulation de P96 dans ton fichier de
config.

Calque toi sur le mien . ici ca marche bien 😉

kickstart_rom_file=kick30.rom
filesystem=rw,workbench:data:workbench
filesystem=rw,HD-Games:data:HD-Games
filesystem=rw,Applications:data:Applications
immediate_blits=no
cpu_type=68020
gfx_width=1024
gfx_height=768
gfx_linemode=double
gfx_center_horizontal=smart
gfx_center_vertical=smart
gfx_fullscreen_amiga=yes
gfx_fullscreen_picasso=yes
z3mem_size=32
gfxcard_size=4
cpu_speed=1
#sound_output=none
chipset=aga
#gfx_vsync=true



ACE Posté le 14 août 2005



comme tu tabasse fab 🙂
c trop fort

Merli, edite .uaerc et ajoute gfxcard_size=4



Merlin Posté le 14 août 2005



@serge

c’était bien ça. Ca marche maintenant.
Bon maintenant je pourais dire que j’ai réussi à faire tourner E-UAE sur mon µA1, paske la vitesse, c’est vraiment pas ça…
J’ai même l’impression que mon 1240 est plus réactif



Fab1 Posté le 14 août 2005



Ton 1240 est très certainement plus réactif, à part peut être au niveau gfx sous p96.

e-uae sur un g4 1GHz, ça doit émuler qqch de l’ordre d’un 68030 25MHz, et encore, si le chipset est pas trop utilisé.



Daff Posté le 14 août 2005



J’ai un soucis avec la version overlay : je n’arrive pas à passer du mode fenêtré / mode écran. C’est bien Shift+CRTL+Alt+S ?

Sinon, les deux versions ici mettent un temps fou pour charger le WB. La version CVS compilé par Fab1 il y a quelques jours lance mon WB en quelques secondes seulement alors que ces nouvelles version d’E-UAE mettent 3 fois plus de temps.



Fab1 Posté le 14 août 2005



daff: la version amigaos ne supporte pas (encore) le changement à la volée.

Pour les accès disque, j’ai pas noté de différence ici (aiab r8 boote en 5s), mais j’ai lu sur aw.net que drummond avait expérimenté des threads pour les i/o et que ça donnait pas de bons résultats sur os4, et sur mos aussi, apparemment, pour toi. Je peux désactiver ça, d’ailleurs.

[edit]
voila qui est fait, les accès devraient mieux aller :
http://fabportnawak.free.fr/uae/uae-0.8.28-RC2.1.lha
[/edit]



pulp Posté le 15 août 2005



EUAE sur un G4 1GHz ca serait l’équivalent que d’un 68030 ?

Je sais qu’on peut pas comparer avec winuae, (c’est sans doute moins optimisé), mais quand même je trouves ca décevant.

De toute façon ça reste de l’émulation et winuae a beau aller trés vite et être bien foutu, je m’éclate plus avec mon vrai 1200 68030 sous AGA…



ACE Posté le 15 août 2005



hmmm c’esp decevant c bien ca sert a quoi d’emuler + qu’un 030 ? winuae n’est pas optimise il possede un Jit c’est tout, est le proc qui le fais tourner n’est pas un g4 1ghz c’est souvent un x86 a 2 ou 3 ghz.
sur un p3 800 sans le jit c pas si genial.



serge Posté le 15 août 2005



Fab:
Ta version MorphOS 20% plus rapide est trop géniale.
Mon jeux de référence qui n’a jamais fonctionné correctement avec UAE
 » JimPower » est maintenant fluide et le son ne hachure plus.
Ce jeux est bourré de je ne sais quelle technique pour faire plein de
plans et ca ramait du cul a fond sur tout saufe winuae avec un P4. Que
puisje te dire de plus si ce n’est UN GRAND MERCI.
PS: j’ai fini par lire ton post sur Morphzone et comprendre que le F12 était remplacé
par ctrl+alt.

C’est génial, elle est trop belle la vie 😉



Daff Posté le 15 août 2005



Fab1: le chargement du WB est de nouveau rapide, merci 😉



logo Posté le 15 août 2005



J’ai un soucis avec la version overlay : je n’arrive pas à passer du mode fenêtré / mode écran. C’est bien Shift+CRTL+Alt+S ?

Chez moi, ça marche.

En revanche, pourquoi les arguments en ligne de commande « joy 0 » pour avoir un joystick et « -H 2 » pour ouvrir un requester pour choisir la résolution, ne fonctionnent-ils plus ?



mahen Posté le 15 août 2005



La dernière build de fab avec overlay et accès disques rapide est la première version de UAE sous MOS que je juge vraiment agréable à utiliser. Hop, pour la première fois, ça va dans mon polynet 🙂



Fab1 Posté le 15 août 2005



logo,

je présume que tu utilises la version sdl si le switch d’écran marche.
Sinon, pour les arguments en ligne de commande, ça peut changer un peu de comportement selon que tu utilises la version sdl ou non. Je te conseille vivement d’utiliser les fichiers de config. Par exemple pour demander un mode d’écran (ça ne marche pas sous la version sdl il me semble), il faut faire amiga.screen_type=ask



logo Posté le 15 août 2005



Merci pour ta réponse, effectivement j’utilise la version SDL.
Pour le fichier config, il faut lui donner un nom précis qu’il va chercher par défaut ou mettre le nom du fichier en argument, parce que la dernière fois que j’avais essayé, il ne voulait pas le prendre ?



Fab1 Posté le 15 août 2005



log,

.uaerc par défaut, sinon tu fais uae -f truc.conf



serge Posté le 17 août 2005



Fab,

Que faut il dans le fichier de config pour emuler une CD32 ? please.
Ici, j’ai réutilisé les roms que j’utilise sur winuae , mais seul le
kickstart 3.1se lance.
Je n’ai pas l’interface de la CD32 avec son beau CD qui tourne.



Fab1 Posté le 17 août 2005



Il faut un kickstart « ext » pour la cd32, « extended rom ». Passe sur irc à l’occasion, je te filerai une config pour la cd32.

J’ai pu tester qu’une chose pour le moment : le player cd de la cd32, mais ça marche. Cela dit l’émul cd32 est assez lente (pour le moment), parait-il.








Haut de page 

Copyright © 2004-2017 Amiga Impact. Tous droits réservés. Les marques citées sont déposées par leurs propriétaires respectifs.
Conditions d'Utilisation, Politique de Confidentialité et Information sur les cookies.


Fil RSS WordPressNicolas Gressard, Conseil et développement informatique

Do NOT follow this link or you will be banned from the site!